aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-06-15 07:32:44 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-06-15 09:12:42 +0000
commit2575860321358416200b2bbac6d9f828dab13ca0 (patch)
tree52f5ad2d8621a731e2e1b42ea8c222c250f9e452
parent13b2de30d383e4674c7a8805660b044948117898 (diff)
www/cpp-httplib: update 0.15.3 → 0.16.0
-rw-r--r--www/cpp-httplib/Makefile3
-rw-r--r--www/cpp-httplib/distinfo6
-rw-r--r--www/cpp-httplib/files/patch-test_Makefile10
3 files changed, 10 insertions, 9 deletions
diff --git a/www/cpp-httplib/Makefile b/www/cpp-httplib/Makefile
index 3e0716280dc6..908dab3df798 100644
--- a/www/cpp-httplib/Makefile
+++ b/www/cpp-httplib/Makefile
@@ -1,6 +1,6 @@
PORTNAME= cpp-httplib
DISTVERSIONPREFIX= v
-DISTVERSION= 0.15.3
+DISTVERSION= 0.16.0
CATEGORIES= www devel
MAINTAINER= yuri@FreeBSD.org
@@ -27,6 +27,7 @@ BINARY_ALIAS= python3=${PYTHON_CMD} # only for tests
PLIST_FILES= include/httplib.h \
lib/cmake/httplib/FindBrotli.cmake \
+ share/doc/httplib/README.md \
lib/cmake/httplib/httplibConfig.cmake \
lib/cmake/httplib/httplibConfigVersion.cmake \
lib/cmake/httplib/httplibTargets.cmake
diff --git a/www/cpp-httplib/distinfo b/www/cpp-httplib/distinfo
index 80338b2a7fdf..2187ebc5bb34 100644
--- a/www/cpp-httplib/distinfo
+++ b/www/cpp-httplib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1708882457
-SHA256 (yhirose-cpp-httplib-v0.15.3_GH0.tar.gz) = 2121bbf38871bb2aafb5f7f2b9b94705366170909f434428352187cb0216124e
-SIZE (yhirose-cpp-httplib-v0.15.3_GH0.tar.gz) = 1151398
+TIMESTAMP = 1718410552
+SHA256 (yhirose-cpp-httplib-v0.16.0_GH0.tar.gz) = c125022eb85eaa12235518dc4638be93b62c3216d0f87b655af7b17b71b38851
+SIZE (yhirose-cpp-httplib-v0.16.0_GH0.tar.gz) = 1156790
diff --git a/www/cpp-httplib/files/patch-test_Makefile b/www/cpp-httplib/files/patch-test_Makefile
index 20dc22f42036..4088a49ddb46 100644
--- a/www/cpp-httplib/files/patch-test_Makefile
+++ b/www/cpp-httplib/files/patch-test_Makefile
@@ -1,13 +1,13 @@
---- test/Makefile.orig 2022-06-07 13:52:08 UTC
+--- test/Makefile.orig 2024-06-11 22:20:47 UTC
+++ test/Makefile
-@@ -1,5 +1,5 @@
+@@ -1,5 +1,5 @@ CXX = clang++
CXX = clang++
-CXXFLAGS = -g -std=c++11 -I. -Wall -Wextra -Wtype-limits -Wconversion -Wshadow # -fno-exceptions -DCPPHTTPLIB_NO_EXCEPTIONS -fsanitize=address
+CXXFLAGS += -g -std=c++11 -I. -Wall -Wextra -Wtype-limits -Wconversion -Wshadow # -fno-exceptions -DCPPHTTPLIB_NO_EXCEPTIONS -fsanitize=address
- PREFIX = /usr/local
- #PREFIX = $(shell brew --prefix)
-@@ -30,15 +30,15 @@ proxy : test_proxy
+ PREFIX ?= $(shell brew --prefix)
+
+@@ -35,15 +35,15 @@ test : test.cc include_httplib.cc ../httplib.h Makefil
./test_proxy
test : test.cc include_httplib.cc ../httplib.h Makefile cert.pem