aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-19 15:46:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-19 15:46:31 +0000
commit25c2ed5e97397b15921a99cf126426a7b13d445a (patch)
tree9bb777b762a281ac9173619fdf82aa37a399525b
parentf42c11f6fdba313fa1924b2e0e728fa4c8fc1520 (diff)
downloadports-25c2ed5e97397b15921a99cf126426a7b13d445a.tar.gz
ports-25c2ed5e97397b15921a99cf126426a7b13d445a.zip
Update to 1.15.0
- While I'm here: - Fix shebang - Fix and sort PLIST - Regenerate patch files with makepatch: Changes: https://theforeman.org/manuals/1.15/index.html#release-notes-for-115 PR: 219329 Submitted by: Frank Wall <fw@moov.de>
Notes
Notes: svn path=/head/; revision=441245
-rw-r--r--net/foreman-proxy/Makefile36
-rw-r--r--net/foreman-proxy/distinfo6
-rw-r--r--net/foreman-proxy/files/patch-bin-smart-proxy6
-rw-r--r--net/foreman-proxy/files/patch-config-settings.d-puppetca.yml.example4
-rw-r--r--net/foreman-proxy/files/patch-config-settings.d-realm.yml.example11
-rw-r--r--net/foreman-proxy/files/patch-config-settings.d-realm_freeipa.yml.example13
-rw-r--r--net/foreman-proxy/files/patch-config-settings.d-tftp.yml.example4
-rw-r--r--net/foreman-proxy/files/patch-config-settings.yml.example4
-rw-r--r--net/foreman-proxy/files/patch-lib_proxy_http__download.rb2
-rw-r--r--net/foreman-proxy/pkg-plist54
10 files changed, 84 insertions, 56 deletions
diff --git a/net/foreman-proxy/Makefile b/net/foreman-proxy/Makefile
index bebc72c41bfe..34a80a42b179 100644
--- a/net/foreman-proxy/Makefile
+++ b/net/foreman-proxy/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= foreman-proxy
-PORTVERSION= 1.12.2
-PORTREVISION= 2
+PORTVERSION= 1.15.0
CATEGORIES= net
MASTER_SITES= http://downloads.theforeman.org/foreman-proxy/
@@ -15,19 +14,20 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-bundler_ext>=0.4:sysutils/rubygem-bundler_ext \
rubygem-json>=1.8.1:devel/rubygem-json \
- rubygem-rack16>=1.4:www/rubygem-rack16 \
- rubygem-sinatra1>=1.4.3:www/rubygem-sinatra1 \
+ rubygem-rack>=2.0:www/rubygem-rack \
+ rubygem-rb-kqueue>=0.2.2:devel/rubygem-rb-kqueue \
+ rubygem-sinatra>=2.0:www/rubygem-sinatra \
wget:ftp/wget
OPTIONS_DEFINE= BMC PUPPET4
BMC_DESC= Depend on rubyipmi for BMC support
PUPPET4_DESC= Depend on Puppet 4
-USES= tar:bzip2
-USE_RUBY= yes
-USE_RC_SUBR= foreman-proxy
-NO_BUILD= yes
NO_ARCH= yes
+NO_BUILD= yes
+USE_RC_SUBR= foreman-proxy
+USE_RUBY= yes
+USES= shebangfix tar:bzip2
FOREMAN_PROXY_USER?= foreman_proxy
FOREMAN_PROXY_GROUP?= foreman_proxy
@@ -45,6 +45,8 @@ SUB_LIST= RUBY="${RUBY}" \
PLIST_SUB= ${SUB_LIST} MKDIR="${MKDIR}"
+SHEBANG_FILES= extra/foreman-debug-proxy
+
BMC_RUN_DEPENDS= rubygem-rubyipmi>=0.10.0:sysutils/rubygem-rubyipmi
PUPPET4_RUN_DEPENDS= puppet:sysutils/puppet4 \
rubygem-ruby-augeas>=0.5:textproc/rubygem-ruby-augeas
@@ -57,7 +59,8 @@ post-patch:
-e "s|%%DATADIR%%|${DATADIR}|g" \
${WRKSRC}/bin/smart-proxy \
${WRKSRC}/extra/migrate_settings.rb \
- ${WRKSRC}/extra/query.rb
+ ${WRKSRC}/extra/query.rb \
+ ${WRKSRC}/extra/register-service.rb
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
-e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
${WRKSRC}/config/settings.d/*.yml.example \
@@ -70,22 +73,23 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/bin/smart-proxy \
${STAGEDIR}${PREFIX}/sbin/smart-proxy
.for file in CHANGELOG Contributors Gemfile LICENSE README.md \
- VERSION bundler.d config.ru lib modules
+ smart_proxy.gemspec VERSION bundler.d config.ru lib modules
${CP} -r ${WRKSRC}/${file} ${STAGEDIR}${DATADIR}
.endfor
${LN} -s Gemfile ${STAGEDIR}${DATADIR}/Gemfile.in
-.for script in migrate_settings.rb query.rb
+.for script in foreman-debug-proxy migrate_settings.rb query.rb register-service.rb
${INSTALL_SCRIPT} ${WRKSRC}/extra/${script} \
${STAGEDIR}${DATADIR}/extra/${script}
.endfor
${CP} -r ${WRKSRC}/extra/migrations ${STAGEDIR}${DATADIR}/extra
${INSTALL_DATA} ${WRKSRC}/config/settings.yml.example \
${STAGEDIR}${PREFIX}/etc/foreman-proxy/settings.yml.sample
-.for cfg in bmc dhcp dhcp_isc dhcp_libvirt dhcp_ms_native dns dns_dnscmd \
- dns_libvirt dns_nsupdate dns_nsupdate dns_nsupdate_gss \
- facts logs puppet puppet_proxy_customrun puppet_proxy_legacy \
- puppet_proxy_mcollective puppet_proxy_puppet_api puppet_proxy_puppetrun \
- puppet_proxy_salt puppet_proxy_ssh puppetca realm templates tftp
+.for cfg in bmc dhcp_isc dhcp_libvirt dhcp_native_ms dhcp dns_dnscmd \
+ dns_libvirt dns_nsupdate_gss dns_nsupdate dns facts logs \
+ puppet_proxy_customrun puppet_proxy_legacy \
+ puppet_proxy_mcollective puppet_proxy_puppet_api \
+ puppet_proxy_puppetrun puppet_proxy_salt puppet_proxy_ssh puppet \
+ puppetca realm templates tftp
${INSTALL_DATA} ${WRKSRC}/config/settings.d/${cfg}.yml.example \
${STAGEDIR}${PREFIX}/etc/foreman-proxy/settings.d/${cfg}.yml.sample
.endfor
diff --git a/net/foreman-proxy/distinfo b/net/foreman-proxy/distinfo
index b86a7f313837..7fc7d74733f6 100644
--- a/net/foreman-proxy/distinfo
+++ b/net/foreman-proxy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1473110479
-SHA256 (foreman-proxy-1.12.2.tar.bz2) = 7d1c807da404a413c47c3931bbad1189aa1c643017ffad7d6a23f69a5d9a7735
-SIZE (foreman-proxy-1.12.2.tar.bz2) = 141089
+TIMESTAMP = 1495117029
+SHA256 (foreman-proxy-1.15.0.tar.bz2) = 122d77bb6ecf836ef00766cb40f10c0153f801884a35ccd38eaa2d917f542fbf
+SIZE (foreman-proxy-1.15.0.tar.bz2) = 158637
diff --git a/net/foreman-proxy/files/patch-bin-smart-proxy b/net/foreman-proxy/files/patch-bin-smart-proxy
index 167ba1b59a3f..d85df17df24c 100644
--- a/net/foreman-proxy/files/patch-bin-smart-proxy
+++ b/net/foreman-proxy/files/patch-bin-smart-proxy
@@ -1,10 +1,10 @@
---- bin/smart-proxy.orig 2014-12-04 11:24:23.964747068 +0100
-+++ bin/smart-proxy 2014-12-04 11:24:26.244762141 +0100
+--- bin/smart-proxy.orig 2017-05-08 15:18:42 UTC
++++ bin/smart-proxy
@@ -1,6 +1,7 @@
#!/usr/bin/env ruby
$LOAD_PATH.unshift(*Dir[File.expand_path("../../lib", __FILE__), File.expand_path("../../modules", __FILE__)])
+$LOAD_PATH.unshift(*Dir["%%DATADIR%%/lib", "%%DATADIR%%/modules"])
- require 'smart_proxy'
+ require 'smart_proxy_main'
Proxy::Launcher.new.launch
diff --git a/net/foreman-proxy/files/patch-config-settings.d-puppetca.yml.example b/net/foreman-proxy/files/patch-config-settings.d-puppetca.yml.example
index c00278e90590..78544b2d4bf3 100644
--- a/net/foreman-proxy/files/patch-config-settings.d-puppetca.yml.example
+++ b/net/foreman-proxy/files/patch-config-settings.d-puppetca.yml.example
@@ -1,5 +1,5 @@
---- config/settings.d/puppetca.yml.example.orig 2016-08-24 09:01:39.000000000 +0200
-+++ config/settings.d/puppetca.yml.example 2016-09-05 23:43:16.509994000 +0200
+--- config/settings.d/puppetca.yml.example.orig 2017-05-08 15:18:42 UTC
++++ config/settings.d/puppetca.yml.example
@@ -2,7 +2,7 @@
# Can be true, false, or http/https to enable just one of the protocols
:enabled: false
diff --git a/net/foreman-proxy/files/patch-config-settings.d-realm.yml.example b/net/foreman-proxy/files/patch-config-settings.d-realm.yml.example
deleted file mode 100644
index a24cad590744..000000000000
--- a/net/foreman-proxy/files/patch-config-settings.d-realm.yml.example
+++ /dev/null
@@ -1,11 +0,0 @@
---- config/settings.d/realm.yml.example.orig 2016-08-24 09:01:39.000000000 +0200
-+++ config/settings.d/realm.yml.example 2016-09-05 23:44:35.005749000 +0200
-@@ -7,7 +7,7 @@
- #:realm_provider: freeipa
-
- # Authentication for Kerberos-based Realms
--:realm_keytab: /etc/foreman-proxy/freeipa.keytab
-+:realm_keytab: %%LOCALBASE%%/etc/foreman-proxy/freeipa.keytab
- :realm_principal: realm-proxy@EXAMPLE.COM
-
- # FreeIPA specific settings
diff --git a/net/foreman-proxy/files/patch-config-settings.d-realm_freeipa.yml.example b/net/foreman-proxy/files/patch-config-settings.d-realm_freeipa.yml.example
new file mode 100644
index 000000000000..2fe5f1da9cd5
--- /dev/null
+++ b/net/foreman-proxy/files/patch-config-settings.d-realm_freeipa.yml.example
@@ -0,0 +1,13 @@
+--- config/settings.d/realm_freeipa.yml.example.orig 2017-05-08 15:18:42 UTC
++++ config/settings.d/realm_freeipa.yml.example
+@@ -1,8 +1,8 @@
+ ---
+ # Authentication for Kerberos-based Realms
+-:keytab_path: /etc/foreman-proxy/freeipa.keytab
++:realm_keytab: %%LOCALBASE%%/etc/foreman-proxy/freeipa.keytab
+ :principal: realm-proxy@EXAMPLE.COM
+
+-:ipa_config: /etc/ipa/default.conf
++:ipa_config: %%LOCALBASE%%/etc/ipa/default.conf
+ # Remove from DNS when deleting the FreeIPA entry
+ :remove_dns: true
diff --git a/net/foreman-proxy/files/patch-config-settings.d-tftp.yml.example b/net/foreman-proxy/files/patch-config-settings.d-tftp.yml.example
index 0763e6d6a8ef..350598f0599c 100644
--- a/net/foreman-proxy/files/patch-config-settings.d-tftp.yml.example
+++ b/net/foreman-proxy/files/patch-config-settings.d-tftp.yml.example
@@ -1,5 +1,5 @@
---- config/settings.d/tftp.yml.example.orig 2016-08-24 09:01:39.000000000 +0200
-+++ config/settings.d/tftp.yml.example 2016-09-05 23:44:01.480711000 +0200
+--- config/settings.d/tftp.yml.example.orig 2017-05-08 15:18:42 UTC
++++ config/settings.d/tftp.yml.example
@@ -2,6 +2,6 @@
# Can be true, false, or http/https to enable just one of the protocols
:enabled: false
diff --git a/net/foreman-proxy/files/patch-config-settings.yml.example b/net/foreman-proxy/files/patch-config-settings.yml.example
index 2a23656a61f7..bf15c6366d0e 100644
--- a/net/foreman-proxy/files/patch-config-settings.yml.example
+++ b/net/foreman-proxy/files/patch-config-settings.yml.example
@@ -1,5 +1,5 @@
---- config/settings.yml.example.orig 2016-08-24 09:01:39.000000000 +0200
-+++ config/settings.yml.example 2016-09-05 23:33:49.472857000 +0200
+--- config/settings.yml.example.orig 2017-05-08 15:18:42 UTC
++++ config/settings.yml.example
@@ -38,7 +38,7 @@
#:foreman_ssl_key: ssl/private_keys/fqdn.pem
diff --git a/net/foreman-proxy/files/patch-lib_proxy_http__download.rb b/net/foreman-proxy/files/patch-lib_proxy_http__download.rb
index 75553d989f69..6c44f49c45a8 100644
--- a/net/foreman-proxy/files/patch-lib_proxy_http__download.rb
+++ b/net/foreman-proxy/files/patch-lib_proxy_http__download.rb
@@ -1,4 +1,4 @@
---- lib/proxy/http_download.rb.orig 2015-12-24 23:13:02 UTC
+--- lib/proxy/http_download.rb.orig 2017-05-08 15:18:42 UTC
+++ lib/proxy/http_download.rb
@@ -6,7 +6,7 @@ module Proxy
diff --git a/net/foreman-proxy/pkg-plist b/net/foreman-proxy/pkg-plist
index 931398464ea9..564d5645e32e 100644
--- a/net/foreman-proxy/pkg-plist
+++ b/net/foreman-proxy/pkg-plist
@@ -2,7 +2,7 @@
@sample %%ETCDIR%%/settings.d/dhcp.yml.sample
@sample %%ETCDIR%%/settings.d/dhcp_isc.yml.sample
@sample %%ETCDIR%%/settings.d/dhcp_libvirt.yml.sample
-@sample %%ETCDIR%%/settings.d/dhcp_ms_native.yml.sample
+@sample %%ETCDIR%%/settings.d/dhcp_native_ms.yml.sample
@sample %%ETCDIR%%/settings.d/dns.yml.sample
@sample %%ETCDIR%%/settings.d/dns_dnscmd.yml.sample
@sample %%ETCDIR%%/settings.d/dns_libvirt.yml.sample
@@ -33,20 +33,25 @@ sbin/smart-proxy
%%DATADIR%%/VERSION
%%DATADIR%%/bundler.d/bmc.rb
%%DATADIR%%/bundler.d/development.rb
+%%DATADIR%%/bundler.d/dhcp_isc.rb
%%DATADIR%%/bundler.d/krb5.rb
%%DATADIR%%/bundler.d/libvirt.rb
%%DATADIR%%/bundler.d/puppet.rb
+%%DATADIR%%/bundler.d/realm_freeipa.rb
%%DATADIR%%/bundler.d/test.rb
%%DATADIR%%/bundler.d/windows.rb
%%DATADIR%%/config
%%DATADIR%%/config.ru
+%%DATADIR%%/extra/foreman-debug-proxy
%%DATADIR%%/extra/migrate_settings.rb
%%DATADIR%%/extra/migrations/20150327000000_migrate_monolithic_config.rb
%%DATADIR%%/extra/migrations/20150611000000_migrate_dns_settings.rb
%%DATADIR%%/extra/migrations/20150826000000_migrate_dhcp_settings.rb
%%DATADIR%%/extra/migrations/20160411000000_migrate_libvirt_settings.rb
%%DATADIR%%/extra/migrations/20160413000000_migrate_puppet_settings.rb
+%%DATADIR%%/extra/migrations/20161209000000_migrate_realm_settings.rb
%%DATADIR%%/extra/query.rb
+%%DATADIR%%/extra/register-service.rb
%%DATADIR%%/lib/bundler_helper.rb
%%DATADIR%%/lib/checks.rb
%%DATADIR%%/lib/daemon.rb
@@ -58,8 +63,6 @@ sbin/smart-proxy
%%DATADIR%%/lib/proxy/file_lock.rb
%%DATADIR%%/lib/proxy/helpers.rb
%%DATADIR%%/lib/proxy/http_download.rb
-%%DATADIR%%/lib/proxy/http_download.rb.bak
-%%DATADIR%%/lib/proxy/http_download.rb.orig
%%DATADIR%%/lib/proxy/kerberos.rb
%%DATADIR%%/lib/proxy/log.rb
%%DATADIR%%/lib/proxy/log_buffer/buffer.rb
@@ -74,6 +77,7 @@ sbin/smart-proxy
%%DATADIR%%/lib/proxy/provider.rb
%%DATADIR%%/lib/proxy/provider_factory.rb
%%DATADIR%%/lib/proxy/request.rb
+%%DATADIR%%/lib/proxy/request_id_middleware.rb
%%DATADIR%%/lib/proxy/settings.rb
%%DATADIR%%/lib/proxy/settings/global.rb
%%DATADIR%%/lib/proxy/settings/plugin.rb
@@ -83,6 +87,7 @@ sbin/smart-proxy
%%DATADIR%%/lib/rack-patch.rb
%%DATADIR%%/lib/sinatra-patch.rb
%%DATADIR%%/lib/sinatra/authorization.rb
+%%DATADIR%%/lib/sinatra/default_not_found_page.rb
%%DATADIR%%/lib/smart_proxy.rb
%%DATADIR%%/lib/smart_proxy_for_testing.rb
%%DATADIR%%/lib/smart_proxy_main.rb
@@ -94,13 +99,18 @@ sbin/smart-proxy
%%DATADIR%%/modules/bmc/http_config.ru
%%DATADIR%%/modules/bmc/ipmi.rb
%%DATADIR%%/modules/bmc/shell.rb
+%%DATADIR%%/modules/bmc/ssh.rb
+%%DATADIR%%/modules/dhcp/configuration_loader.rb
+%%DATADIR%%/modules/dhcp/dependency_injection.rb
%%DATADIR%%/modules/dhcp/dhcp.rb
%%DATADIR%%/modules/dhcp/dhcp_api.rb
%%DATADIR%%/modules/dhcp/dhcp_plugin.rb
%%DATADIR%%/modules/dhcp/http_config.ru
-%%DATADIR%%/modules/dhcp_common/dependency_injection/container.rb
-%%DATADIR%%/modules/dhcp_common/dependency_injection/dependencies.rb
%%DATADIR%%/modules/dhcp_common/dhcp_common.rb
+%%DATADIR%%/modules/dhcp_common/isc/configuration_file.rb
+%%DATADIR%%/modules/dhcp_common/isc/file_parser.rb
+%%DATADIR%%/modules/dhcp_common/isc/omapi_provider.rb
+%%DATADIR%%/modules/dhcp_common/isc/subnet_service_initialization.rb
%%DATADIR%%/modules/dhcp_common/monkey_patch_subnet.rb
%%DATADIR%%/modules/dhcp_common/monkey_patches.rb
%%DATADIR%%/modules/dhcp_common/record.rb
@@ -110,43 +120,48 @@ sbin/smart-proxy
%%DATADIR%%/modules/dhcp_common/server.rb
%%DATADIR%%/modules/dhcp_common/subnet.rb
%%DATADIR%%/modules/dhcp_common/subnet_service.rb
-%%DATADIR%%/modules/dhcp_isc/dependencies.rb
+%%DATADIR%%/modules/dhcp_isc/configuration_loader.rb
%%DATADIR%%/modules/dhcp_isc/dhcp_isc.rb
-%%DATADIR%%/modules/dhcp_isc/dhcp_isc_main.rb
%%DATADIR%%/modules/dhcp_isc/dhcp_isc_plugin.rb
-%%DATADIR%%/modules/dhcp_libvirt/dependencies.rb
+%%DATADIR%%/modules/dhcp_isc/inotify_leases_file_observer.rb
+%%DATADIR%%/modules/dhcp_isc/isc_state_changes_observer.rb
+%%DATADIR%%/modules/dhcp_isc/kqueue_leases_file_observer.rb
+%%DATADIR%%/modules/dhcp_isc/leases_file.rb
+%%DATADIR%%/modules/dhcp_libvirt/configuration_loader.rb
%%DATADIR%%/modules/dhcp_libvirt/dhcp_libvirt.rb
%%DATADIR%%/modules/dhcp_libvirt/dhcp_libvirt_main.rb
%%DATADIR%%/modules/dhcp_libvirt/dhcp_libvirt_plugin.rb
%%DATADIR%%/modules/dhcp_libvirt/libvirt_dhcp_network.rb
-%%DATADIR%%/modules/dhcp_native_ms/dependencies.rb
+%%DATADIR%%/modules/dhcp_libvirt/subnet_service_initializer.rb
%%DATADIR%%/modules/dhcp_native_ms/dhcp_native_ms.rb
%%DATADIR%%/modules/dhcp_native_ms/dhcp_native_ms_main.rb
%%DATADIR%%/modules/dhcp_native_ms/dhcp_native_ms_plugin.rb
+%%DATADIR%%/modules/dhcp_native_ms/plugin_configuration.rb
+%%DATADIR%%/modules/dns/configuration_loader.rb
+%%DATADIR%%/modules/dns/dependency_injection.rb
%%DATADIR%%/modules/dns/dns.rb
%%DATADIR%%/modules/dns/dns_api.rb
%%DATADIR%%/modules/dns/dns_plugin.rb
%%DATADIR%%/modules/dns/http_config.ru
-%%DATADIR%%/modules/dns_common/dependency_injection/container.rb
%%DATADIR%%/modules/dns_common/dependency_injection/dependencies.rb
%%DATADIR%%/modules/dns_common/dns_common.rb
-%%DATADIR%%/modules/dns_dnscmd/dependencies.rb
%%DATADIR%%/modules/dns_dnscmd/dns_dnscmd.rb
%%DATADIR%%/modules/dns_dnscmd/dns_dnscmd_main.rb
%%DATADIR%%/modules/dns_dnscmd/dns_dnscmd_plugin.rb
-%%DATADIR%%/modules/dns_libvirt/dependencies.rb
+%%DATADIR%%/modules/dns_dnscmd/plugin_configuration.rb
%%DATADIR%%/modules/dns_libvirt/dns_libvirt.rb
%%DATADIR%%/modules/dns_libvirt/dns_libvirt_main.rb
%%DATADIR%%/modules/dns_libvirt/dns_libvirt_plugin.rb
%%DATADIR%%/modules/dns_libvirt/libvirt_dns_network.rb
+%%DATADIR%%/modules/dns_libvirt/plugin_configuration.rb
%%DATADIR%%/modules/dns_nsupdate/dns_nsupdate.rb
%%DATADIR%%/modules/dns_nsupdate/dns_nsupdate_gss.rb
%%DATADIR%%/modules/dns_nsupdate/dns_nsupdate_gss_main.rb
%%DATADIR%%/modules/dns_nsupdate/dns_nsupdate_gss_plugin.rb
%%DATADIR%%/modules/dns_nsupdate/dns_nsupdate_main.rb
%%DATADIR%%/modules/dns_nsupdate/dns_nsupdate_plugin.rb
-%%DATADIR%%/modules/dns_nsupdate/nsupdate_dependencies.rb
-%%DATADIR%%/modules/dns_nsupdate/nsupdate_gss_dependencies.rb
+%%DATADIR%%/modules/dns_nsupdate/nsupdate_configuration.rb
+%%DATADIR%%/modules/dns_nsupdate/nsupdate_gss_configuration.rb
%%DATADIR%%/modules/facts/facts.rb
%%DATADIR%%/modules/facts/facts_api.rb
%%DATADIR%%/modules/facts/facts_plugin.rb
@@ -194,6 +209,7 @@ sbin/smart-proxy
%%DATADIR%%/modules/puppet_proxy_puppet_api/puppet_proxy_puppet_api_plugin.rb
%%DATADIR%%/modules/puppet_proxy_puppet_api/v3_api_request.rb
%%DATADIR%%/modules/puppet_proxy_puppet_api/v3_classes_retriever.rb
+%%DATADIR%%/modules/puppet_proxy_puppet_api/v3_environment_classes_api_classes_retriever.rb
%%DATADIR%%/modules/puppet_proxy_puppet_api/v3_environments_retriever.rb
%%DATADIR%%/modules/puppet_proxy_puppetrun/plugin_configuration.rb
%%DATADIR%%/modules/puppet_proxy_puppetrun/puppet_proxy_puppetrun.rb
@@ -212,12 +228,17 @@ sbin/smart-proxy
%%DATADIR%%/modules/puppetca/puppetca_api.rb
%%DATADIR%%/modules/puppetca/puppetca_main.rb
%%DATADIR%%/modules/puppetca/puppetca_plugin.rb
-%%DATADIR%%/modules/realm/client.rb
-%%DATADIR%%/modules/realm/freeipa.rb
+%%DATADIR%%/modules/realm/configuration_loader.rb
+%%DATADIR%%/modules/realm/dependency_injection.rb
%%DATADIR%%/modules/realm/http_config.ru
%%DATADIR%%/modules/realm/realm.rb
%%DATADIR%%/modules/realm/realm_api.rb
%%DATADIR%%/modules/realm/realm_plugin.rb
+%%DATADIR%%/modules/realm_freeipa/configuration_loader.rb
+%%DATADIR%%/modules/realm_freeipa/ipa_config_parser.rb
+%%DATADIR%%/modules/realm_freeipa/provider.rb
+%%DATADIR%%/modules/realm_freeipa/realm_freeipa.rb
+%%DATADIR%%/modules/realm_freeipa/realm_freeipa_plugin.rb
%%DATADIR%%/modules/root/http_config.ru
%%DATADIR%%/modules/root/root.rb
%%DATADIR%%/modules/root/root_api.rb
@@ -233,5 +254,6 @@ sbin/smart-proxy
%%DATADIR%%/modules/tftp/tftp.rb
%%DATADIR%%/modules/tftp/tftp_api.rb
%%DATADIR%%/modules/tftp/tftp_plugin.rb
+%%DATADIR%%/smart_proxy.gemspec
@dir(%%FOREMAN_PROXY_USER%%,%%FOREMAN_PROXY_GROUP%%,0700) %%FOREMAN_PROXY_LOGDIR%%
@dir(%%FOREMAN_PROXY_USER%%,%%FOREMAN_PROXY_GROUP%%,0700) %%FOREMAN_PROXY_RUNDIR%%