aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2022-09-16 17:27:03 +0000
committerBrooks Davis <brooks@FreeBSD.org>2022-09-16 17:28:52 +0000
commit25e93187069e74c4050dd39f1f38075a8b597b2c (patch)
treef9503a4fad46d305abd198cd4a44559737023da4
parent88a566688d921982c863db87684d1bbc75267394 (diff)
downloadports-25e93187069e74c4050dd39f1f38075a8b597b2c.tar.gz
ports-25e93187069e74c4050dd39f1f38075a8b597b2c.zip
devel/llvm-devel: fix name collision
Use _COMPILER_RT_LIBS rather than COMPILER_RT_LIBS for the list of library paths installed by the COMPILER_RT option. This worked because it was added after bsd.port.options.mk, but triggered a bsd.sanity.mk warning. PR: 266447
-rw-r--r--devel/llvm-devel/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 77b4d11bf92b..e9ae8881b277 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -131,7 +131,7 @@ CLANG_USE= PERL5=run
.endif
COMPILER_RT_DESC= Sanitizer libraries
COMPILER_RT_IMPLIES= CLANG
-COMPILER_RT_PLIST_FILES=${COMPILER_RT_LIBS} \
+COMPILER_RT_PLIST_FILES=${_COMPILER_RT_LIBS} \
${COMPILER_RT_IGNORELISTS:S|^|${_CRTBLDIR}/|}
DOCS_PORTDOCS= llvm
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx-markdown-tables>=0:textproc/py-sphinx-markdown-tables@${PY_FLAVOR} \
@@ -340,9 +340,9 @@ _CRTLIBDIR= ${_CRTBASEDIR}/lib
.include "Makefile.RUNTIMES"
-COMPILER_RT_LIBS=
+_COMPILER_RT_LIBS=
.for CRT_ARCH in ${COMPILER_RT_ARCHS}
-COMPILER_RT_LIBS:= ${COMPILER_RT_LIBS} ${COMPILER_RT_LIBS_${CRT_ARCH}:S|^|${_CRTLIBDIR}/${CRT_ARCH}-portbld-${OPSYS:tl}${OSREL}/|}
+_COMPILER_RT_LIBS:= ${_COMPILER_RT_LIBS} ${COMPILER_RT_LIBS_${CRT_ARCH}:S|^|${_CRTLIBDIR}/${CRT_ARCH}-portbld-${OPSYS:tl}${OSREL}/|}
.endfor
# Comment out plist entries for unsupported options.