aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-02-05 17:00:19 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-02-05 17:00:19 +0000
commit2618408147fe1be510302fdfcccbb7f9944cf154 (patch)
treeed49d2f1ecc52818c21353b42f6115fbf0fad06c
parent7115b47749b8cb4118f266c5d14e85fe0ed0b803 (diff)
downloadports-2618408147fe1be510302fdfcccbb7f9944cf154.tar.gz
ports-2618408147fe1be510302fdfcccbb7f9944cf154.zip
- Enable stage support
- Strip binaries
Notes
Notes: svn path=/head/; revision=342779
-rw-r--r--security/pidentd/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/security/pidentd/Makefile b/security/pidentd/Makefile
index 47d77ccdd7e5..341b84a8d911 100644
--- a/security/pidentd/Makefile
+++ b/security/pidentd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pidentd
PORTVERSION= 3.0.19
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.lysator.liu.se/pub/unix/ident/servers/ \
ftp://ftp.stack.nl/pub/users/johans/pidentd/
@@ -14,31 +14,34 @@ PATCHFILES= pidentd-${PORTVERSION}-ipv6-20080101.diff.gz
PATCH_DIST_STRIP= -p0
MAINTAINER= johans@FreeBSD.org
-COMMENT= An RFC1413 identification server
+COMMENT= RFC1413 identification server
CONFLICTS_INSTALL= fakeident-[0-9]*
GNU_CONFIGURE= yes
USE_OPENSSL= yes
-MAN8= identd.8 idecrypt.8
-PLIST_FILES= sbin/ibench sbin/identd sbin/idecrypt sbin/ikeygen
+PLIST_FILES= sbin/ibench sbin/identd sbin/idecrypt sbin/ikeygen \
+ man/man8/identd.8.gz man/man8/idecrypt.8.gz
CFLAGS+= -DINCLUDE_CRYPT -DOPENSSL_DES_LIBDES_COMPATIBILITY
LDFLAGS+= -L${OPENSSLLIB} -lcrypto
-NO_STAGE= yes
post-extract:
${CP} ${FILESDIR}/idecrypt.8 ${WRKSRC}/doc/idecrypt.8
post-patch:
@${REINPLACE_CMD} \
- -e "s| /etc/identd.conf| ${PREFIX}/etc/identd.conf|" \
- -e "s| /etc/identd.key| ${PREFIX}/etc/identd.key|" \
+ -e 's| /etc/identd.conf| ${PREFIX}/etc/identd.conf|' \
+ -e 's| /etc/identd.key| ${PREFIX}/etc/identd.key|' \
${WRKSRC}/doc/identd.8 ${WRKSRC}/doc/idecrypt.8
- @${REINPLACE_CMD} -e "s|freebsd.4.7.|freebsd|" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|freebsd.4.7.|freebsd|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$(sbindir)|$${DESTDIR}&|' \
+ -e 's|-m 755|-s &|' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|$$(mandir)|$${DESTDIR}&|' ${WRKSRC}/Makefile.in
post-install:
- ${INSTALL_MAN} -m 644 ${WRKSRC}/doc/idecrypt.8 ${MANPREFIX}/man/man8
+ ${INSTALL_MAN} -m 644 ${WRKSRC}/doc/idecrypt.8 \
+ ${STAGEDIR}${MANPREFIX}/man/man8
.include <bsd.port.mk>