aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-04-02 09:17:40 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-04-02 09:17:40 +0000
commit262a4ce04157fae2f0d58abe940e2ddbdc6d3e63 (patch)
tree389cec837270743b7104dafd6ac3d2b0d1603df8
parent760206b91a4d71759a8d9f3f417a6bdda08923f9 (diff)
downloadports-262a4ce04157fae2f0d58abe940e2ddbdc6d3e63.tar.gz
ports-262a4ce04157fae2f0d58abe940e2ddbdc6d3e63.zip
graphics/goxel: update the port to version 0.12.0
Reported by: portscout
-rw-r--r--graphics/goxel/Makefile3
-rw-r--r--graphics/goxel/distinfo6
-rw-r--r--graphics/goxel/files/patch-SConstruct11
-rw-r--r--graphics/goxel/files/patch-ext__src_quickjs_quickjs-libc.c13
4 files changed, 17 insertions, 16 deletions
diff --git a/graphics/goxel/Makefile b/graphics/goxel/Makefile
index 7468a9da7edd..293f4e78d9d7 100644
--- a/graphics/goxel/Makefile
+++ b/graphics/goxel/Makefile
@@ -1,7 +1,6 @@
PORTNAME= goxel
-PORTVERSION= 0.11.0
+PORTVERSION= 0.12.0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= danfe@FreeBSD.org
diff --git a/graphics/goxel/distinfo b/graphics/goxel/distinfo
index 0bf33d32dba8..0bf9d3f90236 100644
--- a/graphics/goxel/distinfo
+++ b/graphics/goxel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1660638635
-SHA256 (guillaumechereau-goxel-v0.11.0_GH0.tar.gz) = 660030e1b3b33a3e909d8189780a192cba059774af57b042ecb63297f2a6d0fc
-SIZE (guillaumechereau-goxel-v0.11.0_GH0.tar.gz) = 2718621
+TIMESTAMP = 1680336268
+SHA256 (guillaumechereau-goxel-v0.12.0_GH0.tar.gz) = e3825625e1af9f58593695b0129e39f68a8f3c7d5696c096b8ed2d8b9ac69430
+SIZE (guillaumechereau-goxel-v0.12.0_GH0.tar.gz) = 3276773
diff --git a/graphics/goxel/files/patch-SConstruct b/graphics/goxel/files/patch-SConstruct
index 58485b0130ac..4c6f80575996 100644
--- a/graphics/goxel/files/patch-SConstruct
+++ b/graphics/goxel/files/patch-SConstruct
@@ -1,16 +1,5 @@
--- SConstruct.orig 2022-08-16 08:30:35 UTC
+++ SConstruct
-@@ -45,10 +45,6 @@ if os.environ.get('CC') == 'clang':
- if os.environ.get('CC') == 'clang':
- env.Replace(CC='clang', CXX='clang++')
-
--# Hack for gcc <= 5, since pragma diagnostic push doesn't seem to work.
--if env['CCVERSION'] and int(env['CCVERSION'].split('.')[0]) <= 5:
-- env.Append(CCFLAGS=['-Wno-unused-function'])
--
- # Asan & Ubsan (need to come first).
- if env['mode'] == 'debug' and target_os == 'posix':
- env.Append(CCFLAGS=['-fsanitize=address', '-fsanitize=undefined'],
@@ -70,7 +66,7 @@ if env['mode'] not in ['debug', 'analyze']:
env.Append(CCFLAGS='-Werror')
diff --git a/graphics/goxel/files/patch-ext__src_quickjs_quickjs-libc.c b/graphics/goxel/files/patch-ext__src_quickjs_quickjs-libc.c
new file mode 100644
index 000000000000..7d072a65ff09
--- /dev/null
+++ b/graphics/goxel/files/patch-ext__src_quickjs_quickjs-libc.c
@@ -0,0 +1,13 @@
+--- ext_src/quickjs/quickjs-libc.c.orig 2023-04-01 08:04:28 UTC
++++ ext_src/quickjs/quickjs-libc.c
+@@ -47,6 +47,10 @@
+ #include <sys/ioctl.h>
+ #include <sys/wait.h>
+
++#if defined(__FreeBSD__)
++typedef sig_t sighandler_t;
++extern char **environ;
++#endif
+ #if defined(__APPLE__)
+ typedef sig_t sighandler_t;
+ #if !defined(environ)