aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-05 06:45:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-08 15:19:24 +0000
commit264edaa0316b95927defda0b51e3892ad85fb8c2 (patch)
tree4ddc2107c2a8d54c5d6320944707478739267215
parent00268359bcd94c574829d58fe9722fec4bf23917 (diff)
downloadports-264edaa0316b95927defda0b51e3892ad85fb8c2.tar.gz
ports-264edaa0316b95927defda0b51e3892ad85fb8c2.zip
textproc/py-citeproc-py-styles: Unbreak
Python version comparison procedure thinks that the version 2.6.2 is greater than 6.0.0 for some reason. Reported by: fallout (cherry picked from commit a7c2ddb5a20181f1835216965d25d526c9fcc50c)
-rw-r--r--textproc/py-citeproc-py-styles/files/patch-setup.py13
1 files changed, 13 insertions, 0 deletions
diff --git a/textproc/py-citeproc-py-styles/files/patch-setup.py b/textproc/py-citeproc-py-styles/files/patch-setup.py
new file mode 100644
index 000000000000..bcc2ddb8b4b9
--- /dev/null
+++ b/textproc/py-citeproc-py-styles/files/patch-setup.py
@@ -0,0 +1,13 @@
+- fix the problem that Python thinks that the version 2.6.2 is greater than 6.0.0 for pytest-runner
+
+--- setup.py.orig 2022-10-05 06:44:42 UTC
++++ setup.py
+@@ -27,7 +27,7 @@ for reqs in extras_require.values():
+ extras_require['all'].extend(reqs)
+
+ setup_requires = [
+- 'pytest-runner>=2.6.2',
++ 'pytest-runner',
+ ]
+
+ install_requires = [