aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-04-13 00:51:22 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-04-13 00:51:22 +0000
commit265c4c3dbff47f6e795d8e8acd3ce04dabf95599 (patch)
tree4dbc3167e87c90eed8ef2089d9c4a42def99a303
parent9c5ef725fecb10e5ba6c7064f55cb8eb54db9072 (diff)
downloadports-265c4c3dbff47f6e795d8e8acd3ce04dabf95599.tar.gz
ports-265c4c3dbff47f6e795d8e8acd3ce04dabf95599.zip
multimedia/libdv: fix build on !x86
Disable asm on everything but amd64 / i386: libdv/meson.build:62:2: ERROR: Problem encountered: Assembly optimizations were requested, but are not available with this architecture/compiler.
-rw-r--r--multimedia/libdv/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/multimedia/libdv/Makefile b/multimedia/libdv/Makefile
index c6de6c1f06be..674d028631bb 100644
--- a/multimedia/libdv/Makefile
+++ b/multimedia/libdv/Makefile
@@ -26,4 +26,10 @@ LDFLAGS_i386= -Wl,-znotext
MESON_ARGS= -Dtools=enabled
+.include <bsd.port.options.mk>
+
+.if ${ARCH} != amd64 && ${ARCH} != i386
+MESON_ARGS+= -Dasm=disabled
+.endif
+
.include <bsd.port.mk>