aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-10-04 19:24:04 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-10-04 20:02:31 +0000
commit26909942903594722227910fa0f21216b557be8c (patch)
treeada6f86cdf81f1be9c45f684354ced1b364a357a
parent813f9362a1816fe46200abda436f9f95ff498aae (diff)
downloadports-26909942903594722227910fa0f21216b557be8c.tar.gz
ports-26909942903594722227910fa0f21216b557be8c.zip
games/tinycols: jewel matching game
A jewels matching game for the Linux terminal. Three difficulties are provided. WWW: https://github.com/zedr/tinycols
-rw-r--r--games/Makefile1
-rw-r--r--games/tinycols/Makefile33
-rw-r--r--games/tinycols/distinfo3
-rw-r--r--games/tinycols/pkg-descr2
4 files changed, 39 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index a1355e9a2330..d0130af5b7cd 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -966,6 +966,7 @@
SUBDIR += textmaze
SUBDIR += thegrind
SUBDIR += tileworld
+ SUBDIR += tinycols
SUBDIR += tkmoo
SUBDIR += tmatrix
SUBDIR += tomatoes
diff --git a/games/tinycols/Makefile b/games/tinycols/Makefile
new file mode 100644
index 000000000000..fc378fa8cc92
--- /dev/null
+++ b/games/tinycols/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= tinycols
+DISTVERSION= 0.6.1
+CATEGORIES= games
+
+MAINTAINER= fuz@FreeBSD.org
+COMMENT= Jewels matching game for the terminal
+WWW= https://github.com/zedr/tinycols
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= ncurses
+USE_GITHUB= yes
+GH_ACCOUNT= zedr
+
+CPPFLAGS+= -I${NCURSESINC:/ncurses=}
+LDFLAGS+= -L${NCURSESLIB}
+LIBS+= ${NCURSESLIBS}
+
+PLIST_FILES= bin/tinycols \
+ share/man/man6/tinycols.6.gz
+
+do-build:
+ ${MKDIR} ${WRKSRC}/build
+ ${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/build/tinycols \
+ ${WRKSRC}/src/main.c ${WRKSRC}/src/gfx.c ${WRKSRC}/src/tinycols/*.c \
+ ${WRKSRC}/src/queue.c ${LIBS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/tinycols ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/tinycols.6 ${STAGEDIR}${PREFIX}/share/man/man6/
+
+.include <bsd.port.mk>
diff --git a/games/tinycols/distinfo b/games/tinycols/distinfo
new file mode 100644
index 000000000000..840ba6956729
--- /dev/null
+++ b/games/tinycols/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1696446639
+SHA256 (zedr-tinycols-0.6.1_GH0.tar.gz) = c571cf428c5aa4070239cb3fc29bb7165f914cbb853afcd99d194b21482dd321
+SIZE (zedr-tinycols-0.6.1_GH0.tar.gz) = 35352
diff --git a/games/tinycols/pkg-descr b/games/tinycols/pkg-descr
new file mode 100644
index 000000000000..f167ee560a08
--- /dev/null
+++ b/games/tinycols/pkg-descr
@@ -0,0 +1,2 @@
+A jewels matching game for the Linux terminal.
+Three difficulties are provided.