aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:30:29 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-02-05 18:02:28 +0000
commit2690dfce6ef4f303b2d7475328f39fdeb2605904 (patch)
tree62810d69e346daf139584897ad1e139ae47f183c
parent21eadd1aecca2b22de4db0648748c5a284a0cf3f (diff)
downloadports-2690dfce6ef4f303b2d7475328f39fdeb2605904.tar.gz
ports-2690dfce6ef4f303b2d7475328f39fdeb2605904.zip
www/p5-WWW-Curl: Fix build with curl 7.87.0 (latest version)
- Bump PORTREVISION for package change (cherry picked from commit 8a8f565d84a6425507b68b6c3af3b9944a6a4961)
-rw-r--r--www/p5-WWW-Curl/Makefile2
-rw-r--r--www/p5-WWW-Curl/files/patch-Makefile.PL13
2 files changed, 9 insertions, 6 deletions
diff --git a/www/p5-WWW-Curl/Makefile b/www/p5-WWW-Curl/Makefile
index 72cb176d63c7..2e790bf5aeca 100644
--- a/www/p5-WWW-Curl/Makefile
+++ b/www/p5-WWW-Curl/Makefile
@@ -1,6 +1,6 @@
PORTNAME= WWW-Curl
PORTVERSION= 4.17
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www ftp perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/www/p5-WWW-Curl/files/patch-Makefile.PL b/www/p5-WWW-Curl/files/patch-Makefile.PL
index 2f7352fd0389..50bb21ff8387 100644
--- a/www/p5-WWW-Curl/files/patch-Makefile.PL
+++ b/www/p5-WWW-Curl/files/patch-Makefile.PL
@@ -1,20 +1,23 @@
---- Makefile.PL.orig 2014-02-21 08:08:09.000000000 -0800
-+++ Makefile.PL 2020-04-20 15:36:35.008798000 -0700
-@@ -100,6 +100,13 @@
+--- Makefile.PL.orig 2014-02-21 16:08:09 UTC
++++ Makefile.PL
+@@ -100,6 +100,16 @@ if (!defined($curl_h)) {
print "Found curl.h in $curl_h\n";
my @syms;
my $has_cpp = 0;
+ my @skiplist = qw/
++ CURL_DEPRECATED
+ CURL_DID_MEMORY_FUNC_TYPEDEFS
++ CURL_IGNORE_DEPRECATION
+ CURL_STRICTER
-+ CURLINC_CURL_H
+ CURL_WIN32
++ CURLINC_CURL_H
+ CURLOPT
++ CURLOPTDEPRECATED
+ /;
open(H_IN, "-|", "cpp", $curl_h) and $has_cpp++;
unless ($has_cpp) {
warn "No working cpp ($!). Parsing curl.h in Perl";
-@@ -121,6 +128,7 @@
+@@ -121,6 +131,7 @@ if (!defined($curl_h)) {
open (H, "<", $curl_h) or die ("Cannot open $curl_h: ".$!);
while(<H>) {
if (/^#define (CURL[A-Za-z0-9_]*)/) {