aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-05-20 18:27:09 +0000
committerRene Ladan <rene@FreeBSD.org>2016-05-20 18:27:09 +0000
commit26bcf8719690fc1731cff9b05074f3e5809cb6b5 (patch)
treecbbf22ffdedbd1444289befb3cb15567180ed51e
parentd7d34cab7d87681f358150eb9b043b44fb989c5c (diff)
downloadports-26bcf8719690fc1731cff9b05074f3e5809cb6b5.tar.gz
ports-26bcf8719690fc1731cff9b05074f3e5809cb6b5.zip
Remove expired port:
2016-05-20 dns/nsd3: NSD 3 is EOL, please upgrade to NSD 4 in dns/nsd
Notes
Notes: svn path=/head/; revision=415568
-rw-r--r--MOVED1
-rw-r--r--dns/Makefile1
-rw-r--r--dns/nsd3/Makefile93
-rw-r--r--dns/nsd3/distinfo2
-rw-r--r--dns/nsd3/files/nsd.in85
-rw-r--r--dns/nsd3/pkg-descr4
-rw-r--r--dns/nsd3/pkg-message16
-rw-r--r--dns/nsd3/pkg-plist20
8 files changed, 1 insertions, 221 deletions
diff --git a/MOVED b/MOVED
index 558c8dbcc44f..a22c7a7f4199 100644
--- a/MOVED
+++ b/MOVED
@@ -8324,3 +8324,4 @@ databases/postgresql90-pltcl||2016-05-16|Has expired: "EOL was reached in Septem
databases/postgresql90-docs||2016-05-16|Has expired: "EOL was reached in September 2015"
devel/py-gyp-devel|devel/py-gyp|2016-05-16|Renamed to devel/py-gyp
sysutils/relaunchd|sysutils/jobd|2016-05-20|Renamed to sysutils/jobd
+dns/nsd3|dns/nsd|2016-05-20|Has expired: NSD 3 is EOL, please upgrade to NSD 4 in dns/nsd
diff --git a/dns/Makefile b/dns/Makefile
index 6458b8926fe8..3df57a08ffbb 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -96,7 +96,6 @@
SUBDIR += mydns-ng
SUBDIR += noip
SUBDIR += nsd
- SUBDIR += nsd3
SUBDIR += nslint
SUBDIR += nsping
SUBDIR += nss_mdns
diff --git a/dns/nsd3/Makefile b/dns/nsd3/Makefile
deleted file mode 100644
index 6c48a0c8a7fc..000000000000
--- a/dns/nsd3/Makefile
+++ /dev/null
@@ -1,93 +0,0 @@
-# Created by: alexis
-# $FreeBSD$
-
-PORTNAME= nsd
-PORTVERSION= 3.2.21
-CATEGORIES= dns ipv6
-MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/ \
- ftp://ftp.rhnet.is/pub/nsd/
-PKGNAMESUFFIX= 3
-
-MAINTAINER= jaap@NLnetLabs.nl
-COMMENT= Authoritative only non-recursive name server
-
-LICENSE= BSD3CLAUSE
-
-CONFLICTS= nsd-[0-2]* nsd-4*
-
-DEPRECATED= NSD 3 is EOL, please upgrade to NSD 4 in dns/nsd
-EXPIRATION_DATE= 2016-05-20
-
-USE_RC_SUBR= nsd
-
-NSDUSER?= bind
-NSDGROUP?= bind
-NSDLSDIR= /var
-NSDDBDIR= /var/db/nsd
-NSDRUNDIR= /var/run/nsd
-NSDMAX_IPS?= 512
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-user=${NSDUSER} \
- --with-configdir=${PREFIX}/etc/nsd \
- --localstatedir=${NSDLSDIR} \
- --with-dbfile=${NSDDBDIR}/nsd.db \
- --with-pidfile=${NSDRUNDIR}/nsd.pid
-
-PLIST_SUB= NSDUSER=${NSDUSER} \
- NSDGROUP=${NSDGROUP} \
- NSDDBDIR=${NSDDBDIR} \
- NSDRUNDIR=${NSDRUNDIR}
-
-USE_OPENSSL= yes
-
-PORTDOCS= CREDITS ChangeLog LICENSE NSD-DATABASE NSD-DIFFFILE \
- NSD-FOR-BIND-USERS README README.icc RELNOTES \
- REQUIREMENTS TESTPLAN TODO UPGRADING coding-style \
- differences.tex
-
-OPTIONS_DEFINE= ROOT_SERVER LARGEFILE IPV6 BIND8_STATS ZONE_STATS CHECKING \
- MINRESPSIZE NSEC3 NSEC3PREHASH MMAP MAXIPS DOCS RRL
-OPTIONS_DEFAULT= LARGEFILE IPV6 NSEC3 NSEC3PREHASH MINRESPSIZE
-
-ROOT_SERVER_DESC= Configure as a root server
-LARGEFILE_DESC= Largefile support
-BIND8_STATS_DESC= BIND8-like NSTATS & XSTATS
-ZONE_STATS_DESC= Per-zone BIND8 stats
-CHECKING_DESC= Internal run-time checks
-NSEC3_DESC= NSEC3 support
-NSEC3PREHASH_DESC= Full NSEC3 pre-hashing
-MINRESPSIZE_DESC= Minimial response sizing
-MMAP_DESC= Use mmap instead of malloc (experimental)
-MAXIPS_DESC= Raise max-ips from 8 to ${NSDMAX_IPS}
-RRL_DESC= Response Rate Limiting
-
-ROOT_SERVER_CONFIGURE_ENABLE= root-server
-LARGEFILE_CONFIGURE_ENABLE= largefile
-IPV6_CONFIGURE_ENABLE= ipv6
-BIND8_STATS_CONFIGURE_ON= --enable-bind8-stats
-CHECKING_CONFIGURE_ENABLE= checking
-NSEC3_CONFIGURE_ENABLE= nsec3
-MINRESPSIZE_CONFIGURE_ENABLE= minimal-responses
-NSEC3PREHASH_CONFIGURE_ENABLE= full-prehash
-MMAP_CONFIGURE_ENABLE= mmap
-MAXIPS_CONFIGURE_ON= --with-max-ips=${NSDMAX_IPS}
-RRL_CONFIGURE_ENABLE= ratelimit
-ZONE_STATS_CONFIGURE_ENABLE= zone-stats
-ZONE_STATS_IMPLIES= BIND8_STATS
-
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/nsd.conf.sample \
- ${STAGEDIR}${PREFIX}/etc/nsd/nsd.conf.sample
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/nsd \
- ${STAGEDIR}${PREFIX}/sbin/nsd-checkconf \
- ${STAGEDIR}${PREFIX}/sbin/nsd-notify \
- ${STAGEDIR}${PREFIX}/sbin/nsd-patch \
- ${STAGEDIR}${PREFIX}/sbin/nsd-xfer \
- ${STAGEDIR}${PREFIX}/sbin/zonec
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/dns/nsd3/distinfo b/dns/nsd3/distinfo
deleted file mode 100644
index 6d986f67d966..000000000000
--- a/dns/nsd3/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (nsd-3.2.21.tar.gz) = 1a3a1ceebff7277e9632160575543e0648dc0d1dfb2ffe42ed23fabec7503501
-SIZE (nsd-3.2.21.tar.gz) = 923043
diff --git a/dns/nsd3/files/nsd.in b/dns/nsd3/files/nsd.in
deleted file mode 100644
index 7f00215921a1..000000000000
--- a/dns/nsd3/files/nsd.in
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: nsd
-# REQUIRE: DAEMON
-# REQUIRE: LOGIN
-# KEYWORD: shutdown
-#
-# Add the following line to /etc/rc.conf to enable nsd:
-#
-# nsd_enable="YES"
-#
-
-. /etc/rc.subr
-
-case $0 in
-/etc/rc*)
- # during boot (shutdown) $0 is /etc/rc (/etc/rc.shutdown),
- # so get the name of the script from $_file
- name=$_file
- ;;
-*)
- name=$0
- ;;
-esac
-
-name=${name##*/}
-
-rcvar=${name}_enable
-
-load_rc_config ${name}
-
-eval ": \${${name}_conf:=\"%%PREFIX%%/etc/nsd/${name}.conf\"}"
-eval "_conf=\${${name}_conf}"
-
-command=%%PREFIX%%/sbin/nsdc
-procname=%%PREFIX%%/sbin/nsd
-
-required_files=${_conf}
-pidfile=`%%PREFIX%%/sbin/nsd-checkconf -o pidfile ${_conf}`
-
-extra_commands="notify patch rebuild reload update"
-
-notify_cmd="nsd_nsdc_cmd notify"
-patch_cmd="nsd_nsdc_cmd patch"
-rebuild_cmd="nsd_nsdc_cmd rebuild"
-reload_cmd="nsd_reload_cmd"
-start_cmd="nsd_start_cmd"
-stop_cmd="nsd_stop_cmd"
-update_cmd="nsd_nsdc_cmd update"
-
-nsd_nsdc_cmd()
-{
- ${command} -c ${_conf} "$1"
-}
-
-nsd_reload_cmd()
-{
- nsd_nsdc_cmd rebuild && nsd_nsdc_cmd reload
-}
-
-nsd_start_cmd()
-{
- local _db
- _db=`%%PREFIX%%/sbin/nsd-checkconf -o database ${_conf}`
- if [ ! -f "${_db}" ]; then
- nsd_nsdc_cmd rebuild
- fi
-
- echo "Starting ${name}."
- nsd_nsdc_cmd start
-}
-
-nsd_stop_cmd()
-{
- echo "Merging nsd zone transfer changes to zone files."
- nsd_nsdc_cmd patch
-
- echo "Stopping ${name}."
- nsd_nsdc_cmd stop
-}
-
-run_rc_command "$1"
-
diff --git a/dns/nsd3/pkg-descr b/dns/nsd3/pkg-descr
deleted file mode 100644
index d946a437d921..000000000000
--- a/dns/nsd3/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-NSD (Name Server Daemon) is a complete implementation of an
-authoritative DNS nameserver.
-
-WWW: http://www.nlnetlabs.nl/nsd
diff --git a/dns/nsd3/pkg-message b/dns/nsd3/pkg-message
deleted file mode 100644
index c9750e7ca4e2..000000000000
--- a/dns/nsd3/pkg-message
+++ /dev/null
@@ -1,16 +0,0 @@
-**************************************************************************
-* *
-* NSD 3 is end-of-life. Please install NSD 4 if you want to use NSD. *
-* For details, of the support commitments, see the mail at *
-* http://www.nlnetlabs.nl/pipermail/nsd-users/2015-May/002100.html *
-* and the project page <http://www.nlnetlabs.nl/projects/nsd/>. *
-* *
-**************************************************************************
-**************************************************************************
-* To run nsd from startup, add nsd_enable="YES" to your etc/rc.conf *
-* *
-* Take good care when using nsd commands, since they often need to *
-* be executed as user dedicated to nsd, in order for the files it *
-* touches or creates to have the proper permissions. *
-* *
-**************************************************************************
diff --git a/dns/nsd3/pkg-plist b/dns/nsd3/pkg-plist
deleted file mode 100644
index 32922647b417..000000000000
--- a/dns/nsd3/pkg-plist
+++ /dev/null
@@ -1,20 +0,0 @@
-%%ETCDIR%%/nsd.conf.sample
-man/man5/nsd.conf.5.gz
-man/man8/nsd-checkconf.8.gz
-man/man8/nsd-notify.8.gz
-man/man8/nsd-patch.8.gz
-man/man8/nsd-xfer.8.gz
-man/man8/nsd.8.gz
-man/man8/nsdc.8.gz
-man/man8/zonec.8.gz
-sbin/nsd
-sbin/nsd-checkconf
-sbin/nsd-notify
-sbin/nsd-patch
-sbin/nsd-xfer
-sbin/nsdc
-sbin/zonec
-@dir(%%NSDUSER%%,%%NSDGROUP%%,0755) %%NSDRUNDIR%%
-@dir(%%NSDUSER%%,%%NSDGROUP%%,0755) %%NSDDBDIR%%
-@postexec chown -R %%NSDUSER%%:%%NSDGROUP%% %%NSDRUNDIR%%
-@postexec chown -R %%NSDUSER%%:%%NSDGROUP%% %%NSDDBDIR%%