aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2002-10-15 13:18:00 +0000
committerMikhail Teterin <mi@FreeBSD.org>2002-10-15 13:18:00 +0000
commit26c59a87d0c0a2ff9352fe95022b727e321e2855 (patch)
tree53fd94bef1787ff3a3caf72dec37f58e82f798cf
parente484b20eb8e27a274e83ee8cd2ff2f99dc25255e (diff)
downloadports-26c59a87d0c0a2ff9352fe95022b727e321e2855.tar.gz
ports-26c59a87d0c0a2ff9352fe95022b727e321e2855.zip
Reset maintainership to ports, due to the original author's
timeout (the previous timeout also noted in the cvs-log -- 2 years ago). Upgrade to the latest sqsh-2.1. Build with readline and motif, unless WITHOUT_X11 is set (plain --with-x results in a rather hard to use X support, author recommend Motif too). Remove the bogus dependency on gettext introduced in Makefile version 1.2 -- the (unpatched) software will, indeed, link with libintl, if present -- mistaking it for Sybase OpenClient's libintl. Install the system-wide sqshrc as ${PREFIX}/etc/sqshrc.default, and allow for another system-wide ${PREFIX}/etc/sqshrc to overwrite some or all of the default settings. PR: ports/40374 (readline and X/Motif)
Notes
Notes: svn path=/head/; revision=68099
-rw-r--r--databases/sqsh/Makefile31
-rw-r--r--databases/sqsh/distinfo2
-rw-r--r--databases/sqsh/files/patch-aa20
-rw-r--r--databases/sqsh/files/patch-ab59
-rw-r--r--databases/sqsh/files/patch-ac8
-rw-r--r--databases/sqsh/files/patch-rcpath7
-rw-r--r--databases/sqsh/files/patch-sqshrc12
-rw-r--r--databases/sqsh/pkg-descr2
-rw-r--r--databases/sqsh/pkg-plist1
9 files changed, 76 insertions, 66 deletions
diff --git a/databases/sqsh/Makefile b/databases/sqsh/Makefile
index 2b53df5ff1f7..4b5b97b488b5 100644
--- a/databases/sqsh/Makefile
+++ b/databases/sqsh/Makefile
@@ -5,24 +5,37 @@
# $FreeBSD$
PORTNAME= sqsh
-PORTVERSION= 1.7
-PORTREVISION= 2
+PORTVERSION= 2.1
CATEGORIES= databases
-MASTER_SITES= http://www.voicenet.com/~gray/
+MASTER_SITES= http://www.sqsh.org/
EXTRACT_SUFX= -src.tar.gz
-MAINTAINER= midom@dammit.lt
+MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= tds.0:${PORTSDIR}/databases/freetds \
- intl.4:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= tds.0:${PORTSDIR}/databases/freetds
+
+.ifndef WITHOUT_X11
+WITH_MOTIF= yes
+CONFIGURE_ARGS+=--with-motif
+.else
+PKGNAMESUFFIX+= -nox11
+.endif
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= SYBASE="${LOCALBASE}"
+CONFIGURE_ARGS+=--with-readline
MAN1= sqsh.1
+ALL_TARGET= build
+
post-patch:
-.for file in configure autoconf/install-man
- @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/${file}
-.endfor
+ ${MV} ${WRKSRC}/doc/global.sqshrc ${WRKSRC}/doc/global.sqshrc.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/sqsh ${PREFIX}/bin
+ cd ${WRKSRC}/doc && \
+ ${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/doc/global.sqshrc ${PREFIX}/etc/sqshrc.default
.include <bsd.port.mk>
diff --git a/databases/sqsh/distinfo b/databases/sqsh/distinfo
index 8ea134232674..8502d73b9f34 100644
--- a/databases/sqsh/distinfo
+++ b/databases/sqsh/distinfo
@@ -1 +1 @@
-MD5 (sqsh-1.7-src.tar.gz) = dfdb8eda026ff1fedbbf64d8c173705a
+MD5 (sqsh-2.1-src.tar.gz) = a9d75ae51eafd94f89640f99ee3a9918
diff --git a/databases/sqsh/files/patch-aa b/databases/sqsh/files/patch-aa
deleted file mode 100644
index dbb4835a32ee..000000000000
--- a/databases/sqsh/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig Wed Jan 6 04:38:41 1999
-+++ Makefile.in Fri Jan 14 14:44:07 2000
-@@ -190,6 +190,8 @@
- $(TARGET) : $(OBJS) sqsh_main.o
- $(CC) $(LDFLAGS) $(OBJS) sqsh_main.o $(LIBS) -o $@
-
-+all : $(TARGET)
-+
- sqsh_test : $(OBJS) sqsh_test.o
- $(CC) $(LDFLAGS) $(OBJS) sqsh_test.o $(LIBS) -o $@
-
-@@ -206,7 +208,7 @@
- distclean : realclean
- rm -f configure Makefile config.h
-
--install : $(TARGET)
-+install : $(TARGET) install.man
- $(INSTALL_DIR) $(bin_dir)
- $(INSTALL_PROG) $(TARGET) $(bin_dir)/$(TARGET)
-
diff --git a/databases/sqsh/files/patch-ab b/databases/sqsh/files/patch-ab
index 22a94a72dc91..5fd2c7716bae 100644
--- a/databases/sqsh/files/patch-ab
+++ b/databases/sqsh/files/patch-ab
@@ -1,32 +1,35 @@
---- configure.orig Fri Jan 14 14:09:13 2000
-+++ configure Fri Jan 14 14:13:12 2000
-@@ -1047,7 +1047,10 @@
+--- configure Fri Nov 9 14:58:04 2001
++++ configure Tue Oct 15 13:51:29 2002
+@@ -1106,4 +1106,8 @@
+ SYBASE_LIBS=
- #
- # Is $SYBASE defined?
--#
-+# -- it should have some defaults...
-+
-+SYBASE=%%LOCALBASE%%/
-+
- echo $ac_n "checking Open Client installation""... $ac_c" 1>&6
- echo "configure:1053: checking Open Client installation" >&5
++ if test "$SYBASE_VERSION" = "FreeTDS"
++ then
++ SYBASE_LIBS="-lct -ltds"
++ else
+ #
+ # Check for -lblk
+@@ -1152,9 +1156,4 @@
+ fi
-@@ -1095,7 +1098,7 @@
- # The basic client libraries that are always needed
- # on all platforms.
- #
-- SYBASE_LIBS="-lblk -lcs -lct -lcomn -ltcl -lintl"
-+ SYBASE_LIBS="-lct -liconv -lintl"
+- #
+- # Check for -ltds (FreeTDS project)
+- #
+- if test -f $SYBASE_LIBDIR/libtds.a; then
+- SYBASE_LIBS="$SYBASE_LIBS -ltds"
+ fi
- MAJOR_VERSION=`echo $SYBASE_VERSION | cut -d '.' -f 1`
+@@ -1196,5 +1195,5 @@
+ ncr*)
+ SYBASE_OS="-ldl -lm";;
+- sunos*)
++ sunos*|*bsd*)
+ SYBASE_OS="-lm";;
+ solaris*)
+@@ -2691,5 +2690,5 @@
+ cat >> $CONFIG_STATUS <<EOF
-@@ -1128,6 +1131,8 @@
- case "${host_os}" in
- linux*)
- SYBASE_OS="-ldl -lm";;
-+ freebsd*)
-+ SYBASE_OS="-lm";;
- irix*)
- SYBASE_OS="-lnsl -lm";;
- ncr*)
+-CONFIG_FILES=\${CONFIG_FILES-"Makefile src/Makefile scripts/install.sh scripts/make_wrapper.sh"}
++CONFIG_FILES=\${CONFIG_FILES-"Makefile src/Makefile scripts/install.sh scripts/make_wrapper.sh doc/global.sqshrc"}
+ EOF
+ cat >> $CONFIG_STATUS <<\EOF
diff --git a/databases/sqsh/files/patch-ac b/databases/sqsh/files/patch-ac
deleted file mode 100644
index 1673e849dbe2..000000000000
--- a/databases/sqsh/files/patch-ac
+++ /dev/null
@@ -1,8 +0,0 @@
---- autoconf/install-man.orig Fri Jan 14 21:19:45 2000
-+++ autoconf/install-man Fri Jan 14 21:20:00 2000
-@@ -1,4 +1,4 @@
--#!/bin/sh
-+#!%%LOCALBASE%%/bin/bash
- #
- # install-man -- install or uninstall compressed or uncompressed man pages.
- #
diff --git a/databases/sqsh/files/patch-rcpath b/databases/sqsh/files/patch-rcpath
new file mode 100644
index 000000000000..bb082edd690b
--- /dev/null
+++ b/databases/sqsh/files/patch-rcpath
@@ -0,0 +1,7 @@
+--- src/Makefile.in Tue Oct 15 12:59:14 2002
++++ src/Makefile.in Tue Oct 15 13:13:13 2002
+@@ -11,3 +11,3 @@
+ SQSHRC_GLOBAL = @prefix@/etc/sqshrc
+-SQSHRC_PATH = "$(SQSHRC_GLOBAL):$${HOME}/.sqshrc"
++SQSHRC_PATH = "$(SQSHRC_GLOBAL).default:$(SQSHRC_GLOBAL):$${HOME}/.sqshrc"
+
diff --git a/databases/sqsh/files/patch-sqshrc b/databases/sqsh/files/patch-sqshrc
new file mode 100644
index 000000000000..e9bd44ddd5e3
--- /dev/null
+++ b/databases/sqsh/files/patch-sqshrc
@@ -0,0 +1,12 @@
+--- doc/global.sqshrc Tue Oct 23 22:31:06 2001
++++ doc/global.sqshrc Tue Oct 15 13:06:20 2002
+@@ -5,3 +5,8 @@
+ # resource file for all users of sqsh.
+-#
++
++# DO NOT EDIT -- the changes will be lost if you reinstall
++# or upgrade sqsh port/package. Instead, create your own
++# @prefix@/etc/sqshrc
++# if you wish to make system-wide customizations.
++# User-specific customizations can be made in ~/.sqshrc files.
+
diff --git a/databases/sqsh/pkg-descr b/databases/sqsh/pkg-descr
index a44891d9315f..f8bde4b299b8 100644
--- a/databases/sqsh/pkg-descr
+++ b/databases/sqsh/pkg-descr
@@ -1,2 +1,4 @@
This is alternative to ancient isql - interactive
and comfortable database query tool for Sybase.
+
+WWW: http://www.sqsh.org/
diff --git a/databases/sqsh/pkg-plist b/databases/sqsh/pkg-plist
index 1899f9428f2d..dc92f5a0a673 100644
--- a/databases/sqsh/pkg-plist
+++ b/databases/sqsh/pkg-plist
@@ -1 +1,2 @@
bin/sqsh
+etc/sqshrc.default