aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 12:06:58 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 12:27:29 +0000
commit270b10e23e2dca9b8dee067f179984dcf97fcdb9 (patch)
treebc9de368a2c3c385a66f9771d0be476fdbbcab24
parent3d95151c2eb7d9f8cb1f149506116b470c43b947 (diff)
downloadports-270b10e23e2dca9b8dee067f179984dcf97fcdb9.tar.gz
ports-270b10e23e2dca9b8dee067f179984dcf97fcdb9.zip
emulators/aranym: Fix build with llvm16
Previous fix by the MAINTAINER actually do not work and it still fails to build. Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--emulators/aranym/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/emulators/aranym/Makefile b/emulators/aranym/Makefile
index b8f26cb84adb..fa036f5eb2dd 100644
--- a/emulators/aranym/Makefile
+++ b/emulators/aranym/Makefile
@@ -20,7 +20,6 @@ USES= gmake jpeg perl5 pkgconfig gl localbase:ldflags sdl shebangfix xorg
USE_GL= gl
USE_SDL= sdl2 image2
USE_XORG= x11
-USE_CXXSTD= c++14 # work around error: ISO C++17 does not allow 'register' storage class specifier, see https://github.com/aranym/aranym/issues/106
SHEBANG_FILES= tools/arabridge
@@ -29,4 +28,10 @@ CONFIGURE_ARGS= -disable-nat-debug --disable-nat-debug --enable-nfjpeg
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CPPFLAGS+= -Dregister=
+.endif
+
.include <bsd.port.mk>