aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSanthosh Raju <fox@FreeBSD.org>2022-10-01 09:54:29 +0000
committerSanthosh Raju <fox@FreeBSD.org>2022-10-01 10:03:42 +0000
commit270d32558409af5d445b63ff185a99b784927f8b (patch)
tree004462845322cbf52396c2798dfa186da3816411
parent9d41754ae74cdc0a18527131f3a7cfa877735cda (diff)
downloadports-270d32558409af5d445b63ff185a99b784927f8b.tar.gz
ports-270d32558409af5d445b63ff185a99b784927f8b.zip
audio/din: Update to 55
Changes since 54: DIN Is Noise 55: /* an overhaul of Gravity as before, you can click and move the base or the tip of the gravity arrow to adjust its position, direction and strength. to (auto) animate the gravity arrow: assign a drone to base of gravity assign another drone to tip of gravity move or visual FM / AM modulate one or both these drones and gravity moves accordingly. animating gravity influences the trajectory of launched drones :) click 'Base to manual' and 'Tip to manual' to detach assigned drones from base and the tip respectively. you can now manually edit the base and tip again. click 'Select base', 'Select tip' or 'Select both' to select the assigned drones. Useful for moving, for visual AM/FM, to mute them etc. eg., you could mute the assigned drones by clicking 'Select both' and then Menu > Drone Tools > Mute /* /* adjust position/phase of visual drone modulation (AM and FM) Menu > Drone Params > AM Position Menu > Drone Params > FM Position eg., at 0 position with AM and FM BPMs equal, the trail/path of the modulating drones is elliptical. /* set AM BPM to FM BPM of drones and vice-versa /* flip velocity direction of launched drone with respect to the launcher if -ve flag is set in drone velocity defaults /* opacity parameter for oscilloscope * optimised oscilloscope * faster sample add * faster drawing * changed shape of drone handles * optimised snap lines drawing on curve editors ! fixed OpenGL drawing bugs for affected OpenGL drivers on Windows ! ! in oscilloscope ! ! in waveform display on waveform editors ! ! when hz/vol displayed on drones ! ! fixed crash if drones as they are fading in when creating drone mesh are modulated or moved !
-rw-r--r--audio/din/Makefile3
-rw-r--r--audio/din/distinfo6
-rw-r--r--audio/din/files/patch-src_Makefile.am10
3 files changed, 9 insertions, 10 deletions
diff --git a/audio/din/Makefile b/audio/din/Makefile
index a03875fef801..61c028bfc699 100644
--- a/audio/din/Makefile
+++ b/audio/din/Makefile
@@ -1,6 +1,5 @@
PORTNAME= din
-PORTVERSION= 54
-PORTREVISION= 2
+PORTVERSION= 55
CATEGORIES= audio
MASTER_SITES= https://archive.org/download/dinisnoise_source_code/
diff --git a/audio/din/distinfo b/audio/din/distinfo
index 9cf9d3d6d5b4..f42db1651c05 100644
--- a/audio/din/distinfo
+++ b/audio/din/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1651912709
-SHA256 (din-54.tar.gz) = b56ea9f45e206b8bb9f1451870c9a410872d93b47ac17652651fbaf1708df0b7
-SIZE (din-54.tar.gz) = 3710611
+TIMESTAMP = 1664616550
+SHA256 (din-55.tar.gz) = acfcee40fbffaf3cb681d411efdd58ca506f96d416ed71cbbbcd838540bcecf2
+SIZE (din-55.tar.gz) = 3711327
diff --git a/audio/din/files/patch-src_Makefile.am b/audio/din/files/patch-src_Makefile.am
index c6962477df1e..e3c3278a013e 100644
--- a/audio/din/files/patch-src_Makefile.am
+++ b/audio/din/files/patch-src_Makefile.am
@@ -1,15 +1,15 @@
Removed tcl8.6, asound and jack flags, this is now handled in the ports
script.
---- src/Makefile.am.orig 2021-12-04 02:58:55 UTC
+--- src/Makefile.am.orig 2022-09-22 14:07:29 UTC
+++ src/Makefile.am
@@ -1,7 +1,7 @@
#dinincludedir = $(pkgsrcdir)
--AM_CXXFLAGS = -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -D__BOOST_TIME__ -DPREFIX=\"@prefix@\"
+-AM_CXXFLAGS = -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -D__BOOST_TIME__ -DPREFIX=\"@prefix@\"
-LIBS += -ltcl8.6 -lSDL -lGL -lpthread -lasound
-+AM_CXXFLAGS = -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -D__BOOST_TIME__ -DPREFIX=\"@prefix@\"
-+LIBS += -lSDL -lGL -lpthread -lasound
++AM_CXXFLAGS = -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -D__BOOST_TIME__ -DPREFIX=\"@prefix@\"
++LIBS += -lSDL -lGL -lpthread
bin_PROGRAMS = din
- din_SOURCES = alarm.cc arrow_button.cc audio.cc authors_note.cc autoflip.cc autorotator.cc ball.cc ball_ops.cc basic_editor.cc beat2value.cc binaural_drone.cc binaural_drones.cc bit_display.cc box_selector.cc button.cc capturer.cc checkbutton.cc chrono.cc circler.cc command.cc compressor.cc console.cc console_iterator.cc countries.cc cross_button.cc curve.cc curve_display.cc curve_editor.cc curve_library.cc curve_mixer.cc curve_picker.cc curve_samples.cc custom_periodic.cc defvelaccel.cc delay.cc din.cc din_info.cc drawrrow.cc drone.cc eval.cc fader.cc fft.cc field.cc filled_button.cc font.cc font_editor.cc fractaliser.cc globals.cc glyph.cc gravity.cc hit.cc help.cc item_list.cc keyboard_keyboard.cc label.cc levels.cc line.cc lissajous.cc listeners.cc main.cc menu.cc mesh.cc midi_in.cc minus_button.cc mocap.cc modulator.cc mondrian.cc morpher.cc morse_code.cc mouse_slider.cc multi_curve.cc note.cc noiser.cc number.cc oscilloscope.cc phrasor.cc play.cc plugin.cc plugin_browser.cc plus_button.cc point_modulator.cc range.cc recorder.cc rect.cc rose_milker.cc scale_info.cc scale_notes.cc scalelist.cc separator.cc settings.cc sine_mixer.cc slit.cc solver.cc spiraler.cc starrer.cc superformula.cc tap_bpm.cc tcl_interp.cc textboard.cc tokenizer.cc trail.cc triggered_note.cc ui.cc ui_sin_cos_radius.cc viewwin.cc warper.cc widget.cc kiss_fft.c RtAudio.cpp RtMidi.cpp
+