aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2021-10-27 20:14:28 +0000
committerMikhail Teterin <mi@FreeBSD.org>2021-10-27 20:14:28 +0000
commit278c68d7cac1ccf982132f2e364a7f129049f0ba (patch)
tree4a3198f049b2bc100d17d892ff8f972909d7c00e
parent3cc7affdd5cc24a54c8d8bed7938087679454983 (diff)
downloadports-278c68d7cac1ccf982132f2e364a7f129049f0ba.tar.gz
ports-278c68d7cac1ccf982132f2e364a7f129049f0ba.zip
net-im/purple-hangouts: Add the upstream's patch for HTTP-errors 429
PR: 259291 Approved by: J Juanino (maintainer) Sponsored by: United Marsupials
-rw-r--r--net-im/purple-hangouts/Makefile2
-rw-r--r--net-im/purple-hangouts/files/patch-42926
2 files changed, 28 insertions, 0 deletions
diff --git a/net-im/purple-hangouts/Makefile b/net-im/purple-hangouts/Makefile
index d5aaaed477b7..30668fc1046e 100644
--- a/net-im/purple-hangouts/Makefile
+++ b/net-im/purple-hangouts/Makefile
@@ -2,6 +2,7 @@
PORTNAME= purple-hangouts
PORTVERSION= 20190607
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= https://bitbucket.org/EionRobb/${PORTNAME}/get/
# Commit tag. Must be changed according with PORTVERSION.
@@ -19,6 +20,7 @@ LIB_DEPENDS= libpurple.so:net-im/libpurple \
USES= gmake gnome pkgconfig zip
USE_GNOME= glib20
+PATCH_STRIP= -p1 --ignore-whitespace
WRKSRC= ${WRKDIR}/EionRobb-${PORTNAME}-${DISTNAME}
diff --git a/net-im/purple-hangouts/files/patch-429 b/net-im/purple-hangouts/files/patch-429
new file mode 100644
index 000000000000..fa9a62cfc05b
--- /dev/null
+++ b/net-im/purple-hangouts/files/patch-429
@@ -0,0 +1,26 @@
+From 55b9f01d040b240b794700f44d9c21a6cb51251e Mon Sep 17 00:00:00 2001
+From: Eion Robb <eion@robbmob.com>
+Date: Wed, 30 Jun 2021 09:53:47 +1200
+Subject: [PATCH] Fix for 429 errors
+
+Fixes issue #222
+---
+ hangouts_auth.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/hangouts_auth.c b/hangouts_auth.c
+index 025f4f9..d988c3a 100644
+--- a/hangouts_auth.c
++++ b/hangouts_auth.c
+@@ -258,6 +258,11 @@ hangouts_auth_get_session_cookies_got_cb(PurpleHttpConnection *http_conn, Purple
+ return;
+ }
+
++ purple_http_cookie_jar_set(ha->cookie_jar, "__Secure-3PSID", NULL);
++ purple_http_cookie_jar_set(ha->cookie_jar, "__Host-3PLSID", NULL);
++ purple_http_cookie_jar_set(ha->cookie_jar, "__Secure-3PAPISID", NULL);
++ purple_http_cookie_jar_set(ha->cookie_jar, "__Host-GAPS", NULL);
++
+ //Restore the last_event_timestamp before it gets overridden by new events
+ last_event_timestamp = purple_account_get_int(ha->account, "last_event_timestamp_high", 0);
+ if (last_event_timestamp != 0) {