aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-04-21 11:55:54 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-04-22 14:40:08 +0000
commit27ac22d9e28101a4430465f2c3b5859a08176733 (patch)
tree4cc4a330c4b68bdc6b52ea54d08e0e5547214248
parent2d7d9f7ed9d73fe13c25f8d9ea67dc447295f880 (diff)
downloadports-27ac22d9e28101a4430465f2c3b5859a08176733.tar.gz
ports-27ac22d9e28101a4430465f2c3b5859a08176733.zip
x11-toolkits/wlroots-devel: restore port
This reverts commit b008e04d52506b2ead49a5b0baf9ef6d7446c46c.
-rw-r--r--MOVED1
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/wlroots-devel/Makefile79
-rw-r--r--x11-toolkits/wlroots-devel/distinfo7
-rw-r--r--x11-toolkits/wlroots-devel/override.mk8
-rw-r--r--x11-toolkits/wlroots-devel/pkg-descr28
-rw-r--r--x11-toolkits/wlroots-devel/pkg-plist107
7 files changed, 230 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 377602e446e1..fa6e77dc3be5 100644
--- a/MOVED
+++ b/MOVED
@@ -17574,7 +17574,6 @@ devel/py-spyder|devel/spyder|2022-11-06|Spyder is an application, and not a libr
www/grafana7||2022-11-07|Has expired: EOLed upstream, unfixed vulnerabilities
devel/cppcheck-gui|devel/cppcheck|2022-11-07|GUI is now included in devel/cppcheck port
devel/py-types-termcolor||2022-11-11|No longer needed, type annotations are now available in termcolor module
-x11-toolkits/wlroots-devel|x11-toolkits/wlroots|2022-11-11|Out of date: use x11-toolkits/wlroots for now
multimedia/mpv034||2022-11-14|No longer needed
devel/py-types-xxhash||2022-11-15|No longer needed, type annotations are now available in xxhash module
devel/awscli|devel/py-awscli|2022-11-15|Renamed comply with Python Ports Policy and flavored
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 96d10e6f4eb4..26c41850ec0b 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -227,6 +227,7 @@
SUBDIR += vte
SUBDIR += vte3
SUBDIR += wlroots
+ SUBDIR += wlroots-devel
SUBDIR += wlroots015
SUBDIR += wmapp
SUBDIR += wxgtk30
diff --git a/x11-toolkits/wlroots-devel/Makefile b/x11-toolkits/wlroots-devel/Makefile
new file mode 100644
index 000000000000..672e54c0f6b5
--- /dev/null
+++ b/x11-toolkits/wlroots-devel/Makefile
@@ -0,0 +1,79 @@
+PORTNAME= wlroots
+DISTVERSION= 0.16.0-359
+DISTVERSIONSUFFIX= -g${GL_COMMIT:C/(.{12}).*/\1/}
+CATEGORIES= x11-toolkits
+PKGNAMESUFFIX= -devel
+
+PATCH_SITES+= https://github.com/swaywm/${GL_PROJECT}/commit/:github
+PATCHFILES+= 10f80a8f1bb2.patch:-p1:github # https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/2064
+PATCHFILES+= 3196c73d487f.patch:-p1:github # https://gitlab.freedesktop.org/wlroots/wlroots/-/merge_requests/2064
+PATCH_SITES+= ${GL_SITE}/${GL_ACCOUNT}/${GL_PROJECT}/-/commit/
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Modular Wayland compositor library (development snapshot)
+WWW= https://gitlab.freedesktop.org/wlroots/wlroots
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>=1.31:graphics/wayland-protocols
+LIB_DEPENDS= libdrm.so:graphics/libdrm \
+ libwayland-server.so:graphics/wayland \
+ libseat.so:sysutils/seatd \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 gl meson pkgconfig xorg
+USE_GITLAB= yes
+USE_GL= gbm
+USE_XORG= pixman
+USE_LDCONFIG= yes
+GL_SITE= https://gitlab.freedesktop.org
+GL_COMMIT= 44069dfd5e9e3efa150ce468f48c64916f2de0ae
+MESON_ARGS= -Dexamples=false -Dbackends=${BACKENDS:ts,} -Drenderers=${RENDERERS:ts,}
+
+.ifdef PKGNAMESUFFIX
+PORTSCOUT= ignore:1
+PREFIX= ${LOCALBASE}/${PKGBASE} # avoid conflict with the default
+MESON_ARGS+= -Ddatadir="${LOCALBASE}/share"
+.endif
+
+OPTIONS_DEFINE= DRM OPENGL VULKAN X11
+OPTIONS_DEFAULT=DRM OPENGL VULKAN X11
+OPTIONS_SUB= yes
+
+DRM_DESC= KMS console support
+DRM_BUILD_DEPENDS= hwdata>0:misc/hwdata
+DRM_LIB_DEPENDS= libudev.so:devel/libudev-devd \
+ libliftoff.so:graphics/libliftoff \
+ libdisplay-info.so:sysutils/libdisplay-info \
+ libinput.so:x11/libinput
+DRM_MESON_ENABLED= session
+DRM_VARS= BACKENDS+="drm libinput"
+
+OPENGL_RUN_DEPENDS= mesa-dri>0:graphics/mesa-dri
+OPENGL_USE= GL=egl,glesv2
+OPENGL_VARS= RENDERERS+=gles2
+
+VULKAN_DESC= Vulkan renderer
+VULKAN_BUILD_DEPENDS= glslangValidator:graphics/glslang \
+ vulkan-headers>0:graphics/vulkan-headers
+VULKAN_LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader
+VULKAN_RUN_DEPENDS= mesa-dri>0:graphics/mesa-dri
+VULKAN_VARS= RENDERERS+=vulkan
+
+X11_LIB_DEPENDS= libxcb-errors.so:x11/xcb-util-errors \
+ libxcb-render-util.so:x11/xcb-util-renderutil \
+ libxcb-icccm.so:x11/xcb-util-wm
+X11_BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ xwayland-devel>0:x11-servers/xwayland-devel
+X11_RUN_DEPENDS= xwayland-devel>0:x11-servers/xwayland-devel
+X11_USE= XORG=xcb
+X11_MESON_ENABLED= xwayland
+X11_VARS= BACKENDS+=x11
+
+post-patch:
+# Extract (snapshot) version from the port instead of meson.build
+ @${REINPLACE_CMD} "/STR/s/meson.project_version()/'${DISTVERSIONFULL}'/" \
+ ${WRKSRC}/include/wlr/meson.build
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/wlroots-devel/distinfo b/x11-toolkits/wlroots-devel/distinfo
new file mode 100644
index 000000000000..f78d4ad4f01d
--- /dev/null
+++ b/x11-toolkits/wlroots-devel/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1681979986
+SHA256 (wlroots-wlroots-44069dfd5e9e3efa150ce468f48c64916f2de0ae_GL0.tar.gz) = e2a5940ef2e20faed246ac39aa0c9b4c55bb522fd32929ab139838bd81c5821a
+SIZE (wlroots-wlroots-44069dfd5e9e3efa150ce468f48c64916f2de0ae_GL0.tar.gz) = 611892
+SHA256 (10f80a8f1bb2.patch) = ca65f8eecf32e7364d5ba43cd9ee91060710a6fb8392892c86ad71e4f2a4c0b5
+SIZE (10f80a8f1bb2.patch) = 6097
+SHA256 (3196c73d487f.patch) = 69c6bc4658852bb45a24b129f625a7faaed8035dab0d79c388ae74d650beacdc
+SIZE (3196c73d487f.patch) = 4243
diff --git a/x11-toolkits/wlroots-devel/override.mk b/x11-toolkits/wlroots-devel/override.mk
new file mode 100644
index 000000000000..45bd059006f2
--- /dev/null
+++ b/x11-toolkits/wlroots-devel/override.mk
@@ -0,0 +1,8 @@
+WLR_SUFFIX= -devel
+
+BUILD_DEPENDS:= ${BUILD_DEPENDS:S/wlroots/&${WLR_SUFFIX}/g}
+LIB_DEPENDS:= ${LIB_DEPENDS:S/wlroots$/&${WLR_SUFFIX}/}
+
+USES+= localbase # -isystem
+CONFIGURE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/wlroots${WLR_SUFFIX}/libdata/pkgconfig"
+MAKE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/wlroots${WLR_SUFFIX}/libdata/pkgconfig"
diff --git a/x11-toolkits/wlroots-devel/pkg-descr b/x11-toolkits/wlroots-devel/pkg-descr
new file mode 100644
index 000000000000..6daf6a788b68
--- /dev/null
+++ b/x11-toolkits/wlroots-devel/pkg-descr
@@ -0,0 +1,28 @@
+Pluggable, composable, unopinionated modules for building a Wayland
+compositor; or about 60,000 lines of code you were going to write anyway.
+
+- wlroots provides backends that abstract the underlying display and input
+ hardware, including KMS/DRM, libinput, Wayland, X11, and headless backends,
+ plus any custom backends you choose to write, which can all be created or
+ destroyed at runtime and used in concert with each other.
+- wlroots provides unopinionated, mostly standalone implementations of many
+ Wayland interfaces, both from wayland.xml and various protocol extensions.
+ We also promote the standardization of portable extensions across
+ many compositors.
+- wlroots provides several powerful, standalone, and optional tools that
+ implement components common to many compositors, such as the arrangement of
+ outputs in physical space.
+- wlroots provides an Xwayland abstraction that allows you to have excellent
+ Xwayland support without worrying about writing your own X11 window manager
+ on top of writing your compositor.
+- wlroots provides a renderer abstraction that simple compositors can use to
+ avoid writing GL code directly, but which steps out of the way when your
+ needs demand custom rendering code.
+
+wlroots implements a huge variety of Wayland compositor features and implements
+them *right*, so you can focus on the features that make your compositor
+unique. By using wlroots, you get high performance, excellent hardware
+compatibility, broad support for many wayland interfaces, and comfortable
+development tools - or any subset of these features you like, because all of
+them work independently of one another and freely compose with anything you want
+to implement yourself.
diff --git a/x11-toolkits/wlroots-devel/pkg-plist b/x11-toolkits/wlroots-devel/pkg-plist
new file mode 100644
index 000000000000..572d2f14202e
--- /dev/null
+++ b/x11-toolkits/wlroots-devel/pkg-plist
@@ -0,0 +1,107 @@
+include/wlr/backend.h
+%%DRM%%include/wlr/backend/drm.h
+include/wlr/backend/headless.h
+include/wlr/backend/interface.h
+%%DRM%%include/wlr/backend/libinput.h
+include/wlr/backend/multi.h
+%%DRM%%include/wlr/backend/session.h
+include/wlr/backend/wayland.h
+%%X11%%include/wlr/backend/x11.h
+include/wlr/config.h
+include/wlr/interfaces/wlr_buffer.h
+include/wlr/interfaces/wlr_keyboard.h
+include/wlr/interfaces/wlr_output.h
+include/wlr/interfaces/wlr_pointer.h
+include/wlr/interfaces/wlr_switch.h
+include/wlr/interfaces/wlr_tablet_pad.h
+include/wlr/interfaces/wlr_tablet_tool.h
+include/wlr/interfaces/wlr_touch.h
+include/wlr/render/allocator.h
+include/wlr/render/dmabuf.h
+include/wlr/render/drm_format_set.h
+%%OPENGL%%include/wlr/render/egl.h
+%%OPENGL%%include/wlr/render/gles2.h
+include/wlr/render/interface.h
+include/wlr/render/pixman.h
+include/wlr/render/swapchain.h
+%%VULKAN%%include/wlr/render/vulkan.h
+include/wlr/render/wlr_renderer.h
+include/wlr/render/wlr_texture.h
+include/wlr/types/wlr_buffer.h
+include/wlr/types/wlr_compositor.h
+include/wlr/types/wlr_content_type_v1.h
+include/wlr/types/wlr_cursor.h
+include/wlr/types/wlr_damage_ring.h
+include/wlr/types/wlr_data_control_v1.h
+include/wlr/types/wlr_data_device.h
+include/wlr/types/wlr_drm.h
+%%DRM%%include/wlr/types/wlr_drm_lease_v1.h
+include/wlr/types/wlr_export_dmabuf_v1.h
+include/wlr/types/wlr_foreign_toplevel_management_v1.h
+include/wlr/types/wlr_fractional_scale_v1.h
+include/wlr/types/wlr_fullscreen_shell_v1.h
+include/wlr/types/wlr_gamma_control_v1.h
+include/wlr/types/wlr_idle.h
+include/wlr/types/wlr_idle_inhibit_v1.h
+include/wlr/types/wlr_idle_notify_v1.h
+include/wlr/types/wlr_input_device.h
+include/wlr/types/wlr_input_inhibitor.h
+include/wlr/types/wlr_input_method_v2.h
+include/wlr/types/wlr_keyboard.h
+include/wlr/types/wlr_keyboard_group.h
+include/wlr/types/wlr_keyboard_shortcuts_inhibit_v1.h
+include/wlr/types/wlr_layer_shell_v1.h
+include/wlr/types/wlr_linux_dmabuf_v1.h
+include/wlr/types/wlr_matrix.h
+include/wlr/types/wlr_output.h
+include/wlr/types/wlr_output_layer.h
+include/wlr/types/wlr_output_layout.h
+include/wlr/types/wlr_output_management_v1.h
+include/wlr/types/wlr_output_power_management_v1.h
+include/wlr/types/wlr_pointer.h
+include/wlr/types/wlr_pointer_constraints_v1.h
+include/wlr/types/wlr_pointer_gestures_v1.h
+include/wlr/types/wlr_presentation_time.h
+include/wlr/types/wlr_primary_selection.h
+include/wlr/types/wlr_primary_selection_v1.h
+include/wlr/types/wlr_region.h
+include/wlr/types/wlr_relative_pointer_v1.h
+include/wlr/types/wlr_scene.h
+include/wlr/types/wlr_screencopy_v1.h
+include/wlr/types/wlr_seat.h
+include/wlr/types/wlr_server_decoration.h
+include/wlr/types/wlr_session_lock_v1.h
+include/wlr/types/wlr_shm.h
+include/wlr/types/wlr_single_pixel_buffer_v1.h
+include/wlr/types/wlr_subcompositor.h
+include/wlr/types/wlr_switch.h
+include/wlr/types/wlr_tablet_pad.h
+include/wlr/types/wlr_tablet_tool.h
+include/wlr/types/wlr_tablet_v2.h
+include/wlr/types/wlr_text_input_v3.h
+include/wlr/types/wlr_touch.h
+include/wlr/types/wlr_viewporter.h
+include/wlr/types/wlr_virtual_keyboard_v1.h
+include/wlr/types/wlr_virtual_pointer_v1.h
+include/wlr/types/wlr_xcursor_manager.h
+include/wlr/types/wlr_xdg_activation_v1.h
+include/wlr/types/wlr_xdg_decoration_v1.h
+include/wlr/types/wlr_xdg_foreign_registry.h
+include/wlr/types/wlr_xdg_foreign_v1.h
+include/wlr/types/wlr_xdg_foreign_v2.h
+include/wlr/types/wlr_xdg_output_v1.h
+include/wlr/types/wlr_xdg_shell.h
+include/wlr/util/addon.h
+include/wlr/util/box.h
+include/wlr/util/edges.h
+include/wlr/util/log.h
+include/wlr/util/region.h
+include/wlr/version.h
+include/wlr/xcursor.h
+%%X11%%include/wlr/xwayland.h
+%%X11%%include/wlr/xwayland/server.h
+%%X11%%include/wlr/xwayland/shell.h
+%%X11%%include/wlr/xwayland/xwayland.h
+lib/libwlroots.so
+lib/libwlroots.so.12
+libdata/pkgconfig/wlroots.pc