aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-03-04 00:39:14 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-03-04 05:40:25 +0000
commit27c6b39534f6c1f140640641abe8d8e8f1357e01 (patch)
treea47a8238bb861726b0b191615e774ef317273482
parent2c55f46df85c03b2af6bd1b7c3560c5b034db0d0 (diff)
downloadports-27c6b39534f6c1f140640641abe8d8e8f1357e01.tar.gz
ports-27c6b39534f6c1f140640641abe8d8e8f1357e01.zip
misc/qt6ct: new port -- Qt6 Configuration Tool
This program allows users to configure Qt6 settings (theme, font, icons, etc.) under DE/WM without Qt integration. WWW: https://github.com/trialuser02/qt6ct
-rw-r--r--misc/Makefile1
-rw-r--r--misc/qt6ct/Makefile26
-rw-r--r--misc/qt6ct/distinfo3
-rw-r--r--misc/qt6ct/pkg-descr2
-rw-r--r--misc/qt6ct/pkg-message8
-rw-r--r--misc/qt6ct/pkg-plist17
6 files changed, 57 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 10012d3550f6..abb7ac05afd9 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -477,6 +477,7 @@
SUBDIR += qt5ct
SUBDIR += qt6-doc
SUBDIR += qt6-examples
+ SUBDIR += qt6ct
SUBDIR += quantum++
SUBDIR += raspberrypi-gpioshutdown
SUBDIR += raspberrypi-userland
diff --git a/misc/qt6ct/Makefile b/misc/qt6ct/Makefile
new file mode 100644
index 000000000000..8aa6a3208561
--- /dev/null
+++ b/misc/qt6ct/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= qt6ct
+DISTVERSION= 0.7
+CATEGORIES= misc
+
+MAINTAINER= tcberner@FreeBSD.org
+COMMENT= Qt 6 configuration tool
+WWW= https://github.com/trialuser02/qt6ct/tags
+
+LICENSE= BSD2CLAUSE
+
+LIB_DEPENDS= libxkbcommon.so:x11/libxkbcommon
+RUN_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:graphics/vulkan-headers
+
+USES= cmake compiler:c++11-lang gettext-runtime gl qt:6
+USE_GITHUB= yes
+GH_ACCOUNT= trialuser02
+USE_GL= gl opengl
+USE_QT= base svg tools
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}/${DOCSDIR} && \
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/misc/qt6ct/distinfo b/misc/qt6ct/distinfo
new file mode 100644
index 000000000000..22336ec26726
--- /dev/null
+++ b/misc/qt6ct/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1677888789
+SHA256 (trialuser02-qt6ct-0.7_GH0.tar.gz) = 6bc4c35e7c567908d8e123b8ccc11a55d27b5353ad035905cfa44b98c29ca862
+SIZE (trialuser02-qt6ct-0.7_GH0.tar.gz) = 151631
diff --git a/misc/qt6ct/pkg-descr b/misc/qt6ct/pkg-descr
new file mode 100644
index 000000000000..df0799779520
--- /dev/null
+++ b/misc/qt6ct/pkg-descr
@@ -0,0 +1,2 @@
+This program allows users to configure Qt6 settings (theme, font, icons, etc.)
+under DE/WM without Qt integration.
diff --git a/misc/qt6ct/pkg-message b/misc/qt6ct/pkg-message
new file mode 100644
index 000000000000..5d1e33ab822b
--- /dev/null
+++ b/misc/qt6ct/pkg-message
@@ -0,0 +1,8 @@
+[
+{ type: install
+ message: <<EOM
+To activate qt6ct settings add QT_QPA_PLATFORMTHEME=qt6ct to your
+environment.
+EOM
+}
+]
diff --git a/misc/qt6ct/pkg-plist b/misc/qt6ct/pkg-plist
new file mode 100644
index 000000000000..1fb3cbdc203b
--- /dev/null
+++ b/misc/qt6ct/pkg-plist
@@ -0,0 +1,17 @@
+bin/qt6ct
+%%QT_PLUGINDIR%%/platformthemes/libqt6ct.so
+%%QT_PLUGINDIR%%/styles/libqt6ct-style.so
+share/applications/qt6ct.desktop
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/colors/airy.conf
+%%DATADIR%%/colors/darker.conf
+%%DATADIR%%/colors/dusk.conf
+%%DATADIR%%/colors/ia_ora.conf
+%%DATADIR%%/colors/sand.conf
+%%DATADIR%%/colors/simple.conf
+%%DATADIR%%/colors/waves.conf
+%%DATADIR%%/qss/fusion-fixes.qss
+%%DATADIR%%/qss/scrollbar-simple.qss
+%%DATADIR%%/qss/sliders-simple.qss
+%%DATADIR%%/qss/tooltip-simple.qss
+%%DATADIR%%/qss/traynotification-simple.qss