aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-06-24 21:06:47 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-06-24 21:06:47 +0000
commit27da14cac70a58f98db0b18ada670a03cf1d9c3e (patch)
tree71295b3060d1abb573f7bb7df952d23d982b2efe
parent8b3595ee2ce2fefcf35b27329fa60cbb71e17567 (diff)
downloadports-27da14cac70a58f98db0b18ada670a03cf1d9c3e.tar.gz
ports-27da14cac70a58f98db0b18ada670a03cf1d9c3e.zip
net/unison: Update to 2.51.4
-rw-r--r--net/unison/Makefile7
-rw-r--r--net/unison/distinfo6
-rw-r--r--net/unison/files/patch-Makefile.OCaml19
-rw-r--r--net/unison/files/patch-fsmonitor_linux_inotify__stubs.c17
-rw-r--r--net/unison/pkg-plist1
5 files changed, 17 insertions, 33 deletions
diff --git a/net/unison/Makefile b/net/unison/Makefile
index 4636ba360cbb..fae2fb6b1647 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -1,7 +1,7 @@
# Created by: Dan Pelleg <dpelleg+unison@cs.cmu.edu>
PORTNAME= unison
-PORTVERSION= 2.51.3
+PORTVERSION= 2.51.4
DISTVERSIONPREFIX= v
CATEGORIES= net
@@ -21,7 +21,8 @@ x11_CONFLICTS_INSTALL= unison-nox11
x11_BUILD_DEPENDS= lablgtk2:x11-toolkits/ocaml-lablgtk2 \
icotool:graphics/icoutils
x11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz
x11_RUN_DEPENDS= lablgtk2:x11-toolkits/ocaml-lablgtk2
PLIST_SUB= PORTVERSION=${PORTVERSION}
@@ -36,7 +37,7 @@ ALL_TARGET= unison all
USE_GITHUB= yes
GH_ACCOUNT= bcpierce00
-DOCS= BUGS.txt NEWS README
+DOCS= NEWS README
OPTIONS_DEFINE= DOCS FSMONITOR
OPTIONS_DEFAULT?= FSMONITOR
diff --git a/net/unison/distinfo b/net/unison/distinfo
index 89b636be922f..8bd73522358f 100644
--- a/net/unison/distinfo
+++ b/net/unison/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1603288220
-SHA256 (bcpierce00-unison-v2.51.3_GH0.tar.gz) = 0c287d17f52729440b2bdc28edf4d19b2d5ea5869983d78e780d501c5866914b
-SIZE (bcpierce00-unison-v2.51.3_GH0.tar.gz) = 1370060
+TIMESTAMP = 1624546842
+SHA256 (bcpierce00-unison-v2.51.4_GH0.tar.gz) = d1ecc7581aaf2ed0f3403d4960f468acd7b9f1d92838a17c96e6d1df79b802d5
+SIZE (bcpierce00-unison-v2.51.4_GH0.tar.gz) = 1371579
diff --git a/net/unison/files/patch-Makefile.OCaml b/net/unison/files/patch-Makefile.OCaml
index 3e91ae298763..45859e189c5a 100644
--- a/net/unison/files/patch-Makefile.OCaml
+++ b/net/unison/files/patch-Makefile.OCaml
@@ -1,6 +1,6 @@
---- Makefile.OCaml.orig 2017-03-23 16:39:49 UTC
+--- Makefile.OCaml.orig 2021-06-23 14:30:30 UTC
+++ Makefile.OCaml
-@@ -32,7 +32,11 @@ ifeq ($(shell uname),OpenBSD)
+@@ -34,7 +34,11 @@ ifeq ($(shell uname),OpenBSD)
else
ifeq ($(shell uname),NetBSD)
OSARCH=NetBSD
@@ -12,21 +12,22 @@
ifeq ($(shell uname),Linux)
OSARCH=Linux
endif
-@@ -311,6 +315,10 @@ ifeq ($(OSARCH),Linux)
- -include fsmonitor/linux/Makefile src/fsmonitor/linux/Makefile
+@@ -290,6 +294,11 @@ ifeq ($(OSARCH),Linux)
+ INCLFLAGS+=-I fsmonitor -I fsmonitor/linux
endif
+ifeq ($(OSARCH),FreeBSD)
+-include fsmonitor/linux/Makefile src/fsmonitor/linux/Makefile
++INCLFLAGS+=-I fsmonitor -I fsmonitor/linux
+endif
+
- ifeq ($(OSARCH),win32gnuc)
- -include fsmonitor/windows/Makefile src/fsmonitor/windows/Makefile
- endif
-@@ -436,7 +444,7 @@ win32rc/unison.res.lib: win32rc/unison.res
+ ifeq ($(OSARCH),solaris)
+ -include fsmonitor/solaris/Makefile src/fsmonitor/solaris/Makefile
+ INCLFLAGS+=-I fsmonitor -I fsmonitor/solaris
+@@ -432,7 +441,7 @@ fswatch.cmi : ubase/prefs.cmi
%.o %.obj: %.c
- @echo "$(OCAMLOPT): $< ---> $@"
+ @echo "$(CAMLC): $< ---> $@"
- $(CAMLC) $(CAMLFLAGS) -ccopt $(OUTPUT_SEL)$(CWD)/$@ -c $(CWD)/$<
+ $(CAMLC) $(CAMLFLAGS) -ccopt $(OUTPUT_SEL)$(CWD)/$@ -c $(CFLAGS) $(CWD)/$<
diff --git a/net/unison/files/patch-fsmonitor_linux_inotify__stubs.c b/net/unison/files/patch-fsmonitor_linux_inotify__stubs.c
deleted file mode 100644
index fa0be0ade537..000000000000
--- a/net/unison/files/patch-fsmonitor_linux_inotify__stubs.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- fsmonitor/linux/inotify_stubs.c.orig 2017-03-23 16:25:03 UTC
-+++ fsmonitor/linux/inotify_stubs.c
-@@ -27,9 +27,13 @@
- #include <caml/signals.h>
- #include <caml/callback.h>
-
-+#include <sys/param.h>
-+
-+#if !defined(__FreeBSD__)
- #include <features.h>
-+#endif
-
--#if __GLIBC__ >= 2 && __GLIBC_MINOR__ >= 4
-+#if (__GLIBC__ >= 2 && __GLIBC_MINOR__ >= 4) || defined(__FreeBSD__)
- #define GLIBC_SUPPORT_INOTIFY 1
- #else
- #define GLIBC_SUPPORT_INOTIFY 0
diff --git a/net/unison/pkg-plist b/net/unison/pkg-plist
index 9712bef013c6..65166904f178 100644
--- a/net/unison/pkg-plist
+++ b/net/unison/pkg-plist
@@ -3,6 +3,5 @@ bin/unison
%%X11%%share/applications/unison.desktop
%%X11%%bin/unison-text
%%X11%%share/pixmaps/unison.png
-%%PORTDOCS%%%%DOCSDIR%%/BUGS.txt
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README