aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 15:28:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 15:55:49 +0000
commit27ef9941bc2dcc15da30ae8f6c0b1cad40a03aeb (patch)
treee718b8dd508865036d6ac730276c6f7c69934649
parentffd7f1117ff0f4d0bd56ec8c12c5db14794636a9 (diff)
downloadports-27ef9941bc2dcc15da30ae8f6c0b1cad40a03aeb.tar.gz
ports-27ef9941bc2dcc15da30ae8f6c0b1cad40a03aeb.zip
databases/py-asyncmy: Add py-asyncmy 0.2.0
asyncmy is a fast asyncio MySQL driver, which reuse most of pymysql and aiomysql but rewrite core protocol with cython to speedup. WWW: https://github.com/long2ice/asyncmy
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-asyncmy/Makefile21
-rw-r--r--databases/py-asyncmy/distinfo3
-rw-r--r--databases/py-asyncmy/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 2c84d32b33df..77055c0b0356 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -749,6 +749,7 @@
SUBDIR += py-aiosqlite
SUBDIR += py-alembic
SUBDIR += py-apsw
+ SUBDIR += py-asyncmy
SUBDIR += py-asyncpg
SUBDIR += py-berkeleydb
SUBDIR += py-bsddb3
diff --git a/databases/py-asyncmy/Makefile b/databases/py-asyncmy/Makefile
new file mode 100644
index 000000000000..ad1f41bb6931
--- /dev/null
+++ b/databases/py-asyncmy/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= asyncmy
+PORTVERSION= 0.2.0
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fast asyncio MySQL driver
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent cython distutils
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/databases/py-asyncmy/distinfo b/databases/py-asyncmy/distinfo
new file mode 100644
index 000000000000..aa5ee43eea25
--- /dev/null
+++ b/databases/py-asyncmy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632664284
+SHA256 (asyncmy-0.2.0.tar.gz) = b0c8c13d5d408a76eb65d767096d02757cd4e2b364c1c81384521cb8021cc160
+SIZE (asyncmy-0.2.0.tar.gz) = 60411
diff --git a/databases/py-asyncmy/pkg-descr b/databases/py-asyncmy/pkg-descr
new file mode 100644
index 000000000000..0249ef17c154
--- /dev/null
+++ b/databases/py-asyncmy/pkg-descr
@@ -0,0 +1,4 @@
+asyncmy is a fast asyncio MySQL driver, which reuse most of pymysql and aiomysql
+but rewrite core protocol with cython to speedup.
+
+WWW: https://github.com/long2ice/asyncmy