aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-05-22 04:37:13 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-05-22 04:37:13 +0000
commit2835e556f23ebb9dddf778b630b0409e33e2112d (patch)
treed73cd853bfc7ea606b6a19b6676bdbabd940bd52
parent8f948fc5785ba6d469dd89015cdff81e67bb8e56 (diff)
downloadports-2835e556f23ebb9dddf778b630b0409e33e2112d.tar.gz
ports-2835e556f23ebb9dddf778b630b0409e33e2112d.zip
devel/py-jupyterlab-server: Update to 2.14.0
-rw-r--r--devel/py-jupyterlab-server/Makefile6
-rw-r--r--devel/py-jupyterlab-server/distinfo6
-rw-r--r--devel/py-jupyterlab-server/files/patch-setup.cfg11
-rw-r--r--devel/py-jupyterlab-server/files/setup.py58
4 files changed, 65 insertions, 16 deletions
diff --git a/devel/py-jupyterlab-server/Makefile b/devel/py-jupyterlab-server/Makefile
index df6daa06a7de..67ffb673c34a 100644
--- a/devel/py-jupyterlab-server/Makefile
+++ b/devel/py-jupyterlab-server/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= jupyterlab-server
-PORTVERSION= 2.13.0
+PORTVERSION= 2.14.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,6 @@ COMMENT= JupyterLab Server
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jupyter-server>=1.8<2:devel/py-jupyter-server@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=0:devel/py-babel@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Jinja2>=3.0.1:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}json5>=0:devel/py-json5@${PY_FLAVOR} \
@@ -39,4 +38,7 @@ OPENAPI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openapi-core>=0.14.2:devel/py-openap
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=3.6:devel/py-importlib-metadata@${PY_FLAVOR}
.endif
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+
.include <bsd.port.post.mk>
diff --git a/devel/py-jupyterlab-server/distinfo b/devel/py-jupyterlab-server/distinfo
index 50a0b62063f6..7d0fccc36b40 100644
--- a/devel/py-jupyterlab-server/distinfo
+++ b/devel/py-jupyterlab-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1650970113
-SHA256 (jupyterlab_server-2.13.0.tar.gz) = 2040298a133458aa22f287a877d6bb91ff973f6298d562264f9f7b75e92a5ace
-SIZE (jupyterlab_server-2.13.0.tar.gz) = 63896
+TIMESTAMP = 1653151100
+SHA256 (jupyterlab_server-2.14.0.tar.gz) = b04eaf68fe1ef96f70dd38b256417abe0b6ba1a07dd8ca0c97da5b0ebade57ec
+SIZE (jupyterlab_server-2.14.0.tar.gz) = 62704
diff --git a/devel/py-jupyterlab-server/files/patch-setup.cfg b/devel/py-jupyterlab-server/files/patch-setup.cfg
deleted file mode 100644
index 4813f4a1d3d1..000000000000
--- a/devel/py-jupyterlab-server/files/patch-setup.cfg
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.cfg.orig 2022-04-19 21:26:34 UTC
-+++ setup.cfg
-@@ -37,7 +37,7 @@ python_requires = >=3.7
- install_requires =
- babel
- importlib_metadata>=3.6;python_version<"3.10"
-- jinja2>=3.0.3
-+ jinja2>=3.0.1
- json5
- jsonschema>=3.0.1
- jupyter_server>=1.8,<2
diff --git a/devel/py-jupyterlab-server/files/setup.py b/devel/py-jupyterlab-server/files/setup.py
new file mode 100644
index 000000000000..79bce4a35bb0
--- /dev/null
+++ b/devel/py-jupyterlab-server/files/setup.py
@@ -0,0 +1,58 @@
+# -*- coding: utf-8 -*-
+from setuptools import setup
+
+setup(
+ name='jupyterlab-server',
+ version='%%PORTVERSION%%',
+ description='A set of server components for JupyterLab and JupyterLab like applications.',
+ long_description='# jupyterlab server\n\n[![Coverage](https://codecov.io/gh/jupyterlab/jupyterlab_server/branch/master/graph/badge.svg)](https://codecov.io/gh/jupyterlab/jupyterlab_server)\n[![Build Status](https://github.com/jupyterlab/jupyterlab_server/workflows/Tests/badge.svg?branch=master)](https://github.com/jupyterlab/jupyterlab_server/actions?query=branch%3Amaster+workflow%3A%22Tests%22)\n[![Documentation Status](https://readthedocs.org/projects/jupyterlab_server/badge/?version=stable)](http://jupyterlab_server.readthedocs.io/en/stable/)\n\n## Motivation\n\nJupyterLab Server sits between JupyterLab and Jupyter Server, and provides a\nset of REST API handlers and utilities that are used by JupyterLab. It is a separate project in order to\naccommodate creating JupyterLab-like applications from a more limited scope.\n\n## Install\n\n`pip install jupyterlab_server`\n\nTo include optional `openapi` dependencies, use:\n\n`pip install jupyterlab_server[openapi]`\n\nTo include optional `pytest_plugin` dependencies, use:\n\n`pip install jupyterlab_server[test]`\n\n## Usage\n\nSee the full documentation for [API docs](https://jupyterlab-server.readthedocs.io/en/stable/api/index.html) and [REST endpoint descriptions](https://jupyterlab-server.readthedocs.io/en/stable/api/rest.html).\n\n## Extending the Application\n\nSubclass the `LabServerApp` and provide additional traits and handlers as appropriate for your application.\n\n## Contribution\n\nPlease see `CONTRIBUTING.md` for details.\n',
+ author_email='Jupyter Development Team <jupyter@googlegroups.com>',
+ classifiers=[
+ 'Framework :: Jupyter',
+ 'Framework :: Jupyter :: JupyterLab',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Science/Research',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: BSD License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3 :: Only',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ ],
+ install_requires=[
+ 'babel',
+ 'importlib-metadata>=3.6; python_version < "3.10"',
+ 'jinja2>=3.0.1',
+ 'json5',
+ 'jsonschema>=3.0.1',
+ 'jupyter-server<2,>=1.8',
+ 'packaging',
+ 'requests',
+ ],
+ extras_require={
+ 'openapi': [
+ 'openapi-core>=0.14.2',
+ 'ruamel-yaml',
+ ],
+ 'test': [
+ 'codecov',
+ 'ipykernel',
+ 'jupyter-server[test]',
+ 'openapi-core>=0.14.2',
+ 'openapi-spec-validator<0.5',
+ 'pytest-console-scripts',
+ 'pytest-cov',
+ 'pytest>=5.3.2',
+ 'ruamel-yaml',
+ 'strict-rfc3339',
+ ],
+ },
+ packages=[
+ 'jupyterlab_server',
+ 'tests',
+ 'tests.translations.jupyterlab-language-pack-es_CO.jupyterlab_language_pack_es_CO',
+ 'tests.translations.jupyterlab-some-package.jupyterlab_some_package',
+ ],
+)