aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-12-18 14:13:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-12-18 14:13:20 +0000
commit2843d48c80229e38cc2f977210a09e9321f511be (patch)
tree728a06be7ff034a712908669dcf858ede6dbac45
parent3fd7e3d77ab8a9331f5eb3e04f342f0949926ff1 (diff)
downloadports-2843d48c80229e38cc2f977210a09e9321f511be.tar.gz
ports-2843d48c80229e38cc2f977210a09e9321f511be.zip
This library can read and write CSV files, including all extensions used by
Excel - eg. quotes, newlines, 8 bit characters in fields, "0 etc. WWW: http://merjis.com/developers/csv PR: ports/118801 Submitted by: Thomas V. Crimi <tcrimi@procida.us>
Notes
Notes: svn path=/head/; revision=203985
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ocaml-csv/Makefile25
-rw-r--r--textproc/ocaml-csv/distinfo3
-rw-r--r--textproc/ocaml-csv/files/patch-Makefile39
-rw-r--r--textproc/ocaml-csv/pkg-descr4
5 files changed, 72 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index a93ff74c8960..f1991edfd49f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -331,6 +331,7 @@
SUBDIR += nunnimcax
SUBDIR += nux
SUBDIR += ny-aspell
+ SUBDIR += ocaml-csv
SUBDIR += ocaml-expat
SUBDIR += ocaml-pxp
SUBDIR += ocaml-yaxpo
diff --git a/textproc/ocaml-csv/Makefile b/textproc/ocaml-csv/Makefile
new file mode 100644
index 000000000000..50b57788f761
--- /dev/null
+++ b/textproc/ocaml-csv/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: ocaml-calendar
+# Date created: Feb 26, 2007
+# Whom: Jaap Boender <jaapb@kerguelen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ocaml-csv
+PORTVERSION= 1.1.6
+CATEGORIES= textproc
+MASTER_SITES= http://merjis.com/_file/
+
+MAINTAINER= tcrimi@gmail.com
+COMMENT= An OCaml library to read and write CSV files
+
+BUILD_DEPENDS= ${LOCALBASE}/${OCAML_SITELIBDIR}/extlib:${PORTSDIR}/devel/ocaml-extlib
+
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
+OCAML_PKGDIRS= csv
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+.include <bsd.port.post.mk>
diff --git a/textproc/ocaml-csv/distinfo b/textproc/ocaml-csv/distinfo
new file mode 100644
index 000000000000..ecaaa6291cb3
--- /dev/null
+++ b/textproc/ocaml-csv/distinfo
@@ -0,0 +1,3 @@
+MD5 (ocaml-csv-1.1.6.tar.gz) = a91851438f9540b1a445087a4d409507
+SHA256 (ocaml-csv-1.1.6.tar.gz) = ff37843ab5e055950e58a20b8a1989a303f09588aa8547a5b98d6dddb5bee799
+SIZE (ocaml-csv-1.1.6.tar.gz) = 13944
diff --git a/textproc/ocaml-csv/files/patch-Makefile b/textproc/ocaml-csv/files/patch-Makefile
new file mode 100644
index 000000000000..72502f216806
--- /dev/null
+++ b/textproc/ocaml-csv/files/patch-Makefile
@@ -0,0 +1,39 @@
+--- Makefile.orig 2007-12-17 17:56:16.458954606 -0500
++++ Makefile 2007-12-17 17:54:34.177261751 -0500
+@@ -5,11 +5,11 @@
+ # To enable support for Extlib, also uncomment 'open ExtList' at the top
+ # of file csv.ml.
+
+-OCAMLCINCS :=
+-#OCAMLCINCS := -package extlib
++#OCAMLCINCS :=
++OCAMLCINCS := -package extlib
+ OCAMLCFLAGS := -g
+-OCAMLCLIBS :=
+-#OCAMLCLIBS := -linkpkg
++#OCAMLCLIBS :=
++OCAMLCLIBS := -linkpkg
+
+ OCAMLOPTINCS := $(OCAMLCINCS)
+ OCAMLOPTFLAGS :=
+@@ -23,6 +23,20 @@
+
+ all: csv.cma csv.cmxa example csvtool
+
++## The install and META targets were borrowed from Richard W.M. Jones' RPM patch
++install: all META
++ ocamlfind install csv META *.mli $(wildcard *.a) csv.cmi $(wildcard csv.cmx) *.cma $(wildcard *.cmxa)
++# install csvtool ${DESTDIR}${BINDIR}
++
++META:
++ rm -f $@
++ echo 'version="${VERSION}"' >> $@
++ echo 'description="CSV library"' >> $@
++ echo 'archive(byte)="csv.cma"' >> $@
++ echo 'archive(native)="csv.cmxa"' >> $@
++ echo 'requires="extlib"' >> $@
++
++
+ csv.cma: $(OBJS)
+ ocamlfind ocamlc $(OCAMLCINCS) $(OCAMLCFLAGS) -a -o $@ $^
+
diff --git a/textproc/ocaml-csv/pkg-descr b/textproc/ocaml-csv/pkg-descr
new file mode 100644
index 000000000000..6934a0a945da
--- /dev/null
+++ b/textproc/ocaml-csv/pkg-descr
@@ -0,0 +1,4 @@
+This library can read and write CSV files, including all extensions used by
+Excel - eg. quotes, newlines, 8 bit characters in fields, "0 etc.
+
+WWW: http://merjis.com/developers/csv