aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-16 22:55:49 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-16 22:55:49 +0000
commit2868f3cea873dac17620f80c7c4dd2069876dc1d (patch)
treec35f3ded6317f3b57292a5d353718bd7037c60a6
parent483990fcf2585fc23f0c9d179e9dfd1b85082985 (diff)
downloadports-2868f3cea873dac17620f80c7c4dd2069876dc1d.tar.gz
ports-2868f3cea873dac17620f80c7c4dd2069876dc1d.zip
- Fix build with raptor2.
- Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=283628
-rw-r--r--editors/morla/Makefile3
-rw-r--r--editors/morla/files/patch-src__query.c27
2 files changed, 29 insertions, 1 deletions
diff --git a/editors/morla/Makefile b/editors/morla/Makefile
index f8a3d6732a90..9ff59076e101 100644
--- a/editors/morla/Makefile
+++ b/editors/morla/Makefile
@@ -7,7 +7,7 @@
PORTNAME= morla
PORTVERSION= 0.16.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= editors textproc
MASTER_SITES= http://www.morlardf.net/src/ \
http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
@@ -17,6 +17,7 @@ COMMENT= A RDF editor
LIB_DEPENDS= nxml.18:${PORTSDIR}/textproc/libnxml \
rdf.0:${PORTSDIR}/textproc/redland \
+ raptor2.0:${PORTSDIR}/textproc/raptor2 \
curl.6:${PORTSDIR}/ftp/curl
BUILD_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
diff --git a/editors/morla/files/patch-src__query.c b/editors/morla/files/patch-src__query.c
new file mode 100644
index 000000000000..094afece5197
--- /dev/null
+++ b/editors/morla/files/patch-src__query.c
@@ -0,0 +1,27 @@
+--- ./src/query.c.orig 2011-10-02 23:46:35.559557849 +0200
++++ ./src/query.c 2011-10-02 23:50:37.359563100 +0200
+@@ -1400,7 +1400,11 @@
+ #endif
+
+ uri_string = raptor_uri_filename_to_uri_string ("");
++#ifdef USE_RASQAL_OLD
+ base_uri = raptor_new_uri (uri_string);
++#else
++ base_uri = raptor_new_uri (rasqal, uri_string);
++#endif
+ raptor_free_memory (uri_string);
+ }
+
+@@ -1419,11 +1423,7 @@
+
+ if (query)
+ {
+- rasqal_query_set_fatal_error_handler (query, NULL,
+- query_rasqal_error);
+- rasqal_query_set_error_handler (query, NULL, query_rasqal_error);
+- rasqal_query_set_warning_handler (query, NULL,
+- query_rasqal_warning);
++ rasqal_world_set_log_handler (query, NULL, query_rasqal_error);
+
+ if (rasqal_query_prepare
+ (query, (const unsigned char *) buf, base_uri))