aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-02-20 15:33:42 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-02-20 15:33:42 +0000
commit28b870202f4134ebc88b2499b95c5b1feaa3e74a (patch)
treee30bcf1656b58bbf81ea39ff1b2005f5366aeb22
parentf3fd12b4595ef001e8e6359a40b0a477bb86ef67 (diff)
downloadports-28b870202f4134ebc88b2499b95c5b1feaa3e74a.tar.gz
ports-28b870202f4134ebc88b2499b95c5b1feaa3e74a.zip
Update to version 1.3.3
PR: 25209 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=38516
-rw-r--r--converters/mimepp/Makefile27
-rw-r--r--converters/mimepp/distinfo2
-rw-r--r--converters/mimepp/files/Makefile54
-rw-r--r--converters/mimepp/pkg-plist155
4 files changed, 118 insertions, 120 deletions
diff --git a/converters/mimepp/Makefile b/converters/mimepp/Makefile
index d1e3122f87b9..9ddffd6e9cff 100644
--- a/converters/mimepp/Makefile
+++ b/converters/mimepp/Makefile
@@ -5,28 +5,29 @@
# $FreeBSD$
#
-PORTNAME= mimepp
-PORTVERSION= 1.3.1
-CATEGORIES= converters
-MASTER_SITES= http://www.hunnysoft.com/mimepp/
+PORTNAME= mimepp
+PORTVERSION= 1.3.3
+CATEGORIES= converters
+MASTER_SITES= http://www.hunnysoft.com/mimepp/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-MAKEFILE= makefile-unix
-ALL_TARGET= default
+MAKEFILE= makefile-unix
+ALL_TARGET= default
do-install:
${INSTALL_DATA} ${WRKSRC}/dev/*.a ${PREFIX}/lib
@${MKDIR} ${PREFIX}/include/mimepp
${INSTALL_DATA} ${WRKSRC}/src/mimepp/*.h ${PREFIX}/include/mimepp
- @${MKDIR} ${PREFIX}/share/examples/mimepp
- ${INSTALL_DATA} ${WRKSRC}/examples/*.cpp ${PREFIX}/share/examples/mimepp
- ${INSTALL_DATA} ${WRKSRC}/examples/*.h ${PREFIX}/share/examples/mimepp
- ${INSTALL_DATA} ${WRKSRC}/examples/*.txt ${PREFIX}/share/examples/mimepp
- ${INSTALL_DATA} ${WRKSRC}/examples/makefile-unix ${PREFIX}/share/examples/mimepp
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/mimepp
- ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/mimepp
+ ${TAR} -C ${WRKSRC}/doc -cf - . | \
+ ${TAR} -C ${PREFIX}/share/doc/mimepp -xf -
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/doc/mimepp
+ @${MKDIR} ${PREFIX}/share/examples/mimepp
+ ${TAR} -C ${WRKSRC}/examples -cf - . | \
+ ${TAR} -C ${PREFIX}/share/examples/mimepp -xf -
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/examples/mimepp
.endif
.include <bsd.port.mk>
diff --git a/converters/mimepp/distinfo b/converters/mimepp/distinfo
index 32336f8b64f0..f26179e958f4 100644
--- a/converters/mimepp/distinfo
+++ b/converters/mimepp/distinfo
@@ -1 +1 @@
-MD5 (mimepp-1.3.1.tar.gz) = 4de767cfbdc7fd2514dd372e2708b573
+MD5 (mimepp-1.3.3.tar.gz) = e963dadb38e4dbc9f49368696aad11ca
diff --git a/converters/mimepp/files/Makefile b/converters/mimepp/files/Makefile
deleted file mode 100644
index a1ca75df3237..000000000000
--- a/converters/mimepp/files/Makefile
+++ /dev/null
@@ -1,54 +0,0 @@
-# UNIX makefile for MIME++ example programs
-
-# $Revision: 3.0 $
-# $Date: 1997-07-28 06:59:15-05 $
-
-# C++ compiler driver
-# CXX = CC
-CXX = g++
-
-# C++ compiler flags (except -c, -I, -L, -l)
-#
-# Add -g here if you want debugger symbols included
-CXXFLAGS = -O
-
-# The search path for include files. Change only if necessary.
-INC_PATH = -I/usr/local/include
-
-# The search path for library files. Change only if necessary.
-LIB_PATH = -L/usr/local/lib
-
-# Libraries to be included. Change only if necessary.
-LIBS =
-
-# The library directory where MIME++ (libmimepp.a) will be installed.
-LIB_DIR = /usr/local/lib
-
-# The include directory where MIME++ include files should be installed.
-# The include files will actually be copied to $(INC_DIR)/mimepp/.
-INC_DIR = /usr/local/include
-
-all: exampl01 exampl02 exampl03 exampl04 exampl05
-
-exampl01 : libmimepp.a exampl01.o basicmsg.o
- $(CXX) -o exampl01 exampl01.o basicmsg.o $(LIB_PATH) -lmimepp $(LIBS)
-
-exampl02 : libmimepp.a exampl02.o basicmsg.o
- $(CXX) -o exampl02 exampl02.o basicmsg.o $(LIB_PATH) -lmimepp $(LIBS)
-
-exampl03 : libmimepp.a exampl03.o multipar.o basicmsg.o
- $(CXX) -o exampl03 exampl03.o multipar.o basicmsg.o $(LIB_PATH) -lmimepp $(LIBS)
-
-exampl04 : libmimepp.a exampl04.o multipar.o basicmsg.o
- $(CXX) -o exampl04 exampl04.o multipar.o basicmsg.o $(LIB_PATH) -lmimepp $(LIBS)
-
-exampl05 : libmimepp.a exampl05.o attach.o multipar.o basicmsg.o
- $(CXX) -o exampl05 exampl05.o attach.o multipar.o basicmsg.o $(LIB_PATH) -lmimepp $(LIBS)
-
-clean:
- -rm *.o exampl0? *.out
-
-.SUFFIXES: .cpp
-
-.cpp.o:
- $(CXX) -c $(CXXFLAGS) $< $(INC_PATH)
diff --git a/converters/mimepp/pkg-plist b/converters/mimepp/pkg-plist
index 619573260b78..bf65cb1c5b26 100644
--- a/converters/mimepp/pkg-plist
+++ b/converters/mimepp/pkg-plist
@@ -43,56 +43,107 @@ include/mimepp/uuencode.h
lib/libmimepp_core.a
lib/libmimepp_net.a
lib/libmimepp_util.a
-share/doc/mimepp/address.html
-share/doc/mimepp/addrlist.html
-share/doc/mimepp/applfile.html
-share/doc/mimepp/binhex.html
-share/doc/mimepp/body.html
-share/doc/mimepp/bodypart.html
-share/doc/mimepp/boyermor.html
-share/doc/mimepp/datetime.html
-share/doc/mimepp/disptype.html
-share/doc/mimepp/encoded.html
-share/doc/mimepp/entity.html
-share/doc/mimepp/field.html
-share/doc/mimepp/fieldbdy.html
-share/doc/mimepp/group.html
-share/doc/mimepp/headers.html
-share/doc/mimepp/mailbox.html
-share/doc/mimepp/mboxlist.html
-share/doc/mimepp/mechansm.html
-share/doc/mimepp/mediatyp.html
-share/doc/mimepp/message.html
-share/doc/mimepp/mimepp.html
-share/doc/mimepp/msgcmp.html
-share/doc/mimepp/msgid.html
-share/doc/mimepp/nntp.html
-share/doc/mimepp/param.html
-share/doc/mimepp/pop.html
-share/doc/mimepp/protocol.html
-share/doc/mimepp/smtp.html
-share/doc/mimepp/stamp.html
-share/doc/mimepp/string.html
-share/doc/mimepp/text.html
-share/doc/mimepp/util.html
-share/doc/mimepp/uuencode.html
-share/examples/mimepp/attach.cpp
-share/examples/mimepp/attach.h
-share/examples/mimepp/basicmsg.cpp
-share/examples/mimepp/basicmsg.h
-share/examples/mimepp/exampl01.cpp
-share/examples/mimepp/exampl01.txt
-share/examples/mimepp/exampl02.cpp
-share/examples/mimepp/exampl02.txt
-share/examples/mimepp/exampl03.cpp
-share/examples/mimepp/exampl03.txt
-share/examples/mimepp/exampl04.cpp
-share/examples/mimepp/exampl04.txt
-share/examples/mimepp/exampl05.cpp
-share/examples/mimepp/exampl05.txt
-share/examples/mimepp/makefile-unix
-share/examples/mimepp/multipar.cpp
-share/examples/mimepp/multipar.h
-@dirrm share/examples/mimepp
-@dirrm share/doc/mimepp
+%%PORTDOCS%%share/doc/mimepp/address.htm
+%%PORTDOCS%%share/doc/mimepp/addrlist.htm
+%%PORTDOCS%%share/doc/mimepp/applfile.htm
+%%PORTDOCS%%share/doc/mimepp/binhex.htm
+%%PORTDOCS%%share/doc/mimepp/body.htm
+%%PORTDOCS%%share/doc/mimepp/bodypart.htm
+%%PORTDOCS%%share/doc/mimepp/boyermor.htm
+%%PORTDOCS%%share/doc/mimepp/datetime.htm
+%%PORTDOCS%%share/doc/mimepp/disptype.htm
+%%PORTDOCS%%share/doc/mimepp/encoded.htm
+%%PORTDOCS%%share/doc/mimepp/entity.htm
+%%PORTDOCS%%share/doc/mimepp/field.htm
+%%PORTDOCS%%share/doc/mimepp/fieldbdy.htm
+%%PORTDOCS%%share/doc/mimepp/group.htm
+%%PORTDOCS%%share/doc/mimepp/headers.htm
+%%PORTDOCS%%share/doc/mimepp/mailbox.htm
+%%PORTDOCS%%share/doc/mimepp/mboxlist.htm
+%%PORTDOCS%%share/doc/mimepp/mechansm.htm
+%%PORTDOCS%%share/doc/mimepp/mediatyp.htm
+%%PORTDOCS%%share/doc/mimepp/message.htm
+%%PORTDOCS%%share/doc/mimepp/mimepp.htm
+%%PORTDOCS%%share/doc/mimepp/msgcmp.htm
+%%PORTDOCS%%share/doc/mimepp/msgid.htm
+%%PORTDOCS%%share/doc/mimepp/nntp.htm
+%%PORTDOCS%%share/doc/mimepp/param.htm
+%%PORTDOCS%%share/doc/mimepp/pop.htm
+%%PORTDOCS%%share/doc/mimepp/protocol.htm
+%%PORTDOCS%%share/doc/mimepp/smtp.htm
+%%PORTDOCS%%share/doc/mimepp/stamp.htm
+%%PORTDOCS%%share/doc/mimepp/string.htm
+%%PORTDOCS%%share/doc/mimepp/text.htm
+%%PORTDOCS%%share/doc/mimepp/util.htm
+%%PORTDOCS%%share/doc/mimepp/uuencode.htm
+%%PORTDOCS%%share/examples/mimepp/00-README.txt
+%%PORTDOCS%%share/examples/mimepp/attach.cpp
+%%PORTDOCS%%share/examples/mimepp/attach.h
+%%PORTDOCS%%share/examples/mimepp/basicmsg.cpp
+%%PORTDOCS%%share/examples/mimepp/basicmsg.h
+%%PORTDOCS%%share/examples/mimepp/email/00-README.txt
+%%PORTDOCS%%share/examples/mimepp/email/EmailAddress.cpp
+%%PORTDOCS%%share/examples/mimepp/email/EmailAddress.h
+%%PORTDOCS%%share/examples/mimepp/email/EmailAddressList.cpp
+%%PORTDOCS%%share/examples/mimepp/email/EmailAddressList.h
+%%PORTDOCS%%share/examples/mimepp/email/EmailAttach.cpp
+%%PORTDOCS%%share/examples/mimepp/email/EmailAttach.h
+%%PORTDOCS%%share/examples/mimepp/email/EmailAttachList.cpp
+%%PORTDOCS%%share/examples/mimepp/email/EmailAttachList.h
+%%PORTDOCS%%share/examples/mimepp/email/EmailDate.cpp
+%%PORTDOCS%%share/examples/mimepp/email/EmailDate.h
+%%PORTDOCS%%share/examples/mimepp/email/EmailMessage.cpp
+%%PORTDOCS%%share/examples/mimepp/email/EmailMessage.h
+%%PORTDOCS%%share/examples/mimepp/email/EmailText.cpp
+%%PORTDOCS%%share/examples/mimepp/email/EmailText.h
+%%PORTDOCS%%share/examples/mimepp/email/Makefile
+%%PORTDOCS%%share/examples/mimepp/email/create_ex.cpp
+%%PORTDOCS%%share/examples/mimepp/email/html_ex.cpp
+%%PORTDOCS%%share/examples/mimepp/exampl01.cpp
+%%PORTDOCS%%share/examples/mimepp/exampl01.txt
+%%PORTDOCS%%share/examples/mimepp/exampl02.cpp
+%%PORTDOCS%%share/examples/mimepp/exampl02.txt
+%%PORTDOCS%%share/examples/mimepp/exampl03.cpp
+%%PORTDOCS%%share/examples/mimepp/exampl03.txt
+%%PORTDOCS%%share/examples/mimepp/exampl04.cpp
+%%PORTDOCS%%share/examples/mimepp/exampl04.txt
+%%PORTDOCS%%share/examples/mimepp/exampl05.cpp
+%%PORTDOCS%%share/examples/mimepp/exampl05.txt
+%%PORTDOCS%%share/examples/mimepp/makefile-aix
+%%PORTDOCS%%share/examples/mimepp/makefile-hpux
+%%PORTDOCS%%share/examples/mimepp/makefile-linux
+%%PORTDOCS%%share/examples/mimepp/makefile-unix
+%%PORTDOCS%%share/examples/mimepp/makefile-vc
+%%PORTDOCS%%share/examples/mimepp/multipar.cpp
+%%PORTDOCS%%share/examples/mimepp/multipar.h
+%%PORTDOCS%%share/examples/mimepp/pop/00-README.txt
+%%PORTDOCS%%share/examples/mimepp/pop/Makefile
+%%PORTDOCS%%share/examples/mimepp/pop/pop_ex.cpp
+%%PORTDOCS%%share/examples/mimepp/smtp/00-README.txt
+%%PORTDOCS%%share/examples/mimepp/smtp/Makefile
+%%PORTDOCS%%share/examples/mimepp/smtp/smtp.cpp
+%%PORTDOCS%%share/examples/mimepp/smtp/smtp.h
+%%PORTDOCS%%share/examples/mimepp/smtp/smtp_ex.cpp
+%%PORTDOCS%%share/examples/mimepp/smtp/test.txt
+%%PORTDOCS%%share/examples/mimepp/text/00-README.txt
+%%PORTDOCS%%share/examples/mimepp/text/Makefile
+%%PORTDOCS%%share/examples/mimepp/text/subject_ex.cpp
+%%PORTDOCS%%share/examples/mimepp/tree/00-README.txt
+%%PORTDOCS%%share/examples/mimepp/tree/Makefile
+%%PORTDOCS%%share/examples/mimepp/tree/tree_ex.cpp
+%%PORTDOCS%%share/examples/mimepp/uuencode/00-README.txt
+%%PORTDOCS%%share/examples/mimepp/uuencode/Makefile
+%%PORTDOCS%%share/examples/mimepp/uuencode/msg-1.txt
+%%PORTDOCS%%share/examples/mimepp/uuencode/msg-2.txt
+%%PORTDOCS%%share/examples/mimepp/uuencode/msg-3.txt
+%%PORTDOCS%%share/examples/mimepp/uuencode/msg-4.txt
+%%PORTDOCS%%share/examples/mimepp/uuencode/uuencode_ex.cpp
+%%PORTDOCS%%@dirrm share/examples/mimepp/uuencode
+%%PORTDOCS%%@dirrm share/examples/mimepp/tree
+%%PORTDOCS%%@dirrm share/examples/mimepp/text
+%%PORTDOCS%%@dirrm share/examples/mimepp/smtp
+%%PORTDOCS%%@dirrm share/examples/mimepp/pop
+%%PORTDOCS%%@dirrm share/examples/mimepp/email
+%%PORTDOCS%%@dirrm share/examples/mimepp
+%%PORTDOCS%%@dirrm share/doc/mimepp
@dirrm include/mimepp