aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2021-05-03 18:22:01 +0000
committerStefan Eßer <se@FreeBSD.org>2021-05-03 18:26:12 +0000
commit295be8e6e715068e019ee0447fe40afed6ece0d3 (patch)
treed9e73094b65a0529a8e52211bc16707b107b4ae0
parent2a92ce401f52d3744457b7782cd0fa4a14a66ae2 (diff)
downloadports-295be8e6e715068e019ee0447fe40afed6ece0d3.tar.gz
ports-295be8e6e715068e019ee0447fe40afed6ece0d3.zip
security/ncrack: resurrect and update to version 0.7
The port has been recovered after deletion and upgraded to the latest version available on Github. The build has been tested with base and ports versions of openssl.
-rw-r--r--security/Makefile1
-rw-r--r--security/ncrack/Makefile22
-rw-r--r--security/ncrack/distinfo3
-rw-r--r--security/ncrack/files/patch-opensshlib_umac.c11
-rw-r--r--security/ncrack/files/patch-portable__endian.h32
-rw-r--r--security/ncrack/pkg-descr7
-rw-r--r--security/ncrack/pkg-plist11
7 files changed, 87 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7d47f21d3782..8a554120d73b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -365,6 +365,7 @@
SUBDIR += mussh
SUBDIR += n2n
SUBDIR += nacl
+ SUBDIR += ncrack
SUBDIR += ncrypt
SUBDIR += nettle
SUBDIR += nextcloud-end_to_end_encryption
diff --git a/security/ncrack/Makefile b/security/ncrack/Makefile
new file mode 100644
index 000000000000..04cb8e20e660
--- /dev/null
+++ b/security/ncrack/Makefile
@@ -0,0 +1,22 @@
+# Created by: David E. Thiel <lx@FreeBSD.org>
+
+PORTNAME= ncrack
+DISTVERSION= 0.7
+CATEGORIES= security
+
+MAINTAINER= se@FreeBSD.org
+COMMENT= High-speed network authentication cracking tool
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake ssl
+USE_GITHUB= yes
+GH_ACCOUNT= nmap
+
+GNU_CONFIGURE= yes
+
+CPPFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+
+.include <bsd.port.mk>
diff --git a/security/ncrack/distinfo b/security/ncrack/distinfo
new file mode 100644
index 000000000000..7d8bd94676c5
--- /dev/null
+++ b/security/ncrack/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1620063990
+SHA256 (nmap-ncrack-0.7_GH0.tar.gz) = f3f971cd677c4a0c0668cb369002c581d305050b3b0411e18dd3cb9cc270d14a
+SIZE (nmap-ncrack-0.7_GH0.tar.gz) = 8586213
diff --git a/security/ncrack/files/patch-opensshlib_umac.c b/security/ncrack/files/patch-opensshlib_umac.c
new file mode 100644
index 000000000000..d76f89666ca1
--- /dev/null
+++ b/security/ncrack/files/patch-opensshlib_umac.c
@@ -0,0 +1,11 @@
+--- opensshlib/umac.c.orig 2019-08-24 22:25:32 UTC
++++ opensshlib/umac.c
+@@ -1177,7 +1177,7 @@ static int uhash(uhash_ctx_t ahc, u_char *msg, long le
+ * time. The all-at-once is more optimaized than the sequential version and
+ * should be preferred when the sequential interface is not required.
+ */
+-struct umac_ctx {
++extern struct umac_ctx {
+ uhash_ctx hash; /* Hash function for message compression */
+ pdf_ctx pdf; /* PDF for hashed output */
+ void *free_ptr; /* Address to free this struct via */
diff --git a/security/ncrack/files/patch-portable__endian.h b/security/ncrack/files/patch-portable__endian.h
new file mode 100644
index 000000000000..e7f00d6f7d64
--- /dev/null
+++ b/security/ncrack/files/patch-portable__endian.h
@@ -0,0 +1,32 @@
+--- portable_endian.h.orig 2019-08-24 22:25:32 UTC
++++ portable_endian.h
+@@ -18,6 +18,7 @@
+ # include <endian.h>
+ # include <features.h>
+ /* See http://linux.die.net/man/3/endian */
++# if !defined(__FreeBSD__)
+ # if !defined(__GLIBC__) || !defined(__GLIBC_MINOR__) || ((__GLIBC__ < 2) || ((__GLIBC__ == 2) && (__GLIBC_MINOR__ < 9)))
+ # include <arpa/inet.h>
+ # if defined(__BYTE_ORDER) && (__BYTE_ORDER == __LITTLE_ENDIAN)
+@@ -54,6 +55,7 @@
+ # error Byte Order not supported or not defined.
+ # endif
+ # endif
++# endif
+
+
+
+@@ -81,11 +83,11 @@
+ # define __LITTLE_ENDIAN LITTLE_ENDIAN
+ # define __PDP_ENDIAN PDP_ENDIAN
+
+-#elif defined(__OpenBSD__)
++#elif defined(__OpenBSD__) || defined (__FreeBSD__)
+
+ # include <sys/endian.h>
+
+-#elif defined(__NetBSD__) || defined(__FreeBSD__) || defined(__DragonFly__)
++#elif defined(__NetBSD__) || defined(__DragonFly__)
+
+ # include <sys/endian.h>
+
diff --git a/security/ncrack/pkg-descr b/security/ncrack/pkg-descr
new file mode 100644
index 000000000000..660b9725bf50
--- /dev/null
+++ b/security/ncrack/pkg-descr
@@ -0,0 +1,7 @@
+Ncrack is a high-speed network authentication cracking tool. Ncrack was
+designed using a modular approach, a command-line syntax similar to
+Nmap and a dynamic engine that can adapt its behaviour based on network
+feedback. It allows for rapid, yet reliable large-scale auditing of
+multiple hosts.
+
+WWW: https://nmap.org/ncrack/
diff --git a/security/ncrack/pkg-plist b/security/ncrack/pkg-plist
new file mode 100644
index 000000000000..8993a923555c
--- /dev/null
+++ b/security/ncrack/pkg-plist
@@ -0,0 +1,11 @@
+bin/ncrack
+share/ncrack/ncrack-services
+share/ncrack/common.usr
+share/ncrack/default.pwd
+share/ncrack/default.usr
+share/ncrack/jtr.pwd
+share/ncrack/minimal.usr
+share/ncrack/myspace.pwd
+share/ncrack/phpbb.pwd
+share/ncrack/top50000.pwd
+man/man1/ncrack.1.gz