aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 15:45:51 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 17:42:37 +0000
commit29a4848a5eb3435bbcddb9da7a65c91358e46e3d (patch)
treee0da03ffc653e82ccb21fa03a93d7a9f0f10321e
parent82ee657f8414b211b53e753f24eef382efe9206f (diff)
downloadports-29a4848a5eb3435bbcddb9da7a65c91358e46e3d.tar.gz
ports-29a4848a5eb3435bbcddb9da7a65c91358e46e3d.zip
net/afpfs-ng: Fix build with llvm16
- Utilize OPTIONS_SUB and move PLIST_FILES to pkg-plist - Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--net/afpfs-ng/Makefile19
-rw-r--r--net/afpfs-ng/pkg-plist23
2 files changed, 25 insertions, 17 deletions
diff --git a/net/afpfs-ng/Makefile b/net/afpfs-ng/Makefile
index 0476ef54e02d..8e62727d885a 100644
--- a/net/afpfs-ng/Makefile
+++ b/net/afpfs-ng/Makefile
@@ -10,29 +10,30 @@ WWW= https://sourceforge.net/projects/afpfs-ng/
LICENSE= GPLv2
+USES= autoreconf gmake iconv libtool localbase readline shebangfix tar:bzip2
+USE_LDCONFIG= yes
+
+SHEBANG_FILES= fuse/afpfs
+
GNU_CONFIGURE= yes
+
INSTALL_TARGET= install-strip
-USES= autoreconf gmake iconv libtool readline tar:bzip2
-USE_LDCONFIG= yes
CFLAGS+= -Wno-return-type
-CPPFLAGS+= -D_FILE_OFFSET_BITS=64 -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -D_FILE_OFFSET_BITS=64
OPTIONS_DEFINE= FUSE GCRYPT
+OPTIONS_SUB= yes
FUSE_LIB_DEPENDS= libfuse.so:sysutils/fusefs-libs
FUSE_CONFIGURE_ENABLE= fuse
-
GCRYPT_LIB_DEPENDS= libgcrypt.so:security/libgcrypt
GCRYPT_CONFIGURE_ENABLE=gcrypt
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MFUSE}
-PLIST_FILES+= bin/afp_client bin/afpfs bin/afpfsd bin/mount_afp \
- man/man1/afp_client.1.gz man/man1/afpfsd.1.gz \
- man/man1/mount_afp.1.gz
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
post-configure:
diff --git a/net/afpfs-ng/pkg-plist b/net/afpfs-ng/pkg-plist
index 6b69d6e01c9e..80206ca93609 100644
--- a/net/afpfs-ng/pkg-plist
+++ b/net/afpfs-ng/pkg-plist
@@ -1,17 +1,24 @@
-lib/libafpclient.a
-lib/libafpclient.so
-lib/libafpclient.so.0
-lib/libafpclient.so.0.0.0
+%%FUSE%%bin/afp_client
bin/afpcmd
+%%FUSE%%bin/afpfs
+%%FUSE%%bin/afpfsd
bin/afpgetstatus
-include/afpfs-ng/dsi.h
+%%FUSE%%bin/mount_afp
+include/afpfs-ng/afp.h
include/afpfs-ng/afp_protocol.h
-include/afpfs-ng/map_def.h
include/afpfs-ng/codepage.h
-include/afpfs-ng/midlevel.h
+include/afpfs-ng/dsi.h
include/afpfs-ng/libafpclient.h
+include/afpfs-ng/map_def.h
+include/afpfs-ng/midlevel.h
include/afpfs-ng/uams_def.h
-include/afpfs-ng/afp.h
include/afpfs-ng/utils.h
+lib/libafpclient.a
+lib/libafpclient.so
+lib/libafpclient.so.0
+lib/libafpclient.so.0.0.0
+%%FUSE%%man/man1/afp_client.1.gz
man/man1/afpcmd.1.gz
+%%FUSE%%man/man1/afpfsd.1.gz
man/man1/afpgetstatus.1.gz
+%%FUSE%%man/man1/mount_afp.1.gz