aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSanthosh Raju <fox@FreeBSD.org>2021-08-21 21:34:15 +0000
committerSanthosh Raju <fox@FreeBSD.org>2021-08-21 21:41:38 +0000
commit29d50446f541f2679c80aa3532ea9c750c7b879e (patch)
tree1b490cf8b2ca9742a5c7a4d7b81e6213dab45862
parent577eeb90083a0f9e9fb229e9ba5f16fed9cbff75 (diff)
downloadports-29d50446f541f2679c80aa3532ea9c750c7b879e.tar.gz
ports-29d50446f541f2679c80aa3532ea9c750c7b879e.zip
audio/din: Updates to 51.1.1
Changes since 51.1: DIN Is Noise 51.1.1: ! fixed build failures due to inconsistent variable type declaration !
-rw-r--r--audio/din/Makefile3
-rw-r--r--audio/din/distinfo6
-rw-r--r--audio/din/files/patch-src_ball.cc13
-rw-r--r--audio/din/files/patch-src_modulator.h13
-rw-r--r--audio/din/files/patch-src_mondrian.cc13
5 files changed, 4 insertions, 44 deletions
diff --git a/audio/din/Makefile b/audio/din/Makefile
index 66196a2a7cb6..377873654623 100644
--- a/audio/din/Makefile
+++ b/audio/din/Makefile
@@ -1,6 +1,5 @@
PORTNAME= din
-PORTVERSION= 51.1
-PORTREVISION= 1
+PORTVERSION= 51.1.1
CATEGORIES= audio
MASTER_SITES= https://archive.org/download/dinisnoise_source_code/
diff --git a/audio/din/distinfo b/audio/din/distinfo
index 8c55751959fc..c15169483ffa 100644
--- a/audio/din/distinfo
+++ b/audio/din/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1626222892
-SHA256 (din-51.1.tar.gz) = 4cdeebba091a8ed298840ccdecf204089d8481c5599bbd8bd526f3466a728e7c
-SIZE (din-51.1.tar.gz) = 3700748
+TIMESTAMP = 1629545974
+SHA256 (din-51.1.1.tar.gz) = f679ead486e2a55ffef0acfd00e35d47642309acd1fd1400f64ae3c2c1d5b6e9
+SIZE (din-51.1.1.tar.gz) = 3700797
diff --git a/audio/din/files/patch-src_ball.cc b/audio/din/files/patch-src_ball.cc
deleted file mode 100644
index c786baad8a95..000000000000
--- a/audio/din/files/patch-src_ball.cc
+++ /dev/null
@@ -1,13 +0,0 @@
-Fixes the redeclaration error. float vs const float.
-
---- src/ball.cc.orig 2021-07-12 10:55:38 UTC
-+++ src/ball.cc
-@@ -14,7 +14,7 @@
- using namespace std;
-
- extern mondrian mondrian0;
--extern float PI_BY_180;
-+extern const float PI_BY_180;
- extern float TWO_PI;
- extern int TRAILSIZE;
-
diff --git a/audio/din/files/patch-src_modulator.h b/audio/din/files/patch-src_modulator.h
deleted file mode 100644
index 3f582d51c6cc..000000000000
--- a/audio/din/files/patch-src_modulator.h
+++ /dev/null
@@ -1,13 +0,0 @@
-Fixes the redeclaration error. float vs const float.
-
---- src/modulator.h.orig 2021-07-12 11:03:15 UTC
-+++ src/modulator.h
-@@ -70,7 +70,7 @@ struct autorotator {
- inline void setdeg (float d) {
- deg = d;
- if (deg < 0.0f) deg = 0.0f;
-- extern float PI_BY_180;
-+ extern const float PI_BY_180;
- angle.persec = deg * PI_BY_180;
- }
-
diff --git a/audio/din/files/patch-src_mondrian.cc b/audio/din/files/patch-src_mondrian.cc
deleted file mode 100644
index 18620eac5a2f..000000000000
--- a/audio/din/files/patch-src_mondrian.cc
+++ /dev/null
@@ -1,13 +0,0 @@
-Fixes the redeclaration error. float vs const float.
-
---- src/mondrian.cc.orig 2021-07-12 13:10:37 UTC
-+++ src/mondrian.cc
-@@ -42,7 +42,7 @@ extern gotog _gotomax;
- extern int quit;
- extern beat2value octave_shift;
- extern float GOLDEN_RATIO;
--extern float PI_BY_180;
-+extern const float PI_BY_180;
- extern int IPS;
- extern std::map <string, float> INTERVALS;
- extern oscilloscope scope;