aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-04-16 17:22:16 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-04-17 12:12:19 +0000
commit29ecddac0f43cfef8e7756f58bd64b9177947d24 (patch)
tree454887e67904bf193560bd118a5f2af52f5b14a0
parent4611b90e0577e867e5352dd60104ed02ee1cb8a9 (diff)
downloadports-29ecddac0f43cfef8e7756f58bd64b9177947d24.tar.gz
ports-29ecddac0f43cfef8e7756f58bd64b9177947d24.zip
devel/gitlist: update to 1.0.2
Maintainer changes email address. PR: 254377 Reported by: freebsd-ports@andre.rikkertdekoe.nl (maintainer)
-rw-r--r--devel/gitlist/Makefile18
-rw-r--r--devel/gitlist/distinfo6
-rw-r--r--devel/gitlist/files/pkg-message.in2
3 files changed, 13 insertions, 13 deletions
diff --git a/devel/gitlist/Makefile b/devel/gitlist/Makefile
index be718c0170a7..3901ff10cfca 100644
--- a/devel/gitlist/Makefile
+++ b/devel/gitlist/Makefile
@@ -1,13 +1,12 @@
# Created by: Andre Rikkert de Koe - ARK-ICT <andre@ark-ict.nl>
PORTNAME= gitlist
-DISTVERSION= 1.0.1
-PORTREVISION= 1
+DISTVERSION= 1.0.2
CATEGORIES= devel www
MASTER_SITES= https://github.com/klaussilveira/gitlist/releases/download/${DISTVERSION}/ \
- http://freebsd.ark-ict.nl/ports/
+ https://freebsd.ark-ict.nl/ports/
-MAINTAINER= andre@ark-ict.nl
+MAINTAINER= freebsd-ports@misc.ark-ict.nl
COMMENT= Web based Git repository browser written in PHP
LICENSE= BSD3CLAUSE
@@ -15,20 +14,18 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= git:devel/git
-PLIST= ${WRKDIR}/plist
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
NO_BUILD= yes
USES= php:web
-USE_PHP= ctype hash simplexml
+USE_PHP= ctype hash json simplexml
+
+PLIST= ${WRKDIR}/plist
+WRKSRC= ${WRKDIR}/${PORTNAME}
USERS?= ${WWWOWN}
GROUPS?= ${WWWGRP}
SUB_FILES= pkg-message
post-patch:
- ${FIND} ${WRKSRC}/vendor/klaussilveira/gitter/lib/Gitter/Model/ -name \*.php -exec ${SED} -i '' 's/Object/Objekt/g' {} \;
- ${MV} ${WRKSRC}/vendor/klaussilveira/gitter/lib/Gitter/Model/Object.php ${WRKSRC}/vendor/klaussilveira/gitter/lib/Gitter/Model/Objekt.php
${MKDIR} ${WRKSRC}/cache
cd ${WRKSRC}; \
${REINPLACE_CMD} -e 's|/usr/bin/git|/usr/local/bin/git|g' config.ini-example; \
@@ -46,5 +43,6 @@ do-install:
${INSTALL_DATA} "$$src" "$$dst"; \
fi \
done
+ ${RM} -r "${WWWDIR}/cache/views"
.include <bsd.port.mk>
diff --git a/devel/gitlist/distinfo b/devel/gitlist/distinfo
index 1d3ef00e82bb..0296b42f5a4f 100644
--- a/devel/gitlist/distinfo
+++ b/devel/gitlist/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1533453094
-SHA256 (gitlist-1.0.1.tar.gz) = 3da0643f710c5c6b9b86efa46f87bc4a14069b8d31702f21a81213882b7783ea
-SIZE (gitlist-1.0.1.tar.gz) = 3027710
+TIMESTAMP = 1615986035
+SHA256 (gitlist-1.0.2.tar.gz) = 38728b688f6600ad97b6d5900b472da6529ff7f3b8c0669ada25ae0bb65d34d9
+SIZE (gitlist-1.0.2.tar.gz) = 5794820
diff --git a/devel/gitlist/files/pkg-message.in b/devel/gitlist/files/pkg-message.in
index a921ff5b0e35..3818dd4d3555 100644
--- a/devel/gitlist/files/pkg-message.in
+++ b/devel/gitlist/files/pkg-message.in
@@ -6,6 +6,8 @@ Copy %%WWWDIR%%/config.ini-example
to %%WWWDIR%%/config.ini and
edit it to make it use your git repositories.
Then configure your webserver to use the htdocs directory.
+Make sure mod_rewrite is enabled in your webserver,
+else the url-rewrite will not work and result in a 404 when accessing a repository.
EOM
}
]