aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2022-06-04 17:53:21 +0000
committerCraig Leres <leres@FreeBSD.org>2022-06-04 17:53:21 +0000
commit2a039d20f859058d97089c6d5a8945d2304ecc64 (patch)
treed7f4c60fa5fc119e068f8744a2bd9ddcc39cd9da
parent3a2b2ea88418dfe73676170c460e8ada5c39d7ce (diff)
downloadports-2a039d20f859058d97089c6d5a8945d2304ecc64.tar.gz
ports-2a039d20f859058d97089c6d5a8945d2304ecc64.zip
net-mgmt/check_nwc_health: Work around port scout failure
Out of the blue (on 6-Apr-2022) pkg-fallout started objecting to an awk expression in a support script: /usr/bin/awk: syntax error in regular expression ^#! ?\/.*\/[a-z]{0,2}awk at 0 source line number 44 source file ./subst context is /^#! ?\/.*\/[a-z]{0,2}awk/ {sub(/^#! ?\/.*\/[a-z]{0,2}awk/,"#! >>> /usr/bin/awk") <<< ;} *** [check_nwc_health] Error code 2 This only happens with 12.3 and the amd64 and arm64 architectures and I have never been able to reproduce the error in a poudriere jail. Remove the offending expression (which is not used by check_nwc_health). Reported by: portscout
-rw-r--r--net-mgmt/check_nwc_health/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-mgmt/check_nwc_health/Makefile b/net-mgmt/check_nwc_health/Makefile
index 5f47bd9bc8be..0b73fe3d34e9 100644
--- a/net-mgmt/check_nwc_health/Makefile
+++ b/net-mgmt/check_nwc_health/Makefile
@@ -1,5 +1,6 @@
PORTNAME= check_nwc_health
PORTVERSION= 10.1.0.3
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://labs.consol.de/assets/downloads/nagios/
@@ -27,5 +28,8 @@ PLIST_FILES= libexec/check_nwc_health
post-patch:
${REINPLACE_CMD} -e "s| /bin/sed| ${SED}|" -e "s| /bin/grep| ${GREP}|" \
${WRKSRC}/plugins-scripts/Makefile.in
+ # Remove unused expression that is problematic for pkg-fallout
+ # under 12.3 but causes no problems anywhere else
+ ${REINPLACE_CMD} -e "/@AWK@/d" ${WRKSRC}/plugins-scripts/subst.in
.include <bsd.port.mk>