aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-24 06:56:46 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-24 06:57:18 +0000
commit2a165c431a7f3788eed7925824c018a64081a6ec (patch)
tree914a014e4e7b663812678ead24ee942d182ac861
parentc576d090245098742531d8ff6219cf4800be6c16 (diff)
downloadports-2a165c431a7f3788eed7925824c018a64081a6ec.tar.gz
ports-2a165c431a7f3788eed7925824c018a64081a6ec.zip
science/meep: Re-add port: Finite-difference time-domain software for electromagnetic simulations
-rw-r--r--MOVED1
-rw-r--r--science/Makefile1
-rw-r--r--science/meep/Makefile35
-rw-r--r--science/meep/distinfo3
-rw-r--r--science/meep/pkg-descr5
-rw-r--r--science/meep/pkg-plist12
6 files changed, 56 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 72226fc14860..6c540b7ea1bd 100644
--- a/MOVED
+++ b/MOVED
@@ -13644,7 +13644,6 @@ games/xtris||2020-01-10|Has expired: Broken for more than 3 months
graphics/mapnik||2020-01-10|Has expired: Broken for more than 8 months
lang/js_of_ocaml||2020-01-10|Has expired: Depends on broken and expiring devel/ocaml-deriving-ocsigen
lang/rubinius||2020-01-10|Has expired: Broken for more than 7 months
-science/meep||2020-01-10|Has expired: Broken for more than 6 months
sysutils/hfm||2020-01-10|Has expired: Broken for more than 4 months
sysutils/u-boot-zedboard||2020-01-10|Has expired: Broken for more than 6 months
sysutils/u-boot-zybo||2020-01-10|Has expired: Broken for more than 6 months
diff --git a/science/Makefile b/science/Makefile
index 27fa79ab7d7c..fefe4450d49d 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -168,6 +168,7 @@
SUBDIR += mcxtrace-comps
SUBDIR += mdynamix
SUBDIR += medit
+ SUBDIR += meep
SUBDIR += metaphysicl
SUBDIR += minc2
SUBDIR += mmdb2
diff --git a/science/meep/Makefile b/science/meep/Makefile
new file mode 100644
index 000000000000..1bb2e5d8e06a
--- /dev/null
+++ b/science/meep/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= meep
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.24.0
+CATEGORIES= science cad
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Finite-difference time-domain software for electromagnetic simulations
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libharminv.a:science/harminv
+LIB_DEPENDS= libblas.so:math/blas \
+ libctlgeom.so:science/libctl \
+ libfftw3.so:math/fftw3 \
+ libhdf5.so:science/hdf5 \
+ liblapack.so:math/lapack \
+ libopenblas.so:math/openblas
+
+USES= autoreconf compiler:c++11-lang fortran gmake libtool localbase
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= NanoComp
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-scheme \
+ --without-python
+
+INSTALL_TARGET= install-strip
+TEST_TARGET= check
+
+BINARY_ALIAS= make=${GMAKE}
+
+.include <bsd.port.mk>
diff --git a/science/meep/distinfo b/science/meep/distinfo
new file mode 100644
index 000000000000..ae0b315b9e3f
--- /dev/null
+++ b/science/meep/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1658642939
+SHA256 (NanoComp-meep-v1.24.0_GH0.tar.gz) = 309e67320ba2b307b542446a00aa101321a8ddeb9759f2ec29016224d9914ac5
+SIZE (NanoComp-meep-v1.24.0_GH0.tar.gz) = 41240264
diff --git a/science/meep/pkg-descr b/science/meep/pkg-descr
new file mode 100644
index 000000000000..e88c4276f2e5
--- /dev/null
+++ b/science/meep/pkg-descr
@@ -0,0 +1,5 @@
+Meep is a free and open-source software package for electromagnetics
+simulation via the finite-difference time-domain (FDTD) method
+spanning a broad range of applications.
+
+WWW: https://github.com/NanoComp/meep
diff --git a/science/meep/pkg-plist b/science/meep/pkg-plist
new file mode 100644
index 000000000000..ffc37a7b5bd7
--- /dev/null
+++ b/science/meep/pkg-plist
@@ -0,0 +1,12 @@
+include/meep.hpp
+include/meep/adjust_verbosity.hpp
+include/meep/material_data.hpp
+include/meep/meep-config.h
+include/meep/meepgeom.hpp
+include/meep/mympi.hpp
+include/meep/vec.hpp
+lib/libmeep.a
+lib/libmeep.so
+lib/libmeep.so.29
+lib/libmeep.so.29.0.0
+libdata/pkgconfig/meep.pc