aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2013-03-02 22:24:45 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2013-03-02 22:24:45 +0000
commit2a1a40c8bffa56d60449805274bebe889eb98fc8 (patch)
tree9846c4617c8cd4d0bfac3959b9187b38ed0bec8b
parentf59a9c6c4b31afb228355e7bd365f51f7e865d69 (diff)
downloadports-2a1a40c8bffa56d60449805274bebe889eb98fc8.tar.gz
ports-2a1a40c8bffa56d60449805274bebe889eb98fc8.zip
- Avoid using PYTHON_SITELIBDIR
- Sync BUILD_DEPENDS and RUN_DEPENDS requirements with setup.py - Remove empty doc dirs (fix install/deinstall with package) - Use PORT_OPTIONS with EXAMPLES
Notes
Notes: svn path=/head/; revision=313302
-rw-r--r--devel/ipython/Makefile21
-rw-r--r--devel/ipython/files/patch-setupbase.py14
2 files changed, 17 insertions, 18 deletions
diff --git a/devel/ipython/Makefile b/devel/ipython/Makefile
index 1b568eb1eda3..c78ab13a67e6 100644
--- a/devel/ipython/Makefile
+++ b/devel/ipython/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ipython
PORTVERSION= 0.13.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
@@ -11,9 +11,9 @@ PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
MAINTAINER= olgeni@FreeBSD.org
COMMENT= An enhanced Interactive Python shell
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pexpect.py:${PORTSDIR}/misc/py-pexpect \
- ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3 \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2:${PORTSDIR}/databases/py-sqlite3
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pexpect>=2:${PORTSDIR}/misc/py-pexpect \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=2:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}pyzmq>=2.1.4:${PORTSDIR}/devel/py-pyzmq
USE_PYTHON= yes
@@ -36,20 +36,11 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:${PORTSDIR}/x11-toolkits/py-qt4-
.endif
.if ${PORT_OPTIONS:MHTML_NOTEBOOK}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=2.1:${PORTSDIR}/www/py-tornado
-.endif
-
-.ifndef NOPORTDOCS
-PORTDOCS= *
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=2.0:${PORTSDIR}/www/py-tornado
.endif
post-patch:
-.if defined(NOPORTDOCS)
- ${REINPLACE_CMD} -e "s#('data',pjoin(docdirbase,'extensions'),igridhelpfiles),# #g" ${WRKSRC}/setupbase.py
- ${REINPLACE_CMD} -e "s# + manual_files##g" ${WRKSRC}/setupbase.py
-.endif
-
-.if defined(NOPORTEXAMPLES)
+.if ! ${PORT_OPTIONS:MEXAMPLES}
${REINPLACE_CMD} -e "s# + example_files##g" ${WRKSRC}/setupbase.py
.endif
diff --git a/devel/ipython/files/patch-setupbase.py b/devel/ipython/files/patch-setupbase.py
index 00bfc2d711a6..598c7a7beff4 100644
--- a/devel/ipython/files/patch-setupbase.py
+++ b/devel/ipython/files/patch-setupbase.py
@@ -3,7 +3,7 @@ $FreeBSD$
--- setupbase.py.orig
+++ setupbase.py
-@@ -197,7 +197,8 @@
+@@ -201,7 +201,8 @@
"""
docdirbase = pjoin('share', 'doc', 'ipython')
@@ -12,8 +12,8 @@ $FreeBSD$
+ examplebase = pjoin('share', 'examples', 'ipython')
# Simple file lists can be made by hand
- manpages = filter(isfile, glob(pjoin('docs','man','*.1.gz')))
-@@ -211,7 +212,7 @@
+ manpages = [f for f in glob(pjoin('docs','man','*.1.gz')) if isfile(f)]
+@@ -215,7 +216,7 @@
example_files = make_dir_struct(
'data',
pjoin('docs','examples'),
@@ -22,3 +22,11 @@ $FreeBSD$
)
manual_files = make_dir_struct(
'data',
+@@ -225,7 +226,6 @@
+
+ # And assemble the entire output list
+ data_files = [ (manpagebase, manpages),
+- (pjoin(docdirbase, 'extensions'), igridhelpfiles),
+ ] + manual_files + example_files
+
+ return data_files