aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2023-05-01 04:07:09 +0000
committerCy Schubert <cy@FreeBSD.org>2023-05-01 04:07:09 +0000
commit2a92344327b6550ce4978f331e5f1119c610e14d (patch)
tree0716aa78d7a3b1c800548ba8a20ae2d865d0ee41
parent4cef8f14aceb0c4a94263466f54cbc28fe89bad2 (diff)
downloadports-2a92344327b6550ce4978f331e5f1119c610e14d.tar.gz
ports-2a92344327b6550ce4978f331e5f1119c610e14d.zip
deskutils/xcalendar: Fix LLVM15 build
At a minimum fix an incompatible pointer to integer conversion flagged by LLVM15. While at it include stdlib.h in preparation for additional work needed on this port. While at all of the above, assume care and feeding of this port. MFH: 2023Q2
-rw-r--r--deskutils/xcalendar/Makefile2
-rw-r--r--deskutils/xcalendar/files/patch-xcalendar.c6
-rw-r--r--deskutils/xcalendar/files/patch-xcalendar.h4
3 files changed, 6 insertions, 6 deletions
diff --git a/deskutils/xcalendar/Makefile b/deskutils/xcalendar/Makefile
index 9fbf6755b886..1366464c344c 100644
--- a/deskutils/xcalendar/Makefile
+++ b/deskutils/xcalendar/Makefile
@@ -5,7 +5,7 @@ CATEGORIES= deskutils
MASTER_SITES= PORTS_JP
DISTNAME= ${PORTNAME}-4.0+i18n
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cy@FreeBSD.org
COMMENT= Calendar with a notebook for X11 (internationalized version)
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/deskutils/xcalendar/files/patch-xcalendar.c b/deskutils/xcalendar/files/patch-xcalendar.c
index a36973d4be28..f69841d25245 100644
--- a/deskutils/xcalendar/files/patch-xcalendar.c
+++ b/deskutils/xcalendar/files/patch-xcalendar.c
@@ -1,5 +1,5 @@
---- xcalendar.c.dist Tue Jul 4 06:59:01 1995
-+++ xcalendar.c Mon Mar 12 20:53:10 2001
+--- xcalendar.c.orig 1995-07-03 14:59:01.000000000 -0700
++++ xcalendar.c 2023-04-30 21:04:24.168420000 -0700
@@ -1091,10 +1091,10 @@
struct tm *
gettime()
@@ -34,7 +34,7 @@
+ if (sizeof(buf) == len) {
+ buf = XtRealloc(buf, len + 1);
+ }
-+ buf[len] = NULL;
++ buf[len] = 0;
+
start = buf;
diff --git a/deskutils/xcalendar/files/patch-xcalendar.h b/deskutils/xcalendar/files/patch-xcalendar.h
index 5aeac0376726..65c4e614757e 100644
--- a/deskutils/xcalendar/files/patch-xcalendar.h
+++ b/deskutils/xcalendar/files/patch-xcalendar.h
@@ -1,5 +1,5 @@
---- xcalendar.h.orig Sun Oct 1 12:21:42 1995
-+++ xcalendar.h Mon Mar 12 20:54:02 2001
+--- xcalendar.h.orig 1995-09-30 20:21:42.000000000 -0700
++++ xcalendar.h 2023-04-30 21:02:14.402254000 -0700
@@ -75,7 +75,7 @@
#include <X11/Xaw/Xawi18n.h>
#endif