aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-04-23 10:23:13 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-04-23 10:28:27 +0000
commit2ac5b8bb6d20b6cfbd77894f524b194103bdf02a (patch)
treeba8b4191e399f79ccb1662d8a5fef52d4fe7878c
parenta9f91734c73c73507dd6c7635cea55f01638b555 (diff)
downloadports-2ac5b8bb6d20b6cfbd77894f524b194103bdf02a.tar.gz
ports-2ac5b8bb6d20b6cfbd77894f524b194103bdf02a.zip
devel/qtcreator: fix general weirdness
- there were REINPLACE_CMDs that did nothing, because the replaced strings were (no longer) in the files being edited. - a .bak file (from REINPLACE_CMD) was left in the plist. - testport failed in check-plist because the install target tries to strip(1) a text file (!?) and that leaves behind an empty `ecp.<random>` file in the dirname of the file being stripped.
-rw-r--r--devel/qtcreator/Makefile12
-rw-r--r--devel/qtcreator/pkg-plist1
2 files changed, 7 insertions, 6 deletions
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index 64add472a74c..e9a34da27d9a 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qtcreator
DISTVERSION= 4.13.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= QT/official_releases/qtcreator/${DISTVERSION:R}/${DISTVERSION}
DISTNAME= qt-creator-opensource-src-${DISTVERSION}
@@ -99,11 +100,6 @@ EXTRA_PATCHES= ${PATCHDIR}/llvm10_patch-src_shared_clang_clang__installation.pri
.endif
post-patch:
-# Fix paths for gnuplot and ant.
- ${REINPLACE_CMD} -e 's|/usr/bin/gnuplot|${LOCALBASE}/bin/gnuplot|' \
- ${WRKSRC}/share/qtcreator/debugger/dumper.py
- ${REINPLACE_CMD} -e 's|/usr/bin/ant|${LOCALBASE}/bin/ant|' \
- ${WRKSRC}/src/plugins/android/androidsettingswidget.cpp
# Fix python binary in pro file.
${REINPLACE_CMD} -e 's|python|${PYTHON_CMD}|g' \
${WRKSRC}/qtcreator.pro
@@ -119,4 +115,10 @@ pre-configure:
# See QTBUG-40825 and ports bugs 194088, 195105 and 198720.
${ECHO_CMD} 'QMAKE_LIBDIR_FLAGS = -L${WRKSRC}/lib' >> ${WRKSRC}/.qmake.cache
+post-stage:
+# There is **one** qmldir file that is staged, which gets stripped.
+# Since it's a text file, strip complains / falls over, but it does
+# leave a 0-size file behind. That in turn trips up check-plist.
+ ${RM} ${STAGEDIR}/${PREFIX}/share/qtcreator/qmldesigner/propertyEditorQmlSources/imports/StudioTheme/ecp.*
+
.include <bsd.port.post.mk>
diff --git a/devel/qtcreator/pkg-plist b/devel/qtcreator/pkg-plist
index ca5e1d79a5e6..5b7bcffe6fbc 100644
--- a/devel/qtcreator/pkg-plist
+++ b/devel/qtcreator/pkg-plist
@@ -179,7 +179,6 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/debugger/cdbbridge.py
%%DATADIR%%/debugger/creatortypes.py
%%DATADIR%%/debugger/dumper.py
-%%DATADIR%%/debugger/dumper.py.bak
%%DATADIR%%/debugger/gdbbridge.py
%%DATADIR%%/debugger/lldbbridge.py
%%DATADIR%%/debugger/misctypes.py