aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-02-06 19:45:58 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-02-06 19:45:58 +0000
commit2b65b90e340df002d3a3806ee8fe9d6692f58c53 (patch)
treece010f230b7fcf1cbf6f65a512c168906c779071
parent0d9d3794e70e986deebb6b5aae76c1680c2a1806 (diff)
downloadports-2b65b90e340df002d3a3806ee8fe9d6692f58c53.tar.gz
ports-2b65b90e340df002d3a3806ee8fe9d6692f58c53.zip
Add xglk 0411, an Xlib implementation of the Glk interactive adventure
display toolkit/API.
Notes
Notes: svn path=/head/; revision=128182
-rw-r--r--games/Makefile1
-rw-r--r--games/xglk/Makefile34
-rw-r--r--games/xglk/distinfo2
-rw-r--r--games/xglk/files/patch-Makefile62
-rw-r--r--games/xglk/pkg-descr8
-rw-r--r--games/xglk/pkg-plist14
6 files changed, 121 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index e1d8ea9a8962..7d009bcdae37 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -552,6 +552,7 @@
SUBDIR += xgalaga
SUBDIR += xgame
SUBDIR += xgammon
+ SUBDIR += xglk
SUBDIR += xgolgo
SUBDIR += xgospel
SUBDIR += xhexagons
diff --git a/games/xglk/Makefile b/games/xglk/Makefile
new file mode 100644
index 000000000000..24e5895b7945
--- /dev/null
+++ b/games/xglk/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xglk
+# Date created: 4 February 2005
+# Whom: Peter Pentchev <roam@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xglk
+PORTVERSION= 411
+CATEGORIES= games
+MASTER_SITES= http://www.ifarchive.org/if-archive/programming/glk/implementations/
+DISTNAME= ${PORTNAME}-0${PORTVERSION}
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= roam@FreeBSD.org
+COMMENT= X Windows Implementation of the Glk API
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg png.5:${PORTSDIR}/graphics/png
+
+USE_XLIB= yes
+USE_X_PREFIX= yes
+
+MAKE_ENV+= AR=${AR} RANLIB=${RANLIB} ECHO=${ECHO} RM=${RM}
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/xglk
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/xglk/
+ ${INSTALL_DATA} ${WRKSRC}/libxglk.a ${PREFIX}/lib/
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Make.xglk ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/xglk/distinfo b/games/xglk/distinfo
new file mode 100644
index 000000000000..4f64a1021e83
--- /dev/null
+++ b/games/xglk/distinfo
@@ -0,0 +1,2 @@
+MD5 (xglk-0411.tar.Z) = d625bd0fde87969582f857109ed3a602
+SIZE (xglk-0411.tar.Z) = 161138
diff --git a/games/xglk/files/patch-Makefile b/games/xglk/files/patch-Makefile
new file mode 100644
index 000000000000..7afde854068c
--- /dev/null
+++ b/games/xglk/files/patch-Makefile
@@ -0,0 +1,62 @@
+--- Makefile.orig Fri Feb 4 21:21:01 2005
++++ Makefile Fri Feb 4 21:24:41 2005
+@@ -58,8 +58,8 @@
+ #XLIB = -L/usr/X11R6/lib -lX11
+
+ # for Red Hat Linux
+-XINCLUDE = -I/usr/X11R6/include/X11
+-XLIB = -L/usr/X11R6/lib -lX11
++XINCLUDE = -I${X11BASE}/include
++XLIB = -L${X11BASE}/lib -lX11
+
+ # for SparcStation / Solaris
+ #XINCLUDE = -I/usr/openwin/include
+@@ -68,8 +68,8 @@
+ # --------------------
+
+ # definitions for where the PNG and JPEG libs are.
+-PNGINCLUDE =
+-PNGLIB = -lpng
++PNGINCLUDE = -I${LOCALBASE}/include
++PNGLIB = -L${LOCALBASE}/lib -lpng
+ JPEGINCLUDE =
+ JPEGLIB = -ljpeg
+
+@@ -82,10 +82,11 @@
+
+ # Pick a C compiler.
+ #CC = cc
+-CC = gcc
++CC ?= gcc
+
+-CFLAGS = -O -ansi $(PNGFLAG) $(JPEGFLAG) $(PNGINCLUDE) $(JPEGINCLUDE) -Wall -Wmissing-prototypes -Wstrict-prototypes -Wno-unused -Wbad-function-cast $(SYSTEMFLAGS) $(XINCLUDE)
+-LDFLAGS =
++CFLAGS ?= -O -ansi -Wall -Wmissing-prototypes -Wstrict-prototypes -Wno-unused -Wbad-function-cast
++CFLAGS += $(PNGFLAG) $(JPEGFLAG) $(PNGINCLUDE) $(JPEGINCLUDE) $(SYSTEMFLAGS) $(XINCLUDE)
++LDFLAGS ?=
+ LIBS = $(XLIB) $(PNGLIB) $(JPEGLIB) $(SYSTEMLIBS)
+
+ OBJS = main.o xglk.o xglk_vars.o xglk_prefs.o xglk_loop.o xglk_init.o \
+@@ -99,12 +100,12 @@
+ all: libxglk.a Make.xglk
+
+ libxglk.a: $(OBJS)
+- ar r libxglk.a $(OBJS)
+- ranlib libxglk.a
++ ${AR} r libxglk.a $(OBJS)
++ ${RANLIB} libxglk.a
+
+ Make.xglk:
+- echo LINKLIBS = $(LIBDIRS) $(LIBS) > Make.xglk
+- echo GLKLIB = -lxglk >> Make.xglk
++ ${ECHO} LINKLIBS = $(LIBDIRS) $(LIBS) > Make.xglk
++ ${ECHO} GLKLIB = -lxglk >> Make.xglk
+
+ $(OBJS): xglk.h xg_internal.h xglk_option.h glk.h gi_dispa.h gi_blorb.h
+
+@@ -113,4 +114,4 @@
+ xg_win_textbuf.o xg_window.o xglk_key.o: xg_win_textbuf.h
+
+ clean:
+- -rm -f *~ *.o libxglk.a Make.xglk
++ -${RM} *~ *.o libxglk.a Make.xglk
diff --git a/games/xglk/pkg-descr b/games/xglk/pkg-descr
new file mode 100644
index 000000000000..b8802f6f88b0
--- /dev/null
+++ b/games/xglk/pkg-descr
@@ -0,0 +1,8 @@
+XGlk: X Windows Implementation of the Glk API.
+
+XGlk Library: version 0.4.11
+Glk API which this implements: version 0.6.1.
+Designed by Andrew Plotkin <erkyrath@eblong.com>
+http://www.eblong.com/zarf/glk/index.html
+
+WWW: http://www.ifarchive.org/if-archive/programming/glk/implementations/
diff --git a/games/xglk/pkg-plist b/games/xglk/pkg-plist
new file mode 100644
index 000000000000..b55d62ec5550
--- /dev/null
+++ b/games/xglk/pkg-plist
@@ -0,0 +1,14 @@
+include/xglk/gi_blorb.h
+include/xglk/gi_dispa.h
+include/xglk/glk.h
+include/xglk/glkstart.h
+include/xglk/xg_internal.h
+include/xglk/xg_win_graphics.h
+include/xglk/xg_win_textbuf.h
+include/xglk/xg_win_textgrid.h
+include/xglk/xglk.h
+include/xglk/xglk_option.h
+@dirrm include/xglk
+lib/libxglk.a
+%%DATADIR%%/Make.xglk
+@dirrm %%DATADIR%%