aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2020-05-28 20:00:47 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2020-05-28 20:00:47 +0000
commit2b83d1e03f83e3367efa705e8e2d06470c65474c (patch)
tree3146cb5e0fc9b8ba17c18851da291863d2eff4b5
parent2fd631f9feda6e6799b0a5842c3e245bf5bc8414 (diff)
downloadports-2b83d1e03f83e3367efa705e8e2d06470c65474c.tar.gz
ports-2b83d1e03f83e3367efa705e8e2d06470c65474c.zip
math/scilab-toolbox-swt:
- Update to 0.3.1 - Remove now needless patches - Update WWW
Notes
Notes: svn path=/head/; revision=536814
-rw-r--r--math/scilab-toolbox-swt/Makefile20
-rw-r--r--math/scilab-toolbox-swt/distinfo5
-rw-r--r--math/scilab-toolbox-swt/files/patch-clang118
-rw-r--r--math/scilab-toolbox-swt/pkg-descr2
-rw-r--r--math/scilab-toolbox-swt/pkg-plist6
5 files changed, 18 insertions, 133 deletions
diff --git a/math/scilab-toolbox-swt/Makefile b/math/scilab-toolbox-swt/Makefile
index eff68cbbd7ea..3156579ece54 100644
--- a/math/scilab-toolbox-swt/Makefile
+++ b/math/scilab-toolbox-swt/Makefile
@@ -1,12 +1,11 @@
# $FreeBSD$
PORTNAME= swt
-PORTVERSION= 0.1.20
-PORTREVISION= 6
+PORTVERSION= 0.3.1
CATEGORIES= math
MASTER_SITES= http://atoms.scilab.org/toolboxes/swt/${PORTVERSION}/files/
PKGNAMEPREFIX= scilab-toolbox-
-DISTFILES= ${DISTNAME}-3-src${EXTRACT_SUFX}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-3-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Scilab 1-D and 2-D Wavelet Toolbox
@@ -14,9 +13,13 @@ COMMENT= Scilab 1-D and 2-D Wavelet Toolbox
BUILD_DEPENDS= ${SCILAB_CMD}:math/scilab
RUN_DEPENDS:= ${BUILD_DEPENDS}
+USES= dos2unix zip
+USE_LOCALE= en_US.UTF-8
+
SCILAB_CMD= ${LOCALBASE}/bin/scilab-adv-cli
SCILAB_ARGS= -noatomsautoload -nb -nouserstartup
MAKE_ENV= SCI_JAVA_ENABLE_HEADLESS=1 SCI_DISABLE_TK=1
+DOS2UNIX_FILES= etc/swt.start
CONTRIBDIR?= share/scilab/contrib
TOOLBOXDIR_REL?= ${CONTRIBDIR}/${PORTNAME}
@@ -45,8 +48,6 @@ post-patch:
.if !${PORT_OPTIONS:MHELP}
${REINPLACE_CMD} -e '/tbx_builder_help/d' ${WRKSRC}/builder.sce
.endif
- ${REINPLACE_CMD} -e '/#include <malloc.h>/d' \
- ${WRKSRC}/sci_gateway/c/kiss_fft.h
${ECHO_CMD} quit >> ${WRKSRC}/builder.sce
pre-build:
@@ -57,15 +58,10 @@ do-build:
${SETENV} ${MAKE_ENV} ${SCILAB_CMD} ${SCILAB_ARGS} -f builder.sce
do-install:
- ${MKDIR} ${STAGEDIR}${TOOLBOXDIR}/sci_gateway/c
- ${INSTALL_DATA} ${WRKSRC}/loader.sce ${STAGEDIR}${TOOLBOXDIR}
- ${INSTALL_DATA} ${WRKSRC}/sci_gateway/loader_gateway.sce \
- ${STAGEDIR}${TOOLBOXDIR}/sci_gateway
- cd ${WRKSRC}/sci_gateway/c && \
- ${INSTALL_DATA} loader.sce ${STAGEDIR}${TOOLBOXDIR}/sci_gateway/c && \
- ${INSTALL_PROGRAM} libswt_c.so ${STAGEDIR}${TOOLBOXDIR}/sci_gateway/c
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${TOOLBOXDIR} "-name *\.so -or -name loader*\.sce"
.for d in ${TOOLBOX_SUBDIRS}
cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${TOOLBOXDIR}
.endfor
+ ${FIND} ${STAGEDIR}${TOOLBOXDIR} -name *\.so -exec ${STRIP_CMD} {} \;
.include <bsd.port.mk>
diff --git a/math/scilab-toolbox-swt/distinfo b/math/scilab-toolbox-swt/distinfo
index b96daa6ffb03..2f10a77fb993 100644
--- a/math/scilab-toolbox-swt/distinfo
+++ b/math/scilab-toolbox-swt/distinfo
@@ -1,2 +1,3 @@
-SHA256 (swt-0.1.20-3-src.tar.gz) = a0edfd25c4a5831d2953c45fdb9289fbba006149a6581dad84a8803293aaffeb
-SIZE (swt-0.1.20-3-src.tar.gz) = 945095
+TIMESTAMP = 1590664412
+SHA256 (swt-0.3.1-3-src.zip) = da2fb4a6c0a74a7bbae3f3aaa5134584d39ab293dfd23787a707318c8cc21eed
+SIZE (swt-0.3.1-3-src.zip) = 1177314
diff --git a/math/scilab-toolbox-swt/files/patch-clang b/math/scilab-toolbox-swt/files/patch-clang
deleted file mode 100644
index 220e193c500e..000000000000
--- a/math/scilab-toolbox-swt/files/patch-clang
+++ /dev/null
@@ -1,118 +0,0 @@
---- ./sci_gateway/c/swt_common.h.orig
-+++ ./sci_gateway/c/swt_common.h
-@@ -323,10 +323,10 @@
- //extern int is_scalar (int row, int col);
- //extern int is_vector (int row, int col);
- //extern int is_matrix (int row, int col);
--extern void void_check (int number, int *type);
--extern void scalar_check (int number, int *type);
--extern void vector_check (int number, int *type);
--extern void matrix_check (int number, int *type);
-+extern int void_check (int number, int *type);
-+extern int scalar_check (int number, int *type);
-+extern int vector_check (int number, int *type);
-+extern int matrix_check (int number, int *type);
- extern void real_or_complex (int number, int *type);
- extern int sci_matrix_vector_real (int number);
- extern int sci_matrix_vector_complex (int number);
-@@ -341,8 +341,8 @@
- extern int scalar_string_check(char *l, char c);
- extern int length_check(int number, int leng);
- extern int vector_length_check(int number1, int number2);
--extern void vector_length_compare(int number, int leng, int *res);
--extern void matrix_length_compare(int number, int rowLeng,
-+extern int vector_length_compare(int number, int leng, int *res);
-+extern int matrix_length_compare(int number, int rowLeng,
- int colLeng, int *resRow,
- int *resCol);
- extern int matrix_length_check (int number1, int number2);
---- ./sci_gateway/c/validate.c.orig
-+++ ./sci_gateway/c/validate.c
-@@ -42,7 +42,7 @@
- /*-------------------------------------------
- * Dimension Checking
- *-----------------------------------------*/
--void void_check (int number, int *type)
-+int void_check (int number, int *type)
- {
- int row, col;
- GetMatrixdims(number,&row,&col);
-@@ -50,10 +50,10 @@
- *type = 1;
- else
- *type = 0;
-- //return;
-+ return 1;
- }
-
--void scalar_check (int number, int *type)
-+int scalar_check (int number, int *type)
- {
- int row, col;
- GetMatrixdims(number,&row,&col);
-@@ -61,10 +61,10 @@
- *type = 1;
- else
- *type = 0;
-- //return;
-+ return 1;
- }
-
--void vector_check (int number, int *type)
-+int vector_check (int number, int *type)
- {
- int row, col;
- GetMatrixdims(number,&row,&col);
-@@ -74,10 +74,10 @@
- *type = 1;
- else
- *type = 0;
-- //return;
-+ return 1;
- }
-
--void matrix_check (int number, int *type)
-+int matrix_check (int number, int *type)
- {
- int row, col;
- GetMatrixdims(number,&row,&col);
-@@ -85,7 +85,7 @@
- *type = 1;
- else
- *type = 0;
-- //return;
-+ return 1;
- }
-
- void real_or_complex (int number, int *type)
-@@ -234,7 +234,7 @@
- return 0;
- }
-
--void vector_length_compare(int number, int leng, int *res)
-+int vector_length_compare(int number, int leng, int *res)
- {
- int row, col;
- GetMatrixdims(number,&row,&col);
-@@ -244,10 +244,10 @@
- *res = 1;
- else
- *res = -1;
-- return;
-+ return 1;
- }
-
--void matrix_length_compare(int number, int rowLeng, int colLeng,
-+int matrix_length_compare(int number, int rowLeng, int colLeng,
- int *resRow, int *resCol)
- {
- int row, col;
-@@ -264,7 +264,7 @@
- *resCol = 1;
- else
- *resCol = -1;
-- return;
-+ return 1;
- }
-
- int
diff --git a/math/scilab-toolbox-swt/pkg-descr b/math/scilab-toolbox-swt/pkg-descr
index e10046491c42..6c1d412d3f3a 100644
--- a/math/scilab-toolbox-swt/pkg-descr
+++ b/math/scilab-toolbox-swt/pkg-descr
@@ -14,4 +14,4 @@ Discrete Fast Wavelet Transform, daubechies wavelets
2-D single level image decomposition and reconstruction
2-D multi-level image decomposition and reconstruction.
-WWW: http://atoms.scilab.org/toolboxes/swt
+WWW: https://atoms.scilab.org/toolboxes/swt
diff --git a/math/scilab-toolbox-swt/pkg-plist b/math/scilab-toolbox-swt/pkg-plist
index 68f8eb189e0d..fc306478476f 100644
--- a/math/scilab-toolbox-swt/pkg-plist
+++ b/math/scilab-toolbox-swt/pkg-plist
@@ -7,8 +7,10 @@
%%TOOLBOXDIR%%/demos/image.sce
%%TOOLBOXDIR%%/demos/image/woman.bmp
%%TOOLBOXDIR%%/demos/image/woman.dat
+%%TOOLBOXDIR%%/demos/imageDenoising.sce
%%TOOLBOXDIR%%/demos/rwt.sce
%%TOOLBOXDIR%%/demos/scale2freq.dem.sce
+%%TOOLBOXDIR%%/demos/semibalance.sce
%%TOOLBOXDIR%%/demos/smoothness_wav.dem.sce
%%TOOLBOXDIR%%/demos/swt.dem.gateway.sce
%%TOOLBOXDIR%%/demos/swt1d.sce
@@ -145,3 +147,7 @@
%%TOOLBOXDIR%%/sci_gateway/c/libswt_c.so
%%TOOLBOXDIR%%/sci_gateway/c/loader.sce
%%TOOLBOXDIR%%/sci_gateway/loader_gateway.sce
+%%TOOLBOXDIR%%/src/c/libswtlib.so
+%%TOOLBOXDIR%%/src/c/loader.sce
+%%TOOLBOXDIR%%/src/gwsupport/libswt_gwsupport.so
+%%TOOLBOXDIR%%/src/gwsupport/loader.sce