aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2023-04-19 14:44:15 +0000
committerNicola Vitale <nivit@FreeBSD.org>2023-04-19 14:44:15 +0000
commit2bafc1aa5b10fce8958b124c082298812200b1cc (patch)
tree0ff74c201f479b345004fb7bb79a6ca3672138d5
parent7640ea1e701f9daa5eef8032469f8686d4e649fd (diff)
downloadports-2bafc1aa5b10fce8958b124c082298812200b1cc.tar.gz
ports-2bafc1aa5b10fce8958b124c082298812200b1cc.zip
graphics/py-fotokilof: Add new port
GUI for ImageMagick and Wand. https://github.com/TeaM-TL/FotoKilof
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-fotokilof/Makefile36
-rw-r--r--graphics/py-fotokilof/distinfo3
-rw-r--r--graphics/py-fotokilof/pkg-descr1
4 files changed, 41 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b9770a4933a6..bf83df974aef 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -860,6 +860,7 @@
SUBDIR += py-face_recognition
SUBDIR += py-face_recognition_models
SUBDIR += py-fiona
+ SUBDIR += py-fotokilof
SUBDIR += py-freeimagepy
SUBDIR += py-gdal
SUBDIR += py-geomdl
diff --git a/graphics/py-fotokilof/Makefile b/graphics/py-fotokilof/Makefile
new file mode 100644
index 000000000000..22f8255695ce
--- /dev/null
+++ b/graphics/py-fotokilof/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= fotokilof
+PORTVERSION= 4.2.6
+CATEGORIES= graphics
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= FotoKilof-${PORTVERSION}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= GUI for ImageMagick and Wand
+WWW= https://github.com/TeaM-TL/FotoKilof
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=63.1.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0.40.0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=9.5.0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tkcolorpicker>=2.1.3:graphics/py-tkcolorpicker@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Wand>=0.6.11:graphics/py-wand@${PY_FLAVOR}
+
+USES= magick:run python:3.7+
+
+# the project really doesn't have PEP-517 support, but distutils/setuptools
+# create a "wrong" entry_points script, so we use our pep517 feature
+# (at least partially).
+USE_PYTHON= autoplist pep517
+PYDISTUTILS_BUILD_TARGET= bdist_wheel
+PEP517_BUILD_CMD= ${PYTHON_CMD} ${PYDISTUTILS_SETUP} \
+ ${PYDISTUTILS_BUILD_TARGET}
+
+# fix Python wheel name (lower case)
+post-patch:
+ ${REINPLACE_CMD} -e 's/\(__appname__ = \)"${PORTNAME}"/\1"${PORTNAME}"/1i' \
+ ${WRKSRC}/fotokilof/version.py
+
+.include <bsd.port.mk>
diff --git a/graphics/py-fotokilof/distinfo b/graphics/py-fotokilof/distinfo
new file mode 100644
index 000000000000..2fed632b1d18
--- /dev/null
+++ b/graphics/py-fotokilof/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1681850853
+SHA256 (FotoKilof-4.2.6.tar.gz) = 42fba8128905cbcfe7a498b415c5cb05fc478820f69780503864d96763a7667c
+SIZE (FotoKilof-4.2.6.tar.gz) = 72894
diff --git a/graphics/py-fotokilof/pkg-descr b/graphics/py-fotokilof/pkg-descr
new file mode 100644
index 000000000000..6ef6f53ede16
--- /dev/null
+++ b/graphics/py-fotokilof/pkg-descr
@@ -0,0 +1 @@
+GUI for the most used ImageMagick functionalities for processing images.