aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-24 18:43:08 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-25 08:36:26 +0000
commit2bb0c72ce57992ece2b9694065a96c9129afebe2 (patch)
tree1823100254312918b75861e7df4159fa496b2cb2
parentc4f8944e4ac32dde001e1f4df2226b836241f6f7 (diff)
print/openprinting: Fix build with llvm16
- Utilize USES=localbase - Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--print/openprinting/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/print/openprinting/Makefile b/print/openprinting/Makefile
index 1bb83f2e91e6..7efa1c41bcb0 100644
--- a/print/openprinting/Makefile
+++ b/print/openprinting/Makefile
@@ -10,17 +10,18 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Sun's implementation of the OpenPrinting API (PAPI)
WWW= http://openprinting.sourceforge.net/
-WRKSRC= ${WRKDIR}/papi-${PORTVERSION}_beta
-
-USES= gettext gmake iconv libtool tar:bzip2
+USES= gettext gmake iconv libtool localbase tar:bzip2
USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
+
MAKE_JOBS_UNSAFE= yes
-LLD_UNSAFE= yes
+INSTALL_TARGET= install-strip
+
+WRKSRC= ${WRKDIR}/papi-${PORTVERSION}_beta
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lintl
+LIBS+= -lintl
+LLD_UNSAFE= yes
# TODO: Get mod_ipp to actually work; Sun's example seems to be broken
# under both Apache 1.3/2.0, this could be a papi issue; does not build
@@ -34,6 +35,10 @@ LIBS+= -L${LOCALBASE}/lib -lintl
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
# NOTE: This has only been tested with www/apache20, with integrated APR.
.if defined(WITH_MOD_IPP)
IGNORE= no supported apache versions available