aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-03-28 19:42:17 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-03-28 19:43:34 +0000
commit2be33351230f23d4382b8e4b929492cbe38976f5 (patch)
tree6ba25e1cad572a5e4e21c68897a671ea5e75ce8b
parentc082a3e1e10d6637a8725f29f8ecffd034934650 (diff)
downloadports-2be33351230f23d4382b8e4b929492cbe38976f5.tar.gz
ports-2be33351230f23d4382b8e4b929492cbe38976f5.zip
sysutils/upower: Replace my patch with upstream fix
-rw-r--r--sysutils/upower/files/patch-doc_meson.build44
-rw-r--r--sysutils/upower/files/patch-meson.build15
2 files changed, 45 insertions, 14 deletions
diff --git a/sysutils/upower/files/patch-doc_meson.build b/sysutils/upower/files/patch-doc_meson.build
new file mode 100644
index 000000000000..5ec319677ffc
--- /dev/null
+++ b/sysutils/upower/files/patch-doc_meson.build
@@ -0,0 +1,44 @@
+--- doc/meson.build.orig 2022-03-09 17:46:34 UTC
++++ doc/meson.build
+@@ -27,21 +27,23 @@ version_xml = configure_file(
+ input: 'version.xml.in',
+ configuration: cdata)
+
+-gnome.gtkdoc('UPower',
+- main_xml: 'upower-docs.xml',
+- src_dir: meson.source_root() / 'libupower-glib',
+- dependencies: [ libupower_glib_dep ],
+- scan_args: ['--rebuild-types', '--rebuild-sections'],
+- content_files: [
+- version_xml,
+- ifaces_refs,
+- 'man/UPower.xml',
+- 'man/upowerd.xml',
+- 'man/upower.xml',
+- '../COPYING',
+- ],
+- ignore_headers: [
+- 'config.h',
+- ],
+- install: get_option('gtk-doc')
+-)
++if get_option('gtk-doc')
++ gnome.gtkdoc('UPower',
++ main_xml: 'upower-docs.xml',
++ src_dir: meson.source_root() / 'libupower-glib',
++ dependencies: [ libupower_glib_dep ],
++ scan_args: ['--rebuild-types', '--rebuild-sections'],
++ content_files: [
++ version_xml,
++ ifaces_refs,
++ 'man/UPower.xml',
++ 'man/upowerd.xml',
++ 'man/upower.xml',
++ '../COPYING',
++ ],
++ ignore_headers: [
++ 'config.h',
++ ],
++ install: get_option('gtk-doc')
++ )
++endif
diff --git a/sysutils/upower/files/patch-meson.build b/sysutils/upower/files/patch-meson.build
index 42a7e4747166..e1258e52df16 100644
--- a/sysutils/upower/files/patch-meson.build
+++ b/sysutils/upower/files/patch-meson.build
@@ -1,19 +1,6 @@
--- meson.build.orig 2022-03-09 17:46:34 UTC
+++ meson.build
-@@ -47,7 +47,11 @@ m_dep = cc.find_library('m', required: true)
- gio_unix_dep = dependency('gio-unix-2.0', version: '>=' + glib_min_version)
- m_dep = cc.find_library('m', required: true)
-
--xsltproc = find_program('xsltproc', disabler: true, required: get_option('gtk-doc') or get_option('man'))
-+if get_option('gtk-doc') or get_option('man')
-+ xsltproc = find_program('xsltproc', disabler: true, required: get_option('gtk-doc') or get_option('man'))
-+else
-+ xsltproc = disabler()
-+endif
-
- # Resolve OS backend
- os_backend = get_option('os_backend')
-@@ -105,7 +109,7 @@ subdir('etc')
+@@ -105,7 +105,7 @@ subdir('etc')
config_h = configure_file(output: 'config.h', configuration: cdata)
subdir('etc')