aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2022-08-29 15:05:31 +0000
committerCy Schubert <cy@FreeBSD.org>2022-08-29 15:56:44 +0000
commit2bf1fc52aa698ebd4909c4127ad20dc4b5cbd706 (patch)
treec0ba3df23272ac48b17176d3c20a8d8828135f16
parenteef437e121599da6bd58621ee49a8efada7a490d (diff)
downloadports-2bf1fc52aa698ebd4909c4127ad20dc4b5cbd706.tar.gz
ports-2bf1fc52aa698ebd4909c4127ad20dc4b5cbd706.zip
security/libomemo: Add new port
libomemo implements OMEMO (XEP-0384 v0.3.0) in C. For more information see https://github.com/gkdr/libomemo. PR: 265966 Submitted by: Michael A. Oshin <micadeyeye at gmail.com> Reported by: Michael A. Oshin <micadeyeye at gmail.com>
-rw-r--r--security/Makefile1
-rw-r--r--security/libomemo/Makefile26
-rw-r--r--security/libomemo/distinfo3
-rw-r--r--security/libomemo/pkg-descr7
-rw-r--r--security/libomemo/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d50a071ef994..c98246ee5b83 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -280,6 +280,7 @@
SUBDIR += libmcrypt
SUBDIR += libnitrokey
SUBDIR += libntlm
+ SUBDIR += libomemo
SUBDIR += liboqs
SUBDIR += libotr
SUBDIR += libotr3
diff --git a/security/libomemo/Makefile b/security/libomemo/Makefile
new file mode 100644
index 000000000000..f012d80d2b20
--- /dev/null
+++ b/security/libomemo/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= libomemo
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.8.1
+CATEGORIES= security
+
+MAINTAINER= micadeyeye@gmail.com
+COMMENT= Implements OMEMO in C
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
+ libmxml.so:textproc/mxml
+
+GH_ACCOUNT= gkdr
+
+USES= cmake gnome pkgconfig sqlite
+USE_GITHUB= yes
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= OMEMO_WITH_TESTS
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/security/libomemo/distinfo b/security/libomemo/distinfo
new file mode 100644
index 000000000000..7662467a1d8c
--- /dev/null
+++ b/security/libomemo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1661585134
+SHA256 (gkdr-libomemo-v0.8.1_GH0.tar.gz) = b64d603f675774c922ae9b0c841dd4dbbb59c3780d6ac60bc40dbcf7b0428519
+SIZE (gkdr-libomemo-v0.8.1_GH0.tar.gz) = 28648
diff --git a/security/libomemo/pkg-descr b/security/libomemo/pkg-descr
new file mode 100644
index 000000000000..4913ca55b74b
--- /dev/null
+++ b/security/libomemo/pkg-descr
@@ -0,0 +1,7 @@
+Implements OMEMO (XEP-0384 v0.3.0) in C.
+
+Input and output are XML strings, so it does not force you to use a certain
+XML lib. While the actual protocol functions do not depend on any kind of
+storage, it comes with a basic implementation in SQLite.
+
+WWW: https://github.com/gkdr/libomemo
diff --git a/security/libomemo/pkg-plist b/security/libomemo/pkg-plist
new file mode 100644
index 000000000000..fe12234529e7
--- /dev/null
+++ b/security/libomemo/pkg-plist
@@ -0,0 +1,7 @@
+include/libomemo/libomemo.h
+include/libomemo/libomemo_crypto.h
+include/libomemo/libomemo_storage.h
+lib/libomemo.so
+lib/libomemo.so.0
+lib/libomemo.so.0.8.1
+libdata/pkgconfig/libomemo.pc