aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2022-04-30 15:20:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2022-05-01 08:39:21 +0000
commit2c00022c720aff69cfcb6ccacd880ac102579c9e (patch)
treeb2769c6014b642af01b1f559e94b17b25f8391b6
parent03a9f8b598ab7278cb62cf12b649add0cfc0872c (diff)
downloadports-2c00022c720aff69cfcb6ccacd880ac102579c9e.tar.gz
ports-2c00022c720aff69cfcb6ccacd880ac102579c9e.zip
print/cups: update to 2.4.1
PR: 263672
-rw-r--r--print/cups/Makefile35
-rw-r--r--print/cups/distinfo6
-rw-r--r--print/cups/files/patch-configure88
-rw-r--r--print/cups/files/patch-scheduler_client.c13
-rw-r--r--print/cups/pkg-plist78
5 files changed, 163 insertions, 57 deletions
diff --git a/print/cups/Makefile b/print/cups/Makefile
index dd2d406a33cb..f8e05ae9c087 100644
--- a/print/cups/Makefile
+++ b/print/cups/Makefile
@@ -1,7 +1,7 @@
# Created by: Alan Eldridge <alane@geeksrus.net>
PORTNAME= cups
-PORTVERSION= 2.3.3op2
+PORTVERSION= 2.4.1
DISTVERSIONPREFIX=v
CATEGORIES= print
@@ -11,17 +11,16 @@ COMMENT= Common UNIX Printing System
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-CONFLICTS= LPRng
+USES= compiler:c++11-lang cpe gmake iconv localbase pkgconfig
+CPE_VENDOR= apple
USE_GITHUB= yes
GH_ACCOUNT= OpenPrinting
-DESTDIRNAME= DSTROOT
+CONFLICTS= LPRng
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-dnssd \
- --disable-gssapi \
- --disable-launchd \
- --disable-systemd \
+CONFIGURE_ARGS= --enable-relro \
--with-cups-user=${USERS} \
--with-cups-group=${GROUPS} \
--with-system-groups=wheel \
@@ -32,10 +31,7 @@ CONFIGURE_ARGS= --disable-dnssd \
--with-rcdir=no \
--with-optim=" " \
--with-pam-module="unix" \
- ac_cv_path_JAVA= ac_cv_path_PERL= ac_cv_path_PHPCGI= \
- ac_cv_path_PHP= ac_cv_path_PYTHON=
-USES= compiler:c++11-lang cpe gmake iconv localbase pkgconfig
-CPE_VENDOR= apple
+ --without-ondemand
USE_LDCONFIG= yes
USE_RC_SUBR= cupsd
@@ -47,7 +43,7 @@ OPTIONS_DEFAULT= AVAHI DBUS GNUTLS LIBPAPER
OPTIONS_SUB= yes
AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
-AVAHI_CONFIGURE_ENABLE= avahi
+AVAHI_CONFIGURE_WITH= dnssd=avahi
AVAHI_SUB_LIST= AVAHI_DAEMON=avahi_daemon
AVAHI_SUB_LIST_OFF= AVAHI_DAEMON=
@@ -57,8 +53,7 @@ DBUS_SUB_LIST= DBUS_DAEMON=dbus
DBUS_SUB_LIST_OFF= DBUS_DAEMON=
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
-GNUTLS_CONFIGURE_ON= --enable-gnutls
-GNUTLS_CONFIGURE_OFF= --disable-ssl
+GNUTLS_CONFIGURE_WITH= tls
IPPTOOL_DESC= Internet Printing Protocol testing tool
@@ -95,10 +90,7 @@ post-patch:
@${REINPLACE_CMD} -e '/SILENT/d' ${WRKSRC}/Makedefs.in
@${REINPLACE_CMD} 's/usblp/ulpt/g' ${WRKSRC}/backend/usb-libusb.c
@${REINPLACE_CMD} -e 's|/usr/local/etc/pam.d|${LOCALBASE}/etc/pam.d|' \
- -e 's/-fstack-protector//' ${WRKSRC}/configure
- @${FIND} ${WRKSRC}/doc ${WRKSRC}/templates -type f -exec ${SED} -i '' \
- 's|http://www.cups.org|https://www.cups.org|g' {} +
- @${REINPLACE_CMD} '/stripopt=/s/-x//' ${WRKSRC}/install-sh
+ ${WRKSRC}/configure
@${REINPLACE_CMD} 's|/etc/cups|${LOCALBASE}/etc/cups|g' \
${WRKSRC}/man/*.[1-9]
@${REINPLACE_CMD} -e 's|\.default|.sample|'\
@@ -108,9 +100,10 @@ post-patch:
post-patch-DOCS-off:
# Link to online documentation.
@${FIND} ${WRKSRC}/doc ${WRKSRC}/templates -type f -exec ${SED} -i '' \
- -e 's|[Hh][Rr][Ee][Ff]="/*help/\([{"]\)|href="https://www.cups.org/documentation.html\1|g' \
- -e '/have_gssapi/s|[Hh][Rr][Ee][Ff]="/*help/|href="https\\://www.cups.org/doc/|g' \
- -e 's|[Hh][Rr][Ee][Ff]="/*help/|href="https://www.cups.org/doc/|g' {} +
+ -e 's|[Hh][Rr][Ee][Ff]="/*help/{[^"]*"|href="https://openprinting.github.io/cups/#DOCUMENTATION|g' \
+ -e 's|[Hh][Rr][Ee][Ff]="/*help/"|href="https://openprinting.github.io/cups/#DOCUMENTATION|g' \
+ -e '/have_gssapi/s|[Hh][Rr][Ee][Ff]="/*help/|href="https\\://openprinting.github.io/cups/doc/|g' \
+ -e 's|[Hh][Rr][Ee][Ff]="/*help/|href="https://openprinting.github.io/cups/doc/|g' {} +
post-install:
${LN} -sf lpr ${STAGEDIR}${PREFIX}/bin/lpr-cups
diff --git a/print/cups/distinfo b/print/cups/distinfo
index a986a702cb18..7c710517534c 100644
--- a/print/cups/distinfo
+++ b/print/cups/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1613065122
-SHA256 (OpenPrinting-cups-v2.3.3op2_GH0.tar.gz) = 5d7dc1f05cde3d5c31d3a2b3b54d519ca74e42c1b25df1add9a1802cd13c65ad
-SIZE (OpenPrinting-cups-v2.3.3op2_GH0.tar.gz) = 8249533
+TIMESTAMP = 1651312674
+SHA256 (OpenPrinting-cups-v2.4.1_GH0.tar.gz) = df195c931349949293c832e1337527e7831e1225f567b60caf5d9c206c2bffdc
+SIZE (OpenPrinting-cups-v2.4.1_GH0.tar.gz) = 8160270
diff --git a/print/cups/files/patch-configure b/print/cups/files/patch-configure
index 331f120f9ce8..bb57aa88721e 100644
--- a/print/cups/files/patch-configure
+++ b/print/cups/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2020-04-27 18:04:29 UTC
+--- configure.orig 2022-01-27 11:11:42 UTC
+++ configure
-@@ -5775,7 +5775,6 @@ fi
+@@ -6793,7 +6793,6 @@ LIBS="$SAVELIBS"
fi
LIBS="$SAVELIBS"
@@ -8,26 +8,64 @@
DBUS_NOTIFIER=""
DBUS_NOTIFIERLIBS=""
-@@ -6590,7 +6589,6 @@ if test "$DSO" != ":"; then
- if test $exec_prefix != /usr; then
- DSOFLAGS="-Wl,-R$libdir $DSOFLAGS"
- LDFLAGS="$LDFLAGS -Wl,-R$libdir"
-- EXPORT_LDFLAGS="-Wl,-R$libdir"
- fi
- ;;
- linux* | gnu*)
-@@ -8560,13 +8558,7 @@ fi
- PAMLIBS="-lpam"
- fi
-
-- # Find the PAM configuration directory, if any...
-- for dir in /private/etc/pam.d /etc/pam.d; do
-- if test -d $dir; then
-- PAMDIR=$dir
-- break;
-- fi
-- done
-+ PAMDIR=/usr/local/etc/pam.d
- fi
-
- LIBS="$SAVELIBS"
+@@ -7807,7 +7806,6 @@ then :
+
+ DSOFLAGS="-Wl,-R$libdir $DSOFLAGS"
+ LDFLAGS="$LDFLAGS -Wl,-R$libdir"
+- EXPORT_LDFLAGS="-Wl,-R$libdir"
+
+ fi
+ ;; #(
+@@ -8124,7 +8122,6 @@ then :
+ if ac_fn_c_try_link "$LINENO"
+ then :
+
+- OPTIM="$OPTIM -fstack-protector-strong"
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+ printf "%s\n" "yes" >&6; }
+
+@@ -8149,7 +8146,6 @@ then :
+ if ac_fn_c_try_link "$LINENO"
+ then :
+
+- OPTIM="$OPTIM -fstack-protector"
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+ printf "%s\n" "yes" >&6; }
+
+@@ -8336,6 +8332,7 @@ case $host_os_name in #(
+ # glibc 2.8 and higher breaks peer credentials unless you
+ # define _GNU_SOURCE...
+ OPTIM="$OPTIM -D_GNU_SOURCE"
++esac
+
+ # The -z relro option is provided by the Linux linker command to
+ # make relocatable data read-only.
+@@ -8345,10 +8342,6 @@ fi
+ RELROFLAGS="-Wl,-z,relro,-z,now"
+
+ fi
+- ;; #(
+- *) :
+- ;;
+-esac
+
+
+ ac_fn_c_check_header_compile "$LINENO" "resolv.h" "ac_cv_header_resolv_h" "
+@@ -10191,16 +10184,7 @@ fi
+
+ fi
+
+- # Find the PAM configuration directory, if any...
+- for dir in /private/etc/pam.d /etc/pam.d; do
+- if test -d $dir
+-then :
+-
+- PAMDIR="$dir"
+- break;
+-
+-fi
+- done
++ PAMDIR=/usr/local/etc/pam.d
+
+ fi
+
diff --git a/print/cups/files/patch-scheduler_client.c b/print/cups/files/patch-scheduler_client.c
new file mode 100644
index 000000000000..1afe1c8fd3e6
--- /dev/null
+++ b/print/cups/files/patch-scheduler_client.c
@@ -0,0 +1,13 @@
+--- scheduler/client.c.orig 2022-01-27 11:11:42 UTC
++++ scheduler/client.c
+@@ -3514,8 +3514,8 @@ pipe_command(cupsd_client_t *con, /* I - Client connec
+ * Then execute the command...
+ */
+
+- if (cupsdStartProcess(command, argv, envp, infile, fds[1], CGIPipes[1],
+- -1, -1, root, DefaultProfile, NULL, &pid) < 0)
++ if (!cupsdStartProcess(command, argv, envp, infile, fds[1], CGIPipes[1],
++ -1, -1, root, DefaultProfile, NULL, &pid))
+ {
+ /*
+ * Error - can't fork!
diff --git a/print/cups/pkg-plist b/print/cups/pkg-plist
index 6ff0347f50c0..27c1b3b5af18 100644
--- a/print/cups/pkg-plist
+++ b/print/cups/pkg-plist
@@ -51,6 +51,7 @@ lib/libcups.so
lib/libcups.so.2
lib/libcupsimage.so
lib/libcupsimage.so.2
+libdata/pkgconfig/cups.pc
%%AVAHI%%libexec/cups/backend/dnssd
libexec/cups/backend/http
%%GNUTLS%%libexec/cups/backend/https
@@ -216,6 +217,7 @@ sbin/lpmove
%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-letter.test
%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-manual.test
%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-media-col.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-media-needed.test
%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-password.test
%%IPPTOOL%%%%DATADIR%%/ipptool/print-job.test
%%IPPTOOL%%%%DATADIR%%/ipptool/print-uri.test
@@ -251,6 +253,71 @@ sbin/lpmove
%%DATADIR%%/templates/classes-header.tmpl
%%DATADIR%%/templates/classes.tmpl
%%DATADIR%%/templates/command.tmpl
+%%NLS%%%%DATADIR%%/templates/da/add-class.tmpl
+%%NLS%%%%DATADIR%%/templates/da/add-printer.tmpl
+%%NLS%%%%DATADIR%%/templates/da/admin.tmpl
+%%NLS%%%%DATADIR%%/templates/da/choose-device.tmpl
+%%NLS%%%%DATADIR%%/templates/da/choose-make.tmpl
+%%NLS%%%%DATADIR%%/templates/da/choose-model.tmpl
+%%NLS%%%%DATADIR%%/templates/da/choose-serial.tmpl
+%%NLS%%%%DATADIR%%/templates/da/choose-uri.tmpl
+%%NLS%%%%DATADIR%%/templates/da/class-added.tmpl
+%%NLS%%%%DATADIR%%/templates/da/class-confirm.tmpl
+%%NLS%%%%DATADIR%%/templates/da/class-deleted.tmpl
+%%NLS%%%%DATADIR%%/templates/da/class-jobs-header.tmpl
+%%NLS%%%%DATADIR%%/templates/da/class-modified.tmpl
+%%NLS%%%%DATADIR%%/templates/da/class.tmpl
+%%NLS%%%%DATADIR%%/templates/da/classes-header.tmpl
+%%NLS%%%%DATADIR%%/templates/da/classes.tmpl
+%%NLS%%%%DATADIR%%/templates/da/command.tmpl
+%%NLS%%%%DATADIR%%/templates/da/edit-config.tmpl
+%%NLS%%%%DATADIR%%/templates/da/error-op.tmpl
+%%NLS%%%%DATADIR%%/templates/da/error.tmpl
+%%NLS%%%%DATADIR%%/templates/da/header.tmpl
+%%NLS%%%%DATADIR%%/templates/da/help-header.tmpl
+%%NLS%%%%DATADIR%%/templates/da/help-printable.tmpl
+%%NLS%%%%DATADIR%%/templates/da/help-trailer.tmpl
+%%NLS%%%%DATADIR%%/templates/da/job-cancel.tmpl
+%%NLS%%%%DATADIR%%/templates/da/job-hold.tmpl
+%%NLS%%%%DATADIR%%/templates/da/job-move.tmpl
+%%NLS%%%%DATADIR%%/templates/da/job-moved.tmpl
+%%NLS%%%%DATADIR%%/templates/da/job-release.tmpl
+%%NLS%%%%DATADIR%%/templates/da/job-restart.tmpl
+%%NLS%%%%DATADIR%%/templates/da/jobs-header.tmpl
+%%NLS%%%%DATADIR%%/templates/da/jobs.tmpl
+%%NLS%%%%DATADIR%%/templates/da/list-available-printers.tmpl
+%%NLS%%%%DATADIR%%/templates/da/modify-class.tmpl
+%%NLS%%%%DATADIR%%/templates/da/modify-printer.tmpl
+%%NLS%%%%DATADIR%%/templates/da/norestart.tmpl
+%%NLS%%%%DATADIR%%/templates/da/option-boolean.tmpl
+%%NLS%%%%DATADIR%%/templates/da/option-conflict.tmpl
+%%NLS%%%%DATADIR%%/templates/da/option-header.tmpl
+%%NLS%%%%DATADIR%%/templates/da/option-pickmany.tmpl
+%%NLS%%%%DATADIR%%/templates/da/option-pickone.tmpl
+%%NLS%%%%DATADIR%%/templates/da/option-trailer.tmpl
+%%NLS%%%%DATADIR%%/templates/da/pager.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-accept.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-added.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-cancel-jobs.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-configured.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-confirm.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-default.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-deleted.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-jobs-header.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-modified.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-reject.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-start.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer-stop.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printer.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printers-header.tmpl
+%%NLS%%%%DATADIR%%/templates/da/printers.tmpl
+%%NLS%%%%DATADIR%%/templates/da/restart.tmpl
+%%NLS%%%%DATADIR%%/templates/da/search.tmpl
+%%NLS%%%%DATADIR%%/templates/da/set-printer-options-header.tmpl
+%%NLS%%%%DATADIR%%/templates/da/set-printer-options-trailer.tmpl
+%%NLS%%%%DATADIR%%/templates/da/test-page.tmpl
+%%NLS%%%%DATADIR%%/templates/da/trailer.tmpl
+%%NLS%%%%DATADIR%%/templates/da/users.tmpl
%%NLS%%%%DATADIR%%/templates/de/add-class.tmpl
%%NLS%%%%DATADIR%%/templates/de/add-printer.tmpl
%%NLS%%%%DATADIR%%/templates/de/admin.tmpl
@@ -693,14 +760,15 @@ sbin/lpmove
%%DOCSDIR%%/apple-touch-icon.png
%%DOCSDIR%%/cups-printable.css
%%DOCSDIR%%/cups.css
+%%NLS%%%%DOCSDIR%%/da/index.html
%%NLS%%%%DOCSDIR%%/de/index.html
%%NLS%%%%DOCSDIR%%/es/index.html
+%%NLS%%%%DOCSDIR%%/fr/index.html
%%PORTDOCS%%%%DOCSDIR%%/help/accounting.html
%%PORTDOCS%%%%DOCSDIR%%/help/admin.html
%%PORTDOCS%%%%DOCSDIR%%/help/api-admin.html
%%PORTDOCS%%%%DOCSDIR%%/help/api-filter.html
%%PORTDOCS%%%%DOCSDIR%%/help/api-ppd.html
-%%PORTDOCS%%%%DOCSDIR%%/help/api-raster.html
%%PORTDOCS%%%%DOCSDIR%%/help/cgi.html
%%PORTDOCS%%%%DOCSDIR%%/help/cupspm.html
%%PORTDOCS%%%%DOCSDIR%%/help/encryption.html
@@ -768,22 +836,15 @@ sbin/lpmove
%%PORTDOCS%%%%DOCSDIR%%/help/spec-raster.html
%%PORTDOCS%%%%DOCSDIR%%/help/spec-stp.html
%%PORTDOCS%%%%DOCSDIR%%/help/translation.html
-%%PORTDOCS%%%%DOCSDIR%%/images/color-wheel.png
%%PORTDOCS%%%%DOCSDIR%%/images/cups-block-diagram.png
%%PORTDOCS%%%%DOCSDIR%%/images/cups-command-chain.png
-%%PORTDOCS%%%%DOCSDIR%%/images/cups-icon.png
%%PORTDOCS%%%%DOCSDIR%%/images/cups-postscript-chain.png
%%PORTDOCS%%%%DOCSDIR%%/images/cups-raster-chain.png
%%PORTDOCS%%%%DOCSDIR%%/images/cups.png
-%%DOCSDIR%%/images/generic.png
-%%PORTDOCS%%%%DOCSDIR%%/images/left.gif
%%PORTDOCS%%%%DOCSDIR%%/images/raster-organization.png
%%PORTDOCS%%%%DOCSDIR%%/images/raster.png
-%%PORTDOCS%%%%DOCSDIR%%/images/right.gif
%%PORTDOCS%%%%DOCSDIR%%/images/sample-image.png
-%%DOCSDIR%%/images/sel.gif
%%PORTDOCS%%%%DOCSDIR%%/images/smiley.jpg
-%%DOCSDIR%%/images/unsel.gif
%%DOCSDIR%%/images/wait.gif
%%DOCSDIR%%/index.html
%%NLS%%%%DOCSDIR%%/ja/index.html
@@ -796,6 +857,7 @@ sbin/lpmove
%%X11%%share/icons/hicolor/64x64/apps/cups.png
%%NLS%%share/locale/ca/cups_ca.po
%%NLS%%share/locale/cs/cups_cs.po
+%%NLS%%share/locale/da/cups_da.po
%%NLS%%share/locale/de/cups_de.po
%%NLS%%share/locale/en/cups_en.po
%%NLS%%share/locale/es/cups_es.po