aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-15 03:26:08 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-15 03:26:08 +0000
commit2ccbebaf07b3bca79b08db6bdc1c8f9dd354e9b6 (patch)
treeba19ecbbe199bee7b001f3ac81d89d00eab2ab3e
parent4586e77a75bf4c378897c0ce32dd87d61f1f627d (diff)
downloadports-2ccbebaf07b3bca79b08db6bdc1c8f9dd354e9b6.tar.gz
ports-2ccbebaf07b3bca79b08db6bdc1c8f9dd354e9b6.zip
This package builds a docset from sources in different formats. The
generated documents can be all nicely interlinked and to have the same look and feel. Currently it knows to handle input formats: * POD * HTML and knows to generate: * HTML * PS * PDF WWW: http://search.cpan.org/~stas/DocSet
Notes
Notes: svn path=/head/; revision=226142
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-DocSet/Makefile46
-rw-r--r--textproc/p5-DocSet/distinfo3
-rw-r--r--textproc/p5-DocSet/pkg-descr13
-rw-r--r--textproc/p5-DocSet/pkg-plist32
5 files changed, 95 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index bb8d6f6bdd4f..1f04bccaddb6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -393,6 +393,7 @@
SUBDIR += p5-Data-SpreadPagination
SUBDIR += p5-DelimMatch
SUBDIR += p5-Devel-TraceSAX
+ SUBDIR += p5-DocSet
SUBDIR += p5-Excel-Template
SUBDIR += p5-Filter-Simple
SUBDIR += p5-FormValidator-Simple
diff --git a/textproc/p5-DocSet/Makefile b/textproc/p5-DocSet/Makefile
new file mode 100644
index 000000000000..ac0c82f36e11
--- /dev/null
+++ b/textproc/p5-DocSet/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: p5-DocSet
+# Date created: 2009 January 14
+# Whom: pgollucci@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= DocSet
+PORTVERSION= 0.19
+CATEGORIES= textproc www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/S/ST/STAS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= Dcumentation projects builder in HTML, PS and PDF formats
+
+BUILD_DEPENDS= ${SITE_PERL}/Pod/POM.pm:${PORTSDIR}/textproc/p5-Pod-POM \
+ ${SITE_PERL}/${PERL_ARCH}/Template/Toolkit.pod:${PORTSDIR}/www/p5-Template-Toolkit
+
+MAN1= docset_build.1
+
+MAN3= DocSet.3 \
+ DocSet::5005compat.3 \
+ DocSet::Cache.3 \
+ DocSet::Config.3 \
+ DocSet::Doc.3 \
+ DocSet::Doc::Common.3 \
+ DocSet::Doc::HTML2HTML.3 \
+ DocSet::Doc::HTML2HTMLPS.3 \
+ DocSet::Doc::POD2HTML.3 \
+ DocSet::Doc::POD2HTMLPS.3 \
+ DocSet::Doc::Text2HTML.3 \
+ DocSet::DocSet.3 \
+ DocSet::DocSet::HTML.3 \
+ DocSet::NavigateCache.3 \
+ DocSet::RunTime.3 \
+ DocSet::Source::HTML.3 \
+ DocSet::Source::POD.3 \
+ DocSet::Source::Text.3 \
+ DocSet::DocSet::PSPDF.3 \
+ DocSet::Util.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-DocSet/distinfo b/textproc/p5-DocSet/distinfo
new file mode 100644
index 000000000000..a3da1da94c63
--- /dev/null
+++ b/textproc/p5-DocSet/distinfo
@@ -0,0 +1,3 @@
+MD5 (DocSet-0.19.tar.gz) = 2656d097a9f610f7614efc7900ecb6e2
+SHA256 (DocSet-0.19.tar.gz) = 2611697f3651e7e37147f0e41ff046d6e0c118f936797f09339f64d8aaef533f
+SIZE (DocSet-0.19.tar.gz) = 376584
diff --git a/textproc/p5-DocSet/pkg-descr b/textproc/p5-DocSet/pkg-descr
new file mode 100644
index 000000000000..94550cb28a62
--- /dev/null
+++ b/textproc/p5-DocSet/pkg-descr
@@ -0,0 +1,13 @@
+This package builds a docset from sources in different formats. The
+generated documents can be all nicely interlinked and to have the same
+look and feel.
+
+Currently it knows to handle input formats:
+
+ * POD * HTML
+
+and knows to generate:
+
+ * HTML * PS * PDF
+
+WWW: http://search.cpan.org/~stas/DocSet
diff --git a/textproc/p5-DocSet/pkg-plist b/textproc/p5-DocSet/pkg-plist
new file mode 100644
index 000000000000..c953a49da606
--- /dev/null
+++ b/textproc/p5-DocSet/pkg-plist
@@ -0,0 +1,32 @@
+bin/docset_build
+bin/html2ps
+%%SITE_PERL%%/DocSet/Doc/POD2HTMLPS.pm
+%%SITE_PERL%%/DocSet/Doc/POD2HTML.pm
+%%SITE_PERL%%/DocSet/Doc/Text2HTML.pm
+%%SITE_PERL%%/DocSet/Doc/HTML2HTMLPS.pm
+%%SITE_PERL%%/DocSet/Doc/HTML2HTML.pm
+%%SITE_PERL%%/DocSet/Doc/Common.pm
+%%SITE_PERL%%/DocSet/DocSet/HTML.pm
+%%SITE_PERL%%/DocSet/DocSet/PSPDF.pm
+%%SITE_PERL%%/DocSet/Source/Text.pm
+%%SITE_PERL%%/DocSet/Source/POD.pm
+%%SITE_PERL%%/DocSet/Source/HTML.pm
+%%SITE_PERL%%/DocSet/Template/Plugin
+%%SITE_PERL%%/DocSet/Template/Plugin/NavigateCache.pm
+%%SITE_PERL%%/DocSet/DocSet.pm
+%%SITE_PERL%%/DocSet/Config.pm
+%%SITE_PERL%%/DocSet/Cache.pm
+%%SITE_PERL%%/DocSet/Doc.pm
+%%SITE_PERL%%/DocSet.pm
+%%SITE_PERL%%/DocSet/NavigateCache.pm
+%%SITE_PERL%%/DocSet/5005compat.pm
+%%SITE_PERL%%/DocSet/Util.pm
+%%SITE_PERL%%/DocSet/RunTime.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DocSet/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DocSet
+@dirrm %%SITE_PERL%%/DocSet/Template/Plugin
+@dirrm %%SITE_PERL%%/DocSet/Template
+@dirrm %%SITE_PERL%%/DocSet/Source
+@dirrm %%SITE_PERL%%/DocSet/DocSet
+@dirrm %%SITE_PERL%%/DocSet/Doc
+@dirrm %%SITE_PERL%%/DocSet