aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2000-04-26 19:12:06 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2000-04-26 19:12:06 +0000
commit2cd3c80e2af07a2f42324d8e25c35e9fc0e0ce1e (patch)
treecff655e056a75a5647ef957ceb646b14030da0b5
parentce0b4a9bd144b4d34a162c5277393ca6e54e94f9 (diff)
downloadports-2cd3c80e2af07a2f42324d8e25c35e9fc0e0ce1e.tar.gz
ports-2cd3c80e2af07a2f42324d8e25c35e9fc0e0ce1e.zip
Import of port for dnscache, djb's set of DNS utilities, including a
caching name server.
Notes
Notes: svn path=/head/; revision=28026
-rw-r--r--dns/djbdns/Makefile23
-rw-r--r--dns/djbdns/distinfo1
-rw-r--r--dns/djbdns/pkg-comment1
-rw-r--r--dns/djbdns/pkg-descr23
-rw-r--r--dns/djbdns/pkg-plist29
-rw-r--r--net/djbdns/Makefile23
-rw-r--r--net/djbdns/distinfo1
-rw-r--r--net/djbdns/pkg-comment1
-rw-r--r--net/djbdns/pkg-descr23
-rw-r--r--net/djbdns/pkg-plist29
10 files changed, 154 insertions, 0 deletions
diff --git a/dns/djbdns/Makefile b/dns/djbdns/Makefile
new file mode 100644
index 000000000000..6fce82cc6bd0
--- /dev/null
+++ b/dns/djbdns/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: dnscache
+# Date created: 24 Jan 2000
+# Whom: Neil Blakey-Milner
+#
+# $FreeBSD$
+#
+
+PORTNAME= dnscache
+PORTVERSION= 1.00
+CATEGORIES= net
+MASTER_SITES= http://cr.yp.to/dnscache/
+
+MAINTAINER= nbm@FreeBSD.org
+
+ALL_TARGET= it
+INSTALL_TARGET= setup check
+
+post-patch:
+ @echo "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
+ @echo "${CC} -s" > ${WRKSRC}/conf-ld
+ @echo "${PREFIX}" > ${WRKSRC}/conf-home
+
+.include <bsd.port.mk>
diff --git a/dns/djbdns/distinfo b/dns/djbdns/distinfo
new file mode 100644
index 000000000000..3aeb8d35fa58
--- /dev/null
+++ b/dns/djbdns/distinfo
@@ -0,0 +1 @@
+MD5 (dnscache-1.00.tar.gz) = 67d51c5403c03f08d6ba8fff0108ab27
diff --git a/dns/djbdns/pkg-comment b/dns/djbdns/pkg-comment
new file mode 100644
index 000000000000..ec46f08f214b
--- /dev/null
+++ b/dns/djbdns/pkg-comment
@@ -0,0 +1 @@
+DNScache is a collection of secure and reliable DNS tools
diff --git a/dns/djbdns/pkg-descr b/dns/djbdns/pkg-descr
new file mode 100644
index 000000000000..742eae2701f5
--- /dev/null
+++ b/dns/djbdns/pkg-descr
@@ -0,0 +1,23 @@
+DNScache is a collection of Domain Name System tools. It includes
+several components:
+
+ * The dnscache program is a local DNS cache. It accepts recursive DNS
+ queries from local clients such as web browsers. It collects
+ responses from remote DNS servers.
+ * The tinydns program is a fast, UDP-only DNS server. It makes local
+ DNS information available to the Internet.
+ * The pickdns program is a load-balancing DNS server. It points
+ clients to a dynamic selection of IP addresses.
+ * The walldns program is a reverse DNS wall. It provides matching
+ reverse and forward records while hiding local host information.
+ * The dns library handles outgoing and incoming DNS packets. It can be
+ used by clients such as web browsers to look up host addresses, host
+ names, MX records, etc. It supports asynchronous resolution.
+ * The dnsfilter program is a parallel IP-address-to-host-name
+ converter.
+ * The dnsip, dnsipq, dnsname, dnstxt, and dnsmx programs are simple
+ command-line interfaces to DNS.
+ * The dnsq and dnstrace programs are DNS debugging tools.
+
+Documentation is at the website below,
+WWW: http://cr.yp.to/dnscache.html
diff --git a/dns/djbdns/pkg-plist b/dns/djbdns/pkg-plist
new file mode 100644
index 000000000000..755b744d5784
--- /dev/null
+++ b/dns/djbdns/pkg-plist
@@ -0,0 +1,29 @@
+etc/dnscache/VERSION
+etc/dnscache/@
+bin/dnscache-conf
+bin/tinydns-conf
+bin/walldns-conf
+bin/rbldns-conf
+bin/pickdns-conf
+bin/axfrdns-conf
+bin/dnscache
+bin/tinydns
+bin/walldns
+bin/rbldns
+bin/pickdns
+bin/axfrdns
+bin/tinydns-get
+bin/tinydns-data
+bin/tinydns-edit
+bin/rbldns-data
+bin/pickdns-data
+bin/axfr-get
+bin/dnsip
+bin/dnsipq
+bin/dnsname
+bin/dnstxt
+bin/dnsmx
+bin/dnsfilter
+bin/dnsq
+bin/random-ip
+bin/dnstrace
diff --git a/net/djbdns/Makefile b/net/djbdns/Makefile
new file mode 100644
index 000000000000..6fce82cc6bd0
--- /dev/null
+++ b/net/djbdns/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: dnscache
+# Date created: 24 Jan 2000
+# Whom: Neil Blakey-Milner
+#
+# $FreeBSD$
+#
+
+PORTNAME= dnscache
+PORTVERSION= 1.00
+CATEGORIES= net
+MASTER_SITES= http://cr.yp.to/dnscache/
+
+MAINTAINER= nbm@FreeBSD.org
+
+ALL_TARGET= it
+INSTALL_TARGET= setup check
+
+post-patch:
+ @echo "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
+ @echo "${CC} -s" > ${WRKSRC}/conf-ld
+ @echo "${PREFIX}" > ${WRKSRC}/conf-home
+
+.include <bsd.port.mk>
diff --git a/net/djbdns/distinfo b/net/djbdns/distinfo
new file mode 100644
index 000000000000..3aeb8d35fa58
--- /dev/null
+++ b/net/djbdns/distinfo
@@ -0,0 +1 @@
+MD5 (dnscache-1.00.tar.gz) = 67d51c5403c03f08d6ba8fff0108ab27
diff --git a/net/djbdns/pkg-comment b/net/djbdns/pkg-comment
new file mode 100644
index 000000000000..ec46f08f214b
--- /dev/null
+++ b/net/djbdns/pkg-comment
@@ -0,0 +1 @@
+DNScache is a collection of secure and reliable DNS tools
diff --git a/net/djbdns/pkg-descr b/net/djbdns/pkg-descr
new file mode 100644
index 000000000000..742eae2701f5
--- /dev/null
+++ b/net/djbdns/pkg-descr
@@ -0,0 +1,23 @@
+DNScache is a collection of Domain Name System tools. It includes
+several components:
+
+ * The dnscache program is a local DNS cache. It accepts recursive DNS
+ queries from local clients such as web browsers. It collects
+ responses from remote DNS servers.
+ * The tinydns program is a fast, UDP-only DNS server. It makes local
+ DNS information available to the Internet.
+ * The pickdns program is a load-balancing DNS server. It points
+ clients to a dynamic selection of IP addresses.
+ * The walldns program is a reverse DNS wall. It provides matching
+ reverse and forward records while hiding local host information.
+ * The dns library handles outgoing and incoming DNS packets. It can be
+ used by clients such as web browsers to look up host addresses, host
+ names, MX records, etc. It supports asynchronous resolution.
+ * The dnsfilter program is a parallel IP-address-to-host-name
+ converter.
+ * The dnsip, dnsipq, dnsname, dnstxt, and dnsmx programs are simple
+ command-line interfaces to DNS.
+ * The dnsq and dnstrace programs are DNS debugging tools.
+
+Documentation is at the website below,
+WWW: http://cr.yp.to/dnscache.html
diff --git a/net/djbdns/pkg-plist b/net/djbdns/pkg-plist
new file mode 100644
index 000000000000..755b744d5784
--- /dev/null
+++ b/net/djbdns/pkg-plist
@@ -0,0 +1,29 @@
+etc/dnscache/VERSION
+etc/dnscache/@
+bin/dnscache-conf
+bin/tinydns-conf
+bin/walldns-conf
+bin/rbldns-conf
+bin/pickdns-conf
+bin/axfrdns-conf
+bin/dnscache
+bin/tinydns
+bin/walldns
+bin/rbldns
+bin/pickdns
+bin/axfrdns
+bin/tinydns-get
+bin/tinydns-data
+bin/tinydns-edit
+bin/rbldns-data
+bin/pickdns-data
+bin/axfr-get
+bin/dnsip
+bin/dnsipq
+bin/dnsname
+bin/dnstxt
+bin/dnsmx
+bin/dnsfilter
+bin/dnsq
+bin/random-ip
+bin/dnstrace