aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-17 15:09:11 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-17 16:22:42 +0000
commit2ce2ca5b614344cfd29081d6acb1e3d80211fb1f (patch)
tree8c2b916b89f3c3bd8c49677e1de764827f784da1
parentcdf28617b49d6e4a3b049746d3754fbc36ef7892 (diff)
downloadports-2ce2ca5b614344cfd29081d6acb1e3d80211fb1f.tar.gz
ports-2ce2ca5b614344cfd29081d6acb1e3d80211fb1f.zip
biology/locarna: Fix tests
-rw-r--r--biology/locarna/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/biology/locarna/Makefile b/biology/locarna/Makefile
index 6c6c008b2384..4483c3792d59 100644
--- a/biology/locarna/Makefile
+++ b/biology/locarna/Makefile
@@ -14,15 +14,23 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libRNA.a:biology/viennarna
LIB_DEPENDS= libgmp.so:math/gmp \
libgsl.so:math/gsl \
libmpfr.so:math/mpfr
+TEST_DEPENDS= bash:shells/bash \
+ catch>0:devel/catch
USES= autoreconf gmake libtool perl5 pkgconfig shebangfix
USE_LDCONFIG= yes
-SHEBANG_FILES= src/Utils/locarna_mcc
+CXXFLAGS+= -I${LOCALBASE}/include/catch2 # use external catch
+
+SHEBANG_FILES= src/Utils/locarna_mcc \
+ src/Tests/test_programs
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-TEST_TARGET= check # tests fail to compile, see https://github.com/s-will/LocARNA/issues/80
+TEST_TARGET= check # one test fails, see https://github.com/s-will/LocARNA/issues/81
+
+post-extract: # unbundle catch, see https://github.com/s-will/LocARNA/issues/80
+ @${RM} ${WRKSRC}/src/Tests/catch.hpp
.include <bsd.port.mk>