aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-11-05 17:51:50 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-11-05 17:51:50 +0000
commit2d361fb615890c1dc45998b1f9cbc5e24da6f5ab (patch)
tree10ba2497fc30c13be2ca0ad775fd701f56084a87
parent60d424bebf55c602da985f12d880a5bf5a91df2b (diff)
downloadports-2d361fb615890c1dc45998b1f9cbc5e24da6f5ab.tar.gz
ports-2d361fb615890c1dc45998b1f9cbc5e24da6f5ab.zip
math/boolector: update 3.2.2 → 3.2.3
Reported by: portscout
-rw-r--r--math/boolector/Makefile17
-rw-r--r--math/boolector/distinfo6
-rw-r--r--math/boolector/files/patch-CMakeLists.txt29
3 files changed, 7 insertions, 45 deletions
diff --git a/math/boolector/Makefile b/math/boolector/Makefile
index 9bc42a36a4be..67612a6808f0 100644
--- a/math/boolector/Makefile
+++ b/math/boolector/Makefile
@@ -1,6 +1,5 @@
PORTNAME= boolector
-DISTVERSION= 3.2.2
-PORTREVISION= 2
+DISTVERSION= 3.2.3
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -19,7 +18,7 @@ LIB_DEPENDS= libbtor2parser.so:math/btor2tools \
libgmp.so:math/gmp
TEST_DEPENDS= bash:shells/bash
-USES= cmake:noninja compiler:c++11-lang cpe python:test # ninja fails to build tests
+USES= cmake:noninja,testing compiler:c++11-lang cpe python:test # ninja fails to build tests
CPE_VENDOR= boolector_project
@@ -28,16 +27,8 @@ GH_ACCOUNT= Boolector
CMAKE_ON= BUILD_SHARED_LIBS \
USE_GMP
+CMAKE_OFF= TESTING
+CMAKE_TESTING_ON= TESTING # tests fail to comile, see https://github.com/Boolector/boolector/issues/216
CMAKE_ARGS= -DCaDiCaL_INCLUDE_DIR=${LOCALBASE}/include
-do-test:
- @${FIND} ${WRKDIR} -name "*.py" \
- | ${XARGS} ${REINPLACE_CMD} -e 's|#!/usr/bin/env python$$|#!${PYTHON_CMD}| ; s|#!/usr/bin/env python3$$|#!${PYTHON_CMD}|'
- @${FIND} ${WRKDIR} -name "*.sh" \
- | ${XARGS} ${REINPLACE_CMD} 's|#!/bin/bash$$|#!${LOCALBASE}/bin/bash|'
- @cd ${BUILD_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTING:BOOL=ON ${CMAKE_SOURCE_PATH} && \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
-
.include <bsd.port.mk>
diff --git a/math/boolector/distinfo b/math/boolector/distinfo
index 3deeba981701..82ff383ccada 100644
--- a/math/boolector/distinfo
+++ b/math/boolector/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1622619758
-SHA256 (Boolector-boolector-3.2.2_GH0.tar.gz) = 9a5bdbacf83f2dd81dbed1e1a9f923766807470afa29b73729c947ae769d42b9
-SIZE (Boolector-boolector-3.2.2_GH0.tar.gz) = 1566009
+TIMESTAMP = 1699204051
+SHA256 (Boolector-boolector-3.2.3_GH0.tar.gz) = 9862134d33cb3ed0aeb6be3c9b154a4d0a90fd076f46ef97cf872813109cc5d9
+SIZE (Boolector-boolector-3.2.3_GH0.tar.gz) = 1566566
diff --git a/math/boolector/files/patch-CMakeLists.txt b/math/boolector/files/patch-CMakeLists.txt
deleted file mode 100644
index c638199bd96e..000000000000
--- a/math/boolector/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,29 +0,0 @@
---- CMakeLists.txt.orig 2019-12-02 22:50:20 UTC
-+++ CMakeLists.txt
-@@ -434,20 +434,24 @@ configure_file(
- # Regression tests
-
- # Get and configure google test
-+if (BUILD_TESTING)
- include(cmake/googletest.cmake)
- fetch_googletest(
- ${PROJECT_SOURCE_DIR}/cmake
- ${PROJECT_BINARY_DIR}/googletest
- )
-
--enable_testing()
-+ enable_testing()
-+endif(BUILD_TESTING)
-
- #-----------------------------------------------------------------------------#
- # Source directories
-
- include_directories(src ${CMAKE_CURRENT_BINARY_DIR}/src)
- add_subdirectory(src)
--add_subdirectory(test)
-+if (BUILD_TESTING)
-+ add_subdirectory(test)
-+endif(BUILD_TESTING)
- if(PYTHON)
- add_subdirectory(src/api/python)
- endif()