aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:46:23 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:08:05 +0000
commit2d5281fa08ca0c4e93212eacd4ec00cb482d11ee (patch)
tree2db8f428f00a43e1d7603b3eb6e6c625ea313c16
parent0cb0cdfa5e01bf9840819b6c464d77bed5a439fb (diff)
downloadports-2d5281fa08ca0c4e93212eacd4ec00cb482d11ee.tar.gz
ports-2d5281fa08ca0c4e93212eacd4ec00cb482d11ee.zip
www/py-django-contact-form: Remove PY_SETUPTOOLS
py-setuptools should be used rather than PY_SETUPTOOLS
-rw-r--r--www/py-django-contact-form/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/www/py-django-contact-form/Makefile b/www/py-django-contact-form/Makefile
index d8519816da89..9b67e9476a64 100644
--- a/www/py-django-contact-form/Makefile
+++ b/www/py-django-contact-form/Makefile
@@ -11,16 +11,15 @@ WWW= https://github.com/ubernostrum/django-contact-form
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PY_SETUPTOOLS} \
- ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=3.2:www/py-django32@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent pep517
-TEST_ENV= DJANGO_SETTINGS_MODULE=tests.settings PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
-
NO_ARCH= yes
+TEST_ENV= DJANGO_SETTINGS_MODULE=tests.settings PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
do-test:
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} runtests.py