aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-24 12:06:04 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-24 12:52:37 +0000
commit2dad9fa1b47a53a9d10ae3b934cb1c6f961600a8 (patch)
tree56110fa9858a5a5de4661c862c6ebbb1a70037e4
parent535e95b34caa282ca070c65f3b7df4056eccb77f (diff)
downloadports-2dad9fa1b47a53a9d10ae3b934cb1c6f961600a8.tar.gz
ports-2dad9fa1b47a53a9d10ae3b934cb1c6f961600a8.zip
textproc/sary: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--textproc/sary/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/textproc/sary/Makefile b/textproc/sary/Makefile
index 615b585bcdd2..94f45315f854 100644
--- a/textproc/sary/Makefile
+++ b/textproc/sary/Makefile
@@ -8,20 +8,29 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Suffix array library and tools, which provide fast full-text search
WWW= http://sary.sourceforge.net/index.html.en
-GNU_CONFIGURE= yes
USES= gnome libtool pathfix pkgconfig
USE_GNOME= glib20
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s|docs||g' ${WRKSRC}/Makefile.in
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsary.so
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/docs && ${FIND} . ! -name "*Makefile*" | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsary.so
.include <bsd.port.mk>