aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2023-04-30 14:15:20 +0000
committerThomas Zander <riggs@FreeBSD.org>2023-04-30 17:42:38 +0000
commit2df216b41d143e27e251b8d4447586a82e7554a5 (patch)
tree0a3a2a3ab3b0eacfc602b294b59f9cc71bdf52cb
parentdb697484784b30137639c6055b7f437e06d3ea94 (diff)
downloadports-2df216b41d143e27e251b8d4447586a82e7554a5.tar.gz
ports-2df216b41d143e27e251b8d4447586a82e7554a5.zip
multimedia/{mplayer|mencoder} Use ffmpeg4 instead of ffmpeg6
Details: Hopefully temporary workaround to fix a whole bunch of decoding problems with various ffmpeg codecs. PR: 270569
-rw-r--r--multimedia/mencoder/Makefile2
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer/Makefile.common7
-rw-r--r--multimedia/mplayer/files/patch-Makefile2
4 files changed, 8 insertions, 5 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index 44826e691f02..7f6b82aa9894 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mencoder
PORTVERSION= ${MPLAYER_PORT_VERSION}.${MPLAYER_SNAPSHOT_DATE:S/-//g}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia audio
MAINTAINER= riggs@FreeBSD.org
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 3e57d404d1f6..35ae0eca59ca 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}.${MPLAYER_SNAPSHOT_DATE:S/-//g}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia audio
MAINTAINER= riggs@FreeBSD.org
diff --git a/multimedia/mplayer/Makefile.common b/multimedia/mplayer/Makefile.common
index ec9ce778dea5..7638a799c473 100644
--- a/multimedia/mplayer/Makefile.common
+++ b/multimedia/mplayer/Makefile.common
@@ -12,7 +12,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libpng.so:graphics/png \
- libavcodec.so:multimedia/ffmpeg \
+ libavcodec.so.58:multimedia/ffmpeg4 \
libfreetype.so:print/freetype2
BUILD_DEPENDS= ${BUILD_DEPENDS_${ARCH}}
@@ -21,7 +21,8 @@ BUILD_DEPENDS_i386= as:devel/binutils
USES= compiler:c11 gmake iconv ncurses tar:xz
NOPRECIOUSMAKEVARS= yes # ARCH
HAS_CONFIGURE= yes
-CONFIGURE_ENV= TMPDIR="${WRKSRC}"
+CONFIGURE_ENV+= TMPDIR="${WRKSRC}" \
+ PKG_CONFIG_PATH="${LOCALBASE}/ffmpeg4/libdata/pkgconfig"
CONFIGURE_ARGS= --cc="${CC}" \
--host-cc="${CC}" \
--as="${AS}" \
@@ -50,6 +51,8 @@ CONFIGURE_ARGS= --cc="${CC}" \
--disable-real \
--yasm=''
+MAKE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/ffmpeg4/libdata/pkgconfig"
+
common-post-patch:
@${REINPLACE_CMD} \
-e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|; \
diff --git a/multimedia/mplayer/files/patch-Makefile b/multimedia/mplayer/files/patch-Makefile
index fe4d63a722ef..0321c42a4b80 100644
--- a/multimedia/mplayer/files/patch-Makefile
+++ b/multimedia/mplayer/files/patch-Makefile
@@ -5,7 +5,7 @@
codec-cfg$(EXESUF) codecs2html$(EXESUF): HOSTCFLAGS := $(HOSTCFLAGS) -DCODECS2HTML
codec-cfg$(EXESUF) codec-cfg-test$(EXESUF) codecs2html$(EXESUF): codec-cfg.c codec-cfg.h help_mp.h
- $(HOST_CC) $(HOSTCFLAGS) -o $@ $<
-+ $(HOST_CC) $(HOSTCFLAGS) -I%%LOCALBASE%%/include -o $@ $<
++ $(HOST_CC) $(HOSTCFLAGS) -I%%LOCALBASE%%/ffmpeg4/include -o $@ $<
codecs.conf.h: codec-cfg$(EXESUF) etc/codecs.conf
./$^ > $@