aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2011-01-11 20:23:21 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2011-01-11 20:23:21 +0000
commit2e3f006ec7c7fcb6b7de86af59bc16487ce1a294 (patch)
treecefe70b5e8fade38f1e418e217ad217b2f4081ae
parent78a4d863bcd9f18c69ed2a456beaa0fec37dd647 (diff)
downloadports-2e3f006ec7c7fcb6b7de86af59bc16487ce1a294.tar.gz
ports-2e3f006ec7c7fcb6b7de86af59bc16487ce1a294.zip
Add patch that handles app being run with stdout disconnected
Submitted by: kmoore Feature safe: yes Sponsored by: iXsystems
Notes
Notes: svn path=/head/; revision=267671
-rw-r--r--net/smb4k-kde4/Makefile2
-rw-r--r--net/smb4k-kde4/files/patch-core-smb4kwalletmanager.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/smb4k-kde4/Makefile b/net/smb4k-kde4/Makefile
index 7a88155cf3fe..9063c5256270 100644
--- a/net/smb4k-kde4/Makefile
+++ b/net/smb4k-kde4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= smb4k-kde4
PORTVERSION= 0.10.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net kde
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= smb4k
diff --git a/net/smb4k-kde4/files/patch-core-smb4kwalletmanager.cpp b/net/smb4k-kde4/files/patch-core-smb4kwalletmanager.cpp
new file mode 100644
index 000000000000..3a081620dbfc
--- /dev/null
+++ b/net/smb4k-kde4/files/patch-core-smb4kwalletmanager.cpp
@@ -0,0 +1,11 @@
+--- core/smb4kwalletmanager.cpp.o 2011-01-11 11:27:23.214191514 -0500
++++ core/smb4kwalletmanager.cpp 2011-01-11 11:32:13.773985643 -0500
+@@ -752,7 +752,7 @@
+ QString password;
+
+ KProcess proc;
+- proc.setShellCommand( Smb4KSettings::smbutil()+" crypt "+authInfo->password() );
++ proc.setShellCommand( Smb4KSettings::smbutil()+" crypt \""+authInfo->password() + "\"" );
+ proc.setOutputChannelMode( KProcess::SeparateChannels );
+
+ switch ( proc.execute() )