aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2023-10-10 22:42:46 +0000
committerCharlie Li <vishwin@FreeBSD.org>2023-10-10 22:42:46 +0000
commit2e6efdc0e608cbab4e178ba727c892b7ba751c67 (patch)
tree4e1c3dc391b8bafed318b2c9dced522c2ce893ac
parent44534cba84a60538773c64c6b11c891bc29d0f56 (diff)
downloadports-2e6efdc0e608cbab4e178ba727c892b7ba751c67.tar.gz
ports-2e6efdc0e608cbab4e178ba727c892b7ba751c67.zip
benchmarks/py-asv-runner: add
Core Python benchmark code for benchmarks/py-asv
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/py-asv-runner/Makefile22
-rw-r--r--benchmarks/py-asv-runner/distinfo3
-rw-r--r--benchmarks/py-asv-runner/pkg-descr3
4 files changed, 29 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index ce7794570a77..4ecebc032b32 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -75,6 +75,7 @@
SUBDIR += polygraph
SUBDIR += postal
SUBDIR += postmark
+ SUBDIR += py-asv-runner
SUBDIR += py-locust
SUBDIR += py-naarad
SUBDIR += py-throughpy
diff --git a/benchmarks/py-asv-runner/Makefile b/benchmarks/py-asv-runner/Makefile
new file mode 100644
index 000000000000..027fd98913fa
--- /dev/null
+++ b/benchmarks/py-asv-runner/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= asv-runner
+DISTVERSION= 0.1.0
+CATEGORIES= benchmarks python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/g}-${DISTVERSION}
+
+MAINTAINER= vishwin@FreeBSD.org
+COMMENT= Core pure python benchmarking for asv
+WWW= https://asv.readthedocs.io/projects/asv-runner/
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pdm-backend>0:devel/py-pdm-backend@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/benchmarks/py-asv-runner/distinfo b/benchmarks/py-asv-runner/distinfo
new file mode 100644
index 000000000000..d0583e575e55
--- /dev/null
+++ b/benchmarks/py-asv-runner/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1696911824
+SHA256 (asv_runner-0.1.0.tar.gz) = 686c2e902a27491649b9ebd8e1f49659c37c92116f312974fdbb6fff1efa7122
+SIZE (asv_runner-0.1.0.tar.gz) = 38737
diff --git a/benchmarks/py-asv-runner/pkg-descr b/benchmarks/py-asv-runner/pkg-descr
new file mode 100644
index 000000000000..5e768807807d
--- /dev/null
+++ b/benchmarks/py-asv-runner/pkg-descr
@@ -0,0 +1,3 @@
+ASV Runner is the pure Python core of ASV (Airspeed-Velocity). ASV
+Runner provides essential functionality for benchmarking Python
+packages with ease and efficiency.