aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-09-12 09:15:44 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-09-12 15:16:35 +0000
commit2e7ad1de91e6f200eec6311a12cd15050b1cdcbd (patch)
treeb266520de6535004422d5ccc3fb64d81e2fcd8dc
parent3270b2a7dbb323afbb387c18b4d71cf98ce01ec1 (diff)
downloadports-2e7ad1de91e6f200eec6311a12cd15050b1cdcbd.tar.gz
ports-2e7ad1de91e6f200eec6311a12cd15050b1cdcbd.zip
www/choqok: move webkit behind default-off option
qt5-webkit will be removed by the end of the year.
-rw-r--r--www/choqok/Makefile12
-rw-r--r--www/choqok/pkg-plist8
2 files changed, 13 insertions, 7 deletions
diff --git a/www/choqok/Makefile b/www/choqok/Makefile
index 91db4718365a..74ab9847e269 100644
--- a/www/choqok/Makefile
+++ b/www/choqok/Makefile
@@ -1,6 +1,6 @@
PORTNAME= choqok
DISTVERSION= 1.7.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION:R}/src
DIST_SUBDIR= KDE/${PORTNAME}
@@ -20,15 +20,21 @@ USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig qca qt:5 \
tar:xz xorg
USE_KDE= attica auth bookmarks codecs completion config configwidgets \
coreaddons doctools emoticons globalaccel guiaddons i18n \
- itemviews jobwidgets kcmutils kdewebkit kio notifications \
+ itemviews jobwidgets kcmutils kio notifications \
notifyconfig parts purpose service solid sonnet textwidgets \
wallet widgetsaddons windowsystem xmlgui \
ecm:build \
kded:run
-USE_QT= concurrent core dbus gui network networkauth webkit widgets \
+USE_QT= concurrent core dbus gui network networkauth widgets \
xml \
buildtools:build qmake:build
USE_XORG= x11
USE_LDCONFIG= yes
+OPTIONS_DEFINE= WEBKIT
+OPTIONS_SUB= yes
+WEBKIT_DESC= Use obsolete qt5-webkit to build Browser Plugin
+WEBKIT_USE= KDE=kdewebkit QT5=webkit
+WEBKIT_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_KF5WebKit
+
.include <bsd.port.mk>
diff --git a/www/choqok/pkg-plist b/www/choqok/pkg-plist
index 182171acfb67..a0403960fe46 100644
--- a/www/choqok/pkg-plist
+++ b/www/choqok/pkg-plist
@@ -102,7 +102,7 @@ lib/libtwitterapihelper.so.1.3.0
%%QT_PLUGINDIR%%/kcm_choqok_tinyarro_ws.so
%%QT_PLUGINDIR%%/kcm_choqok_twitgoo.so
%%QT_PLUGINDIR%%/kcm_choqok_yourls.so
-%%QT_PLUGINDIR%%/kf5/parts/konqchoqokplugin.so
+%%WEBKIT%%%%QT_PLUGINDIR%%/kf5/parts/konqchoqokplugin.so
%%QT_PLUGINDIR%%/kf5/purpose/purposeplugin.so
share/applications/org.kde.choqok.desktop
%%DATADIR%%/images/splash_screen.png
@@ -217,7 +217,7 @@ share/icons/hicolor/64x64/apps/twitgoo_uploader.png
share/icons/hicolor/scalable/apps/choqok_offline.svgz
share/icons/hicolor/scalable/apps/choqok.svgz
share/knotifications5/choqok.notifyrc
-share/kservices5/ServiceMenus/choqok_share.desktop
+%%WEBKIT%%share/kservices5/ServiceMenus/choqok_share.desktop
share/kservices5/choqok_accountsconfig.desktop
share/kservices5/choqok_appearanceconfig.desktop
share/kservices5/choqok_behaviorconfig.desktop
@@ -260,7 +260,7 @@ share/kservices5/choqok_ur1_ca.desktop
share/kservices5/choqok_videopreview.desktop
share/kservices5/choqok_yourls.desktop
share/kservices5/choqok_yourls_config.desktop
-share/kservices5/konqchoqok.desktop
+%%WEBKIT%%share/kservices5/konqchoqok.desktop
share/kservicetypes5/choqokplugin.desktop
share/kservicetypes5/choqokshortenerplugin.desktop
share/kservicetypes5/choqokuploaderplugin.desktop
@@ -269,7 +269,7 @@ share/kxmlgui5/choqok_filter/filterui.rc
share/kxmlgui5/choqok_nowlistening/nowlisteningui.rc
share/kxmlgui5/choqok_quickfilter/quickfilterui.rc
share/kxmlgui5/choqok_searchaction/searchactionui.rc
-share/kxmlgui5/konqchoqokplugin/konqchoqok.rc
+%%WEBKIT%%share/kxmlgui5/konqchoqokplugin/konqchoqok.rc
share/locale/ar/LC_MESSAGES/choqok.mo
share/locale/bg/LC_MESSAGES/choqok.mo
share/locale/bs/LC_MESSAGES/choqok.mo