aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-12-20 19:34:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-12-20 19:34:11 +0000
commit2e9911f602efb133285d096c6955cad324328edb (patch)
treebac7657b7c809f134de666e3748eb52500cad676
parent0a89159f7aec94ccc7a0d529aac87c2ddccfa17c (diff)
downloadports-2e9911f602efb133285d096c6955cad324328edb.tar.gz
ports-2e9911f602efb133285d096c6955cad324328edb.zip
Switch from swig 2.0 to swig 3.0
Notes
Notes: svn path=/head/; revision=456845
-rw-r--r--audio/libgpod/Makefile4
-rw-r--r--biology/libsbml/Makefile6
-rw-r--r--comms/gnuradio/Makefile6
-rw-r--r--comms/owfs/Makefile4
-rw-r--r--devel/libftdi1/Makefile3
-rw-r--r--devel/py-instant/Makefile3
-rw-r--r--dns/ldns/Makefile3
-rw-r--r--emulators/gem5/Makefile4
-rw-r--r--graphics/hugin/Makefile3
-rw-r--r--graphics/mapserver/Makefile6
-rw-r--r--math/fityk/Makefile3
-rw-r--r--math/ufc/Makefile2
-rw-r--r--textproc/zorba/Makefile3
13 files changed, 30 insertions, 20 deletions
diff --git a/audio/libgpod/Makefile b/audio/libgpod/Makefile
index 28c0d74c3351..d02f7e724b0f 100644
--- a/audio/libgpod/Makefile
+++ b/audio/libgpod/Makefile
@@ -38,12 +38,12 @@ IMOBILE_CONFIGURE_WITH= libimobiledevice
MONO_USE= GNOME=gtksharp20
MONO_CONFIGURE_WITH= mono
-PYTHON_BUILD_DEPENDS= swig2.0:devel/swig20 \
+PYTHON_BUILD_DEPENDS= swig3.0:devel/swig30 \
${PYTHON_PKGNAMEPREFIX}mutagen>0:audio/py-mutagen
PYTHON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>0:audio/py-mutagen
PYTHON_USE= GNOME=pygobject
PYTHON_USES= python:2.7
-PYTHON_CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig2.0"
+PYTHON_CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig3.0"
PYTHON_CONFIGURE_WITH= python
PORTDOCS= ChangeLog NEWS README*
diff --git a/biology/libsbml/Makefile b/biology/libsbml/Makefile
index 4ef28a036795..ab86a8745c83 100644
--- a/biology/libsbml/Makefile
+++ b/biology/libsbml/Makefile
@@ -26,16 +26,18 @@ OPTIONS_DEFINE= EXAMPLES PYTHON RUBY
OPTIONS_SUB= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-PYTHON_BUILD_DEPENDS= swig2.0:devel/swig20
+PYTHON_BUILD_DEPENDS= swig3.0:devel/swig30
PYTHON_USES= python:2.7
PYTHON_CMAKE_ON= -DWITH_PYTHON:BOOL=ON \
-DPYTHON_INCLUDE_DIR:STRING="${PYTHON_INCLUDEDIR}" \
-DPYTHON_LIBRARY:STRING="${PYTHONBASE}/lib/lib${PYTHON_VERSION}.so" \
-DPYTHON_EXECUTABLE:STRING="${PYTHON_CMD}"
+PYTHON_BINARY_ALIAS= swig=swig3.0
-RUBY_BUILD_DEPENDS= swig2.0:devel/swig20
+RUBY_BUILD_DEPENDS= swig3.0:devel/swig30
RUBY_USE= ruby=yes
RUBY_CMAKE_ON= -DWITH_RUBY:BOOL=ON
+RUBY_BINARY_ALIAS= swig=swig3.0
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index e72287beabfa..603900617ab4 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gnuradio
PORTVERSION= 3.7.10.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= comms astro hamradio
MASTER_SITES= http://gnuradio.org/releases/gnuradio/ \
LOCAL/db
@@ -13,7 +13,7 @@ COMMENT= Amateur Radio Software defined radio
LICENSE= GPLv3
BUILD_DEPENDS= sdl-config:devel/sdl12 \
- swig2.0:devel/swig20 \
+ swig3.0:devel/swig30 \
cheetah:devel/py-cheetah@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
xdg-open:devel/xdg-utils \
@@ -47,7 +47,7 @@ USES= cmake:outsource compiler:c11 iconv perl5 pkgconfig pyqt:4 python:2.7 sheb
SHEBANG_FILES= grc/scripts/freedesktop/grc_setup_freedesktop.in \
gnuradio-runtime/python/gnuradio/ctrlport/gr-ctrlport-monitor \
gnuradio-runtime/python/gnuradio/ctrlport/gr-perf-monitorx
-CMAKE_ARGS+= -DSWIG_EXECUTABLE:STRING="${LOCALBASE}/bin/swig2.0"\
+CMAKE_ARGS+= -DSWIG_EXECUTABLE:STRING="${LOCALBASE}/bin/swig3.0"\
-DICONV_PREFIX:STRING="${ICONV_PREFIX}" \
-DICONV_LIB:STRING="X${ICONV_LIB}" \
-DENABLE_GR_CTRLPORT="YES" \
diff --git a/comms/owfs/Makefile b/comms/owfs/Makefile
index 26731bdee748..ef5d4eb2b88f 100644
--- a/comms/owfs/Makefile
+++ b/comms/owfs/Makefile
@@ -100,8 +100,8 @@ PLIST_SUB+= OWNETPYTHON="@comment "
# If Perl, Python or PHP is requested, enable SWIG
.if ${PORT_OPTIONS:MOWPERL} || ${PORT_OPTIONS:MOWPYTHON} || ${PORT_OPTIONS:MOWPHP}
-BUILD_DEPENDS+= ${LOCALBASE}/bin/swig2.0:devel/swig20
-CONFIGURE_ARGS+= --enable-swig SWIG=${LOCALBASE}/bin/swig2.0
+BUILD_DEPENDS+= swig3.0:devel/swig30
+CONFIGURE_ARGS+= --enable-swig SWIG=${LOCALBASE}/bin/swig3.0
.else
CONFIGURE_ARGS+= --disable-swig
.endif
diff --git a/devel/libftdi1/Makefile b/devel/libftdi1/Makefile
index 69bebb442e89..83addbff0c7d 100644
--- a/devel/libftdi1/Makefile
+++ b/devel/libftdi1/Makefile
@@ -44,7 +44,8 @@ CMAKE_ARGS+= -DEXAMPLES:BOOL=false
.if ${PORT_OPTIONS:MPYTHON}
USES+= python:2
CMAKE_ARGS+= -DPYTHON_BINDINGS:BOOL=true
-BUILD_DEPENDS+= swig2.0:devel/swig20
+BUILD_DEPENDS+= swig3.0:devel/swig30
+BINARY_ALIAS= swig=swig3.0
.else
CMAKE_ARGS+= -DPYTHON_BINDINGS:BOOL=false
.endif
diff --git a/devel/py-instant/Makefile b/devel/py-instant/Makefile
index 3a141f307b9f..30ba4105894f 100644
--- a/devel/py-instant/Makefile
+++ b/devel/py-instant/Makefile
@@ -3,6 +3,7 @@
PORTNAME= instant
PORTVERSION= ${MMVERSION}.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= https://launchpad.net/${PORTNAME}/${MMVERSION}.x/${PORTVERSION}/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,7 @@ COMMENT= Python module for instant inlining of C and C++ code in Python
LICENSE= LGPL3
-RUN_DEPENDS= swig2.0:devel/swig20
+RUN_DEPENDS= swig3.0:devel/swig30
USES= python:2
USE_PYTHON= distutils
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index 0bcb5788e4f9..b260226fb940 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -66,8 +66,9 @@ INSTALL_TARGET= install-pyldns
CONFIGURE_ARGS+=--with-pyldns
LIB_DEPENDS+= libldns.so:dns/ldns
-BUILD_DEPENDS+= swig2.0:devel/swig20
+BUILD_DEPENDS+= swig3.0:devel/swig30
CFLAGS+= -I${OPENSSLINC}
+BINARY_ALIAS= swig=swig3.0
post-patch:
@${REINPLACE_CMD} \
diff --git a/emulators/gem5/Makefile b/emulators/gem5/Makefile
index 912d83f53bb8..cc23abec5237 100644
--- a/emulators/gem5/Makefile
+++ b/emulators/gem5/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= emulators
MAINTAINER= vg@FreeBSD.org
COMMENT= gem5 Simulator System
-BUILD_DEPENDS= swig2.0:devel/swig20 \
+BUILD_DEPENDS= swig3.0:devel/swig30 \
scons:devel/scons
BROKEN_armv6= fails to link: undefined reference to HDLcd::BUS_OPTIONS_RESETV
@@ -21,7 +21,7 @@ DATE= 20140422
USE_GITHUB= yes
GH_ACCOUNT= CTSRD-CHERI
GH_TAGNAME= 99d65cc
-SWIG_BIN= swig2.0
+SWIG_BIN= swig3.0
USES= gmake
.include <bsd.port.pre.mk>
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 77eb5b5681ed..acdc453923ae 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -49,7 +49,8 @@ AUTOPANOSIFTC_RUN_DEPENDS= autopano:graphics/autopano-sift-c
PYTHON_DESC= Python Scripting Interface
PYTHON_USES= python:2.7
-PYTHON_BUILD_DEPENDS= swig2.0:devel/swig20
+PYTHON_BUILD_DEPENDS= swig3.0:devel/swig30
+PYTHON_BINARY_ALIAS= swig=swig3.0
PYTHON_CMAKE_ON= -DBUILD_HSI=ON
PYTHON_CMAKE_OFF= -DBUILD_HSI=OFF
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index e216c9edee31..e67b2f3bbbd0 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -44,7 +44,8 @@ WCS_DESC= WCS Server support
.if ${PORT_OPTIONS:MPYTHON}
USES+= python:2
-BUILD_DEPENDS+= swig2.0:devel/swig20
+BUILD_DEPENDS+= swig3.0:devel/swig30
+BINARY_ALIAS= swig=swig3.0
CMAKE_ARGS+= -DWITH_PYTHON=yes
PLIST_SUB+= PYTHON=""
MAP_EGG= MapScript-${PORTVERSION}-${PYTHON_VERSION:S/thon//}
@@ -137,9 +138,10 @@ PLIST_SUB+= PHP="@comment "
.if ${PORT_OPTIONS:MPERL}
USES+= perl5
-BUILD_DEPENDS= ${LOCALBASE}/bin/swig2.0:devel/swig20
+BUILD_DEPENDS= swig3.0:devel/swig30
CMAKE_ARGS+= -DWITH_PERL=1
PLIST_SUB+= PERL=""
+BINARY_ALIAS= swig=swig3.0
.else
CMAKE_ARGS+= -DWITH_PERL=0
PLIST_SUB+= PERL="@comment "
diff --git a/math/fityk/Makefile b/math/fityk/Makefile
index 5c7e64843ffb..d7a9ce61941a 100644
--- a/math/fityk/Makefile
+++ b/math/fityk/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= boost-libs>=1.35:devel/boost-libs \
- swig2.0:devel/swig20 \
+ swig3.0:devel/swig30 \
gnuplot:math/gnuplot
RUN_DEPENDS= gnuplot:math/gnuplot
@@ -32,6 +32,7 @@ WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
+BINARY_ALIAS= swig=swig3.0
CFLAGS+= -D_GNU_SOURCE
CPPFLAGS+= -I${WRKDIR}/xylib-1.4 \
diff --git a/math/ufc/Makefile b/math/ufc/Makefile
index 4179b56e57a2..2346cb92b818 100644
--- a/math/ufc/Makefile
+++ b/math/ufc/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://launchpad.net/${PORTNAME}/${MMVERSION}.x/${PORTVERSION}/+do
MAINTAINER= bacon4000@gmail.com
COMMENT= Unified framework for finite element assembly
-BUILD_DEPENDS= swig2.0:devel/swig20
+BUILD_DEPENDS= swig3.0:devel/swig30
LIB_DEPENDS= libboost_math_c99.so:devel/boost-libs
# LICENSE= public domain
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index 3c2117bf9f17..6b3adc673540 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -82,7 +82,8 @@ CMAKE_ARGS+= -DJAVA_LIBDIR:PATH=${JAVALIBDIR}
.endif
.if defined(WITH_SWIG)
-BUILD_DEPENDS+= swig2.0:devel/swig20
+BUILD_DEPENDS+= swig3.0:devel/swig30
+BINARY_ALIAS= swig=swig3.0
.endif
post-patch: