aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-12 08:37:16 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-12 08:42:39 +0000
commit2e9e32cb83ff0ab900c891f4ebd81443b999fcaa (patch)
tree1a36249c3c5826488950df669b680248dcd1feaf
parent1101074b62d00b4ec6118622c450e431bcf363a9 (diff)
downloadports-2e9e32cb83ff0ab900c891f4ebd81443b999fcaa.tar.gz
ports-2e9e32cb83ff0ab900c891f4ebd81443b999fcaa.zip
devel/mimalloc: fix install wiht WITH_DEBUG
If WITH_DEBUG is defined shared objects are installed with -debug suffix. This not only fails to install but would also break consumers. Patch CMakeLists.txt accordingly. Reported by: koobs (via irc) (cherry picked from commit 2cba286258af03d7880db549f64678919040c85c)
-rw-r--r--devel/mimalloc/files/patch-CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/devel/mimalloc/files/patch-CMakeLists.txt b/devel/mimalloc/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..7c9fce5c9d33
--- /dev/null
+++ b/devel/mimalloc/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2022-02-15 00:44:33 UTC
++++ CMakeLists.txt
+@@ -258,8 +258,8 @@ else()
+ endif()
+
+ string(TOLOWER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE_LC)
+-if(NOT(CMAKE_BUILD_TYPE_LC MATCHES "^(release|relwithdebinfo|minsizerel|none)$"))
+- set(mi_basename "${mi_basename}-${CMAKE_BUILD_TYPE_LC}") #append build type (e.g. -debug) if not a release version
++if(NOT(CMAKE_BUILD_TYPE_LC MATCHES "^(debug|release|relwithdebinfo|minsizerel|none)$"))
++ set(mi_basename "${mi_basename}-${CMAKE_BUILD_TYPE_LC}") #append build type if not a release version or debug
+ endif()
+ if(MI_BUILD_SHARED)
+ list(APPEND mi_build_targets "shared")